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AÇIKLAMALAR 
KOD 482BK0082 
ALAN Bilişim Teknolojileri 
DAL/MESLEK Web Programcılığı 
MODÜLÜN ADI Animasyon Düzenleme 1 
MODÜLÜN TANIMI Bilgisayar ortamında ihtiyaca uygun canlandırmaların 

(animasyon) nasıl hazırlanacağını anlatan öğrenme 
materyalidir. 

SÜRE 40/32 
ÖN KOŞUL  
YETERLİK Web sayfaları için animasyonlar hazırlamak  

MODÜLÜN AMACI 

Genel Amaç 
Bu modül ile animasyon düzenleme yazılımlarını 

kullanarak animasyon hazırlama işlemlerini yapabileceksiniz. 
Amaçlar 

1. Çalışma alanını tanıyacaksınız ve düzenleyeceksiniz. 
2. Grafik oluşturabileceksiniz. 
3. Metin işlemlerini gerçekleştirebileceksiniz. 
4. Sembol işlemlerini gerçekleştirebileceksiniz. 
5. Animasyon çeşitlerini ve özelliklerini tanıyarak 

animasyonlar oluşturabileceksiniz. 
6. Temel etkileşim işlemlerini gerçekleştirebileceksiniz. 
7. Ses ve video işlemlerini gerçekleştirebileceksiniz. 
8. Ekranları kullanabileceksiniz. 

EĞİTİM ÖĞRETİM 
ORTAMLARI VE 
DONANIMLARI 

Ortam 
Bilgisayar canlandırmaları hazırlamanıza uygun 

bilgisayar laboratuvarı ve kendi kendinize ya da grupla 
çalışabileceğiniz tüm ortamlar. 
Donanım ve Yazılım 
Bilgisayar, animasyon hazırlama yazılımı, internet tarayıcı 
yazılımı 

ÖLÇME VE 
DEĞERLENDİRME 

Modül içinde ve sonunda verilen öğretici sorularla 
edindiğiniz bilgileri pekiştirecek, uygulama örneklerini ve 
testleri gerekli süre içinde tamamlayarak etkili öğrenmeyi 
gerçekleştireceksiniz. Sırasıyla araştırma yaparak, grup 
çalışmalarına katılarak ve en son aşamada alan 
öğretmenlerine danışarak ölçme ve değerlendirme 
uygulamalarını gerçekleştiriniz. 
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GİRİŞ 
  

Sevgili Öğrenci, 

1989 senesinde bir belge paylaşım formatı olan HTML dili duyurulduğunda oldukça 
basit yapıdaydı ve yalnızca belge içerisindeki yazıları düzenleme özellikleri (yazı tipi, 
paragraf biçimleri, vb.) içermekteydi. HTML dili internet üzerinden belge paylaşım dili 
olarak geliştirilmiş dolayısıyla da web sayfalarının temelini oluşturmuştur. 

İlerleyen yıllarla birlikte web sayfaları da görsel yönden zenginleşmeye ve yalnızca 
metin tabanlı uygulamaları barındıran bir ortam olmaktan çıkmıştır. 1990’lı yılların 
ortalarına doğru kullanıcıdan bilgi alan ve temel düzeyde kullanıcıyla etkileşime giren CGI 
(Common Gateway Interface – Ortak Giriş Arayüzü-) uygulamaları geliştirildi. İlerleyen 
yıllarda daha gelişmiş kullanıcı sorgulama teknikleri geliştirildi (ASP, PHP, vb.). Ancak web 
yine de pek çok kullanıcı için hala çok sıkıcıydı. 

1996 yılında web sayfalarına yönelik olarak Applet diye adlandırılan uygulamalar 
ortaya çıktı. Appletlerin hazırlanmasında; üst düzey bir programlama dili olan, Sun 
Microsystems yazılım firmasının öncelikli olarak internet uygulamaları için geliştirdiği 
JAVA dili kullanılmaktaydı. 

Java apletlerinin yaygınlaşmaya başladığı dönemlerde Future Splash Animator diye 
adlandırılan ve günümüze göre kıyaslandığında son derece basit canlandırmaların 
hazırlanmasına olanak veren bir program kullanılmaktaydı. Macromedia firması 1997 
yılında bu programın lisansını satın alıp adını Flash olarak değiştirdi. Bu dönemden sonra 
web sayfalarından yayınlanabilen canlandırmaların hazırlanmasında yeni bir dönem başlamış 
oldu. Zamanla kullanıcı etkileşiminin güçlendirildiği canlandırmalar hazırlamak olanaklı 
duruma geldi. Flash 4’le birlikte duyurulan dahili ActionScript dili yardımıyla kullanıcı 
tepkisiyle çalışan canlandırmalar hazırlanabildi. 

Flash 5 ve özellikle Flash MX sürümleriyle kullanıcı etkileşimi çok üst noktalara 
çıkartıldı. 2004 yılında Macromedia Flash 2004 MX sürümü ve 2005 yılında Adobe 
firmasının satın aldığı Macromedia Flash 8 piyasaya sürüldü. Her yeni sürümle birlikte çok 
daha esnek ve güçlü bir yazılım karşımıza çıkmaktadır. Flash’ın sunduğu güçlü grafik 
araçları ve ActionScript dili son derce etkileyici canlandırmalar tasarlamayı mümkün 
kılmaktadır. 

Çalıştığınız kurumun ya da kendinizin internet üzerinde en iyi şekilde reklâmınızı 
yapmaya uygun Flash yazılımını kullanmayı bilmek sizlere artı puan kazandıracaktır. 
Gelişen teknolojinin bize sunduğu kolaylıklardan yararlanmak ve onları en etkin şekilde 
kullanmak veriminizi ve üretkenliğinizi yükseltecektir. Bu modülde sizlere sürümden 
bağımsız olarak Flash yazılımının uygulamalı anlatılması hedeflenmiştir. 

GİRİŞ 
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ÖĞRENME FAALİYETİ–1 
 

  
 Bu öğrenme faaliyetinde Flash yazılımının genel özelliklerini öğreneceksiniz. 
 

 

Vektörel grafik yazılımları hakkında temel düzeyde bilgi edininiz. Genellikle 
nerelerde ve ne amaçla kullanıldıklarını öğrenmeye çalışınız. 

 

1. ANİMASYON PROGRAMI HAKKINDA 
GENEL BİLGİ 

 
1.1. Flash Yazılımının Kullanım Alanları 

 
Flash ile web üzerinden yayınlanabilen vektör grafikleriyle hazırlanmış durağan 

resimler, etkileşimsiz ve etkileşimli canlandırmalar (animasyon) hazırlanabilir. Ayrıca sahip 
olduğu dahili programlama dili (ActionScript) yardımıyla yeni başlayanların sıradan 
etkileşim denetimleri eklemesini sağlayacak kadar kolay canlandırmalar hazırlanabilir.  

 
Flash, ileri düzey programcılarsa ActionScript yardımıyla çok güçlü etkileşimlere 

sahip uygulamalar hazırlama imkanı sağlamaktadır.  
 
Flash, ses dosyası ekleme ve ses denetimi yapma özelliğini de kullanıcılara sunmuştur. 

Böylece sesli karikatürler, Flash ile kolayca hazırlanabilir. 
 

1.2. Vektörel Grafikler 
 
Vektörel grafikler, bilgisayar ekranında çeşitli çizimlerin oluşturulması için bir dizi 

koordinat bilgisi ve matematiksel formüllerin kullanıldığı grafiklerdir. 
 
Vektör grafikleri ölçeklenebilir çizimlerdir. Bunun anlamını şöyle açıklayabiliriz: 

Flash’la çizilmiş bir nesne ne kadar büyütülürse büyütülsün görüntüde bir bozulma meydana 
gelmez. 

 

Şekil 1.1: Noktasal ve vektörel doğrunun karşılaştırılması 

ÖĞRENME FAALİYETİ–1 

 AMAÇ 

 ARAŞTIRMA 
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Bitmap diye adlandırılan resim ve grafiklerin oluşturulmasında her biri bağımsız veri 
(renk bilgisi, konum bilgisi) içeren ve piksel diye adlandırılan noktaların oluşturulması 
ilkesine dayanırr. Bitmap resim ve grafikler büyütüldüğünde büyütme oranını karşılamak 
üzere aralara noktalar yerleştirilir. Bu durum, ekrandaki grafik ve resmin kenarlarında 
merdiven basamağını andıran bir bozulmaya neden olur. Şekil 1.1’de noktasal (bitmap) ve 
vektörel iki doğrunun karşılaştırılması yapılmıştır. 
 

Vektörel grafiğin web için sağladığı en büyük yarar, işlevi büyük ancak boyutu küçük 
dosyaların hazırlanabilmesidir. 
 
1.3. Flash’ın Diğer Yetenekleri 
 

Flash’ın en önemli özelliklerinden birisi akışkanlık (streaming) yeteneğidir. Bunu 
anlamak için şöyle bir örnek verebiliriz: 
 

İçinde birkaç yüz Kbyte’lık birden fazla resim dosyaları ve çok büyük ses dosyası 
içeren bir web sayfası düşününüz. Dosya indirme (download) hızının düşük olduğu bir 
durumda sayfadaki resimler ekrana gelene kadar ve ses dosyası tamamen indirilip çalınmaya 
hazır duruma gelene kadar çok uzun zaman geçecektir. Bu pek çok kullanıcı için istenmeyen 
bir durumdur. 
 

Flash’la hazırladığınız bir canlandırma çok sayıda kareden ve sahneden oluşabilir. 
Flash filminin oynatılmaya başlanması için tüm bu karelerin ve sahnelerin yüklenmesine 
gerek yoktur. İlk kare yüklenmeye başlandığı andan itibaren film oynatılır. Kullanıcı 
yüklenen kareleri izlerken diğer kareler de kullanıcının bilgisayarına yüklenmeye devam 
eder. 

 
Filminizi doğru planlarsanız, gelen kareler gösterilen karelere göre asla geç 

kalmaz ve ziyaretçileriniz sürekli akan görüntüler görür. 
 

 

Flash dosyalarına film (movie) adı verilir. Flash’la oluşturulan dosyalar, .fla 
uzantısını alırken Flash Player (Flash oynatıcı) aracılığıyla oynatılan dosyalar .swf (‘svif diye 
okunur) uzantısını alır. Flash oynatıcı yardımıyla .swf uzantılı filmler web tarayıcısı 
üzerinden izlenebileceği gibi bağımsız olarak da çalıştırılabilir. 
 
1.4. Flash Nesnelerinin Hareketlendirilmesi 
 

Flashla canlandırma oluştururken çizgi film tekniğine benzer bir yöntem kullanılır. 
Oluşturulan hareketler ayrı karelerden meydana gelmektedir. Bu karelerin ayarlanan bir 
hızda birbiri ardına gösterilmesiyle hareket etkisi oluşturulur. 
 

Flash’ın önemli bir özelliği de her bir karenin çizimini kullanıcıya bırakmamasıdır. Siz 
başlangıç ve bitiş karelerini tanımlarsınız, ara kareleri Flash kendisi oluşturur. Bu teknikle 
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bir nesnenin belli bir noktadan başka bir noktaya hareketini ya da herhangi bir grafik 
öğesinin renginin ve şeklinin değiştirilmesini sağlayabilirsiniz.  
 

Tüm bu hareketler zaman çizelgesi diye adlandırılan bir cetvel üzerinde 
gerçekleştirilir. Cetvel her bir hareketin tutulacağı karelere ayrılmıştır. Kareler birbirinden 
bağımsızdır ve karelerde istediğiniz grafik öğesini barındırabilirsiniz. 

 
1.5. SWF Uzantılı Filmleri Geri Dönüştürmek 

SWF dosya biçimi FLA dosyalarının derlenmiş durumudur. Bu nedenle SWF’ye 
çevrilmiş bir filmin olağan şartlar altında FLA’ya çevrilmesi söz konusu değildir. Ancak 
bazı yazılım firmaları Ters Mühendislik diye adlandırılan tekniklerle SWF dosyalarını 
FLA’ya dönüştüren ve belli bir ücret karşılığı satılan yazılımlar geliştirmektedir. 

Bir internet tarayıcısında flash decompiler anahtar adıyla arama yaptıracak olursanız 
SWF dosyalarını FLA’ya dönüştüren, diğer bir açıklamayla ters dönüşüm (decompile) 
yapan yazılımları bulabilirsiniz. 
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UYGULAMA FAALİYETİ 
  

İşlem Basamakları Öneriler 

1) Bitmap ve Vektör grafiğinin farkını 
belirleyiniz. 

 Bitmap çizim yapan bir programda (ör: 
Paint) ve Flash’da benzer şekiller çiziniz. 
Çizdiğiniz şekillerin görüntüsünü yeterince 
büyütünüz ve farkı anlamaya çalışın. 

2) Akışkanlık (Streaming) olayını 
inceleyiniz. 

 Akışkanlık tekniğine göre çalışan ve internet 
üzerinde sesli görüntü iletimi yapan bir 
program inceleyebilirsiniz (ör: Windows 
Media Player). Sesli görüntü iletimi yapan 
bir internet sitesine giriniz ve görüntünün 
nasıl geldiğine dikkat ediniz. 

3) Örnek bir SWF dosyasını FLA’ya 
dönüştürünüz. 

 FLA dönüşüm yazılımı elde ediniz (ör: 
SoThink Flash Decompiler). 
Arkadaşlarınızdan ya da İnternetten örnek 
bir SWF dosyası elde ediniz. Açtığınız web 
sayfasında bir flash filmi varsa bu otomatik 
olarak bilgisayarınızın Temporary Internet 
Files klasörüne kaydedilir. 

 

 UYGULAMA FAALİYETİ 
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ÖĞRENME FAALİYETİ–2 
 
  

Bu öğrenme faaliyetinde dosya işlemlerinin nasıl yapıldığını, flash editörünün, araç 
kutularının ve panellerin nasıl kullanılacağını uygulamalı olarak öğreneceksiniz. 

  

Farklı grafik düzenleme yazılımlarının kullanıcı arayüzlerini inceleyerek Macromedia 
Flash yazılımının farkını anlamaya çalışınız. 

 

2. ANİMASYON HAZIRLAMA 
YAZILIMLARI TEMEL İŞLEMLERİ 

 
2.1. Animasyon Yazılımını Bir CD’den Kurmak 

 
Hangi sürümü kullanıyorsanız lisanslı Flash CD’si içerisinde çalıştırılabilir kurulum 

(installer) dosyasını bulunuz (ör: Flash 5 installer.exe, FlashMX installer.exe, vb.). Şekil 
2.1’de Flash MX sürümünün kurulum ekranı gösterilmiştir. 

  

Şekil 2.1: Flash kurulum sihirbazı Şekil 2.2: Lisans anlaşması 
 
Kurulum programı çalıştırıldıktan sonra kurulum dosyalarının hazırlanması ve 

kurulum sihirbazının ekrana gelmesi için ön yükleme işlemi yapılır. İşlem başarıyla 
tamamlandıktan sonra şekil 2.1’deki sihirbaz ekrana gelir. Next butonuna tıkladığınızda 
Lisans Anlaşması ekrana gelir (Şekil 2.2). 

Anlaşmayı Yes düğmesine tıklayarak onayladığınızda kurulumun yapılacağı yeri 
belirlemeniz için ekrana gelen pencereden yeri belirledikten sonra HDD’nizde 100 MB’lık 
bir alana kurulum işlemi gerçekleştirilir. 

ÖĞRENME FAALİYETİ–2 

 AMAÇ 

 ARAŞTIRMA 
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2.2. Boş Belge Açmak 
 
Flash yazılımını çalıştırdıktan sonra ekrana 550 px (piksel) genişliğinde 400 px 

yüksekliğinde boş bir çalışma ortamı gelir. Çalışma ortamı içinde Tools, Timeline, Color 
Mixer, Color Swatches, Components ve Properties panelleri bulunmaktadır. 

 

 
 

Şekil 2.3: Boş çalışma sayfasıyla ekrana gelen Flash editörünün görüntüsü 
 
Editör öğelerini; şekil 2.3’te yapılmış olan numaralandırmaya göre açıklayabiliriz. 
 
1: Zaman doğrusu (timeline). Kare kare canlandırma hazırlanırken zaman doğrusu 

üzerindeki çerçeveler (frame) kullanılır. 
 
2: Flash film dosyalarında kullanılan katmanlar (layer) gösterilir. Katmanlarla ilgili 

işlemler buradan yapılır.  
 
3: Flash’ta grafik çizimleri için gerekli olan araçların bulunduğu araç kutusudur. 
 
4: Flash çalışma alanında ve panellerinde yer alan tüm nesne ve araçların sahip 

oldukları özelliklerin gösterildiği Property Inspector (Özellik Sorgulayıcısı) panelidir. 
 
5: Grafikler üzerinde çeşitli renk işlemlerinin yapıldığı Color Mixer (Renk 

Karıştırıcısı) ve Color Swatches (Renk Pastelleri) panelleridir. 
 
6: Radyo düğmesi, kaydırma çubuğu (scroll bar), kontrol kutusu (check box), buton 

gibi kullanıcı hareketine duyarlı bileşenlerin çalışma sayfasına eklenmesini sağlayan 
Components (Bileşenler) panelidir. 

alonso
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Çalışma Alanı: Stage olarak da adlandırılır. Grafik öğelerinin ve nesnelerin 
yerleştirildiği alandır. Bu alan dışına yerleştirilen öğeler .swf dosyasında gözükmez. 

 

Uygulama-2.1: Çalışma dosyasının kaydedilmesi ve çalıştırılması 

1- Boş çalışma sayfasını File menüsünden Save komutuyla bos ismini vererek masa 
üstüne kaydediniz. 

2- Control menüsünden Test Movie komutuyla ya da Ctrl+Enter tuş ikilisiyle 
bos.fla dosyasını çalıştırınız. 

3- Ekrana gelen Flash Player penceresinde File → Close komutuyla Flash editörüne 
geri dönünüz. 

4- Bilgisayarınızın masa üstünde bos.swf isminde bir dosya var mı? Varsa bu dosyayı 
tek başına çalıştırabiliyor musunuz? 

2.3. Şablon Dosyası Açmak 
 
Flash boş çalışma dosyası dışında çeşitli tiplerde reklâm etiketleri, menüler, sunu ve 

küçük sınav (quiz) taslakları gibi hazır şablonlara sahiptir. Bu şablonlar kullanılarak amaca 
göre en uygun boyutlarda flash dosyası hazırlanabilir. 

Uygulama-2.2: 250x250 boyutlarında reklam şablonunun kullanılır hale getirilmesi 

1- File → New →Template Komutuyla New From Template penceresini ekrana 
getiriniz. 

2- Sınıf (Category) kısmından Ads (Advertisements – reklamlar) sınıfını seçiniz. 

3- Sınıf öğeleri (Category items) kısmından popup_250x250 şablonunu seçiniz ve 
oluştur (Create) komutunu onaylayınız. 

4- Timeline panelinde instructions yazılı katmanın üzerine sol tuşla tıklayarak seçili 
duruma getiriniz ve sağ tuşla tıklayarak çıkan listeden Delete Layer komutunu 
veriniz. 

2.4. Panelleri Kullanmak 
 
Flash 5 ve sonrası Flash sürümleriyle kullanıcı dostu, kullanımı kolay, istenildiği gibi 

hareket ettirilebilen her biri kendine özgü özellikleri barındıran paneller kullanılmaya 
başlanmıştır.  
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Uygulama-2.3: Panellerin üzerinde hareket işlemlerinin yapılması ve bazı 
özelliklerinin değiştirilmes; 

1- Şekil 2.4’te gösterilen Tools panelini bulunuz ve farenin sol tuşuyla sürükleme 
yapılacak alana (kırmızı daire içinde gösterilen alan) tıklayınız. 

2- Tuşu basılı tutarak fareyi çalışma alanına doğru sürükleyiniz. 

3-  Araç kutusunun üstünde gözüken yandaki alanda çarpı işaretine 
tıklayarak araç kutusunu kapatınız. 

4- Windows → Toolbars komutuyla araç kutusunu yeniden görünür hale getiriniz. 

5- Araç kutusunu ilk konumuna taşımak için araç kutusu üstündeki alana sol tuşla 
tıklayın. Tuşu bırakmadan araç kutusunu ekranın sol tarafına doğru sürükleyiniz 
ve bırakınız. Araç kutusunun yerleşiminde bir değişim görülecektir. 

 

Şekil 2.4: Grafik çizimleri için 
araç kutusu paneli 

 

Şekil 2.5: Bileşenler paneli 
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6- Şekil 2.5’te gösterilen Components panelini bulunuz ve işaret edilen  şekle sol 

tuşla tıklayınız (Fare imleci  şeklini alacaktır). 

7- Tuşu bırakmadan paneli istediğiniz bir yere taşıyınız ve tuşu bırakınız. Ardından 

paneli taşımak için tıkladığınız alana ( ) yine tıklayınız ve bu sefer paneli 
önceki konumuna taşıyınız. 

8- Şekil 2.5’te işaret edilen panel alanını açıp kapatan yüzeye sol tuşla aralıklı olarak 
iki defa tıklayınız. Panelin kapanıp sonra tekrar açıldığını gördünüz mü? 

9- Şekil 2.5’te işaret edilen panelle ilgili yapılabilecek işlemler menüsünü açmak için 

kullanılan alana ( ) tıklayınız. Açılan menüde gördüğünüz seçenekleri seçerek 
panelde ne gibi değişiklikler oluştuğunu görünüz. 

10- Window menüsünden diğer panelleri de editör ekranına getirin. Yukarıda verilen 
yönergeleri farklı paneller için de uygulayarak panellerin kullanımıyla ilgili 
yeteneğinizi yükseltmeye çalışınız. 

2.5. Zaman Doğrusunu ve Çalışma Sayfasını Kullanmak 

Uygulama-2.4: Zaman doğrusu ve çalışma alanı üzerinde temel düzeyde işlemlerin 
gerçekleştirilmesi 

1- Modify → Document… (Ctrl+J) komutunu vererek Document Properties 
(Çalışma Sayfası Özellikleri) penceresini açınız. Çalışma sayfasının genişliğini 
(Width) 300px ve yüksekliğini de (Height) 200 px’e ayarlayınız. Zemin rengini 
(Background Color) açık mavi yapınız. Kare hızını (Frame Rate) 20’ye 
ayarlayınız. 

2- Araç kutusundan metin yazma (Text Tool – A) aracını seçiniz. Çalışma sayfasının 
ortasına Çalışma Alanı-1 yazınız. 

3- Araç kutusundan seçme Arrow Tool – ( ) aracını seçin. Fare imleci değiştikten 
sonra daha önceden yazmış olduğunuz Çalışma Alanı-1 metninin üzerine sağ tuşla 
tıklayınız. Çıkan menüden Copy komutunu vererek metni kopyalayınız. 

4- ‘Timeline panelinde şekil 2.6’da gösterildiği gibi içinde siyah noktanın olduğu 
hücrenin yanındaki hücreye sağ tuşla tıklayınız ve Insert Blank Frame komutunu 
veriniz. 
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Şekil 2.6: Boş film karesinin eklenmesi 

5- Edit → Paste in Place (Aynı yere yapıştırın) komutunu veriniz. Araç kutusundan 
metin yazma aracını seçiniz ve Çalışma Alanı-1 yazısının içine girerek 1 
rakamının yerine 2 yazınız. 

6- 4. ve 5. adımları zaman doğrusunda 5. kareye kadar tekrarlayınız. 

7- Çalışma dosyanızı ilk animasyonum adıyla kaydediniz ve Control → Test Movie 
komutunu veriniz. 

8- Hazırladığınız canlandırma Çalışma Alanı-1’den Çalışma Alanı-5’e kadar 
sayıyorsa şekil 2.7’de gösterilen bölgeye çift tıklayarak daha önceden Modify → 
Document… komutunu kullanarak açtığınız Document Properties penceresini 
açınız. 

 

Şekil 2.7: Sayfa özelliklerine zaman doğrusundan ulaşılması 

9- Kare hızını 20’den 5’e ayarlayınız. Filminizi Control → Test Movie komutuyla 
yeniden çalıştırınız. Filmin önceki çalışmasıyla şimdiki çalışması arasında bir fark 
var mı? 

Fps Hakkında: Kare hızı (Frame Rate) ayarlanırken fps (Frame Per Second) 
seçeneği  vardır.. Bu  1 saniye içinde gösterilecek kare sayısını belirtir. 
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Çalışma alanı ayarlarını (Document Properties) sürekli kullanacağınız 
değerlere göre belirledikten sonra bu değerleri Make Default komutuyla 
varsayılan sayfa ayarları olarak belirleyebilirsiniz. Böylece her defasında 
istediğiniz değerleri ayarlamanıza gerek kalmaz. 

Paneller hakkında: Panellerin nasıl düzenleneceğiyle ilgili maddeler hariç 
Window menüsü altında listelenen tüm maddeler bir panel ismidir. O anda açık olan 
panellerin yanında √ işareti vardır. 

Panel düzenleriyle ilgili maddelerin ne amaçla kullanıldıklarını şöyle açıklayabiliriz. 

Window → Panel Sets: Panellerin ekran çözünürlüğüne göre nasıl gösterileceğini ve 
hangi panellerin açık olacağını belirleyen maddedir. Default Layout Flash yazılımınız ilk 
çalıştırıldığında ekrana gelen panel düzenini açar. 

Window → Save Panel Layout: Kendi isteğinize göre hazırlamış olduğunuz panel 
yerleşimini kaydedip Panel Sets altından istediğiniz zaman kullanabilirsiniz. 

İpucu : Hazırladığınız panel grubunu silmek için Flash yazılımı ana 
klasörün içinde yer alan Panel Sets klasörünü açınız. Silmek istediğiniz panel 
grubunun ismini taşıyan dosyayı siliniz. 

Window → Close All Panel: Tüm panelleri kapalı duruma getirir. 

Window → Cascade: Farklı çalışma sayfaları açıldıysa bunları ardışık şekilde gösterir. 

Window → Tile: Farklı çalışma sayfaları açıldıysa ekranı bölerek sayfaları hepsi 
görünecek şekilde yerleştirir. 
 
2.6. Yardım Menüsünü Kullanmak 

Flash’da F1 tuşuna basarak ya da menü çubuğunda Help → Flash Help komutuyla 
yardım menüsüne ulaşabilirsiniz. Yardım menüsü oldukça geniş bir içeriğe sahip olup 
yabancı dil bilmeniz durumunda Flash’la ilgili öğrenmek istediğiniz pek çok konuya 
rahatlıkla ulaşabilirsiniz. 

 

Şekil 2.8: Flash 8’de yardım (Help) menüsü 
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Şekil 2.9: Yardım penceresi 

Flash’ın yardım menüsünde hakkında yardım alabileceğiniz konu sınıfları vardır. 
Özellikle Tutorials & Samples konusunu seçecek olursanız, Flash’ta çeşitli çalışmaları nasıl 
yapabileceğiniz hakkında geniş bir bilgi bulabilirsiniz. Seçtiğiniz konunun açıklaması altında 
o konuyla ilgili en sıcak bilgileri alabileceğiniz View comments on LiveDocs bağlantısı 
bulunmaktadır. Bu bağlantıya tıkladığınızda konuyla ilgili internet sayfasına 
yönlendirilirsiniz. 

 
2.7. Klavye Kısayollarını Özelleştirmek 

 
Flash kısayol tuşları yardımıyla çizim araçlarına ve menü komutlarının çoğuna 

klavyeden hızlıca erişilebilir. İsterseniz bu tuş birleşimlerini değiştirebilirsiniz. Böylece 
kısayol tuşlarını, kendi tercihlerinize göre ayarlama rahatlığına kavuşmuş olursunuz. 

Uygulama-2.5: Listeden kısayol grubu seçilmesi, kısayol grubu hazırlanması ve 
kısayol grubunun silinmesi. 

1- Edit menüsünden Keyboard Shotcuts komutuyla kısayol tuş grupları iletişim 
penceresini açınız. 

2- Current Set açılır menüsünden istediğiniz bir kısayol tuş grubunu seçiniz ve OK 
butonuyla işlemi onaylayıp pencereyi kapatınız. Yeni tuş birleşimleri, menülerde 
ve araç ipuçlarında görünür. 
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Şekil 2.10: Kısayol tuş gruplarından istenilen grubun seçilmesi 

3- Kendi isteğinize göre kısayol grubu oluşturmak için öncelikle kısayol grubu 
menüsünden bir kısayol tuş grubu seçiniz. 

4- Duplicate Set düğmesine tıklayınız ve çıkan iletişim penceresinde yeni bir isim 
giriniz. Böylece seçmiş olduğunuz kısayol tuş grubunun bir kopyasını elde etmiş 
olursunuz. 

  
Şekil 2.11: Kısayol tuş grubunun 

kopyasının oluşturulması 
Şekil 2.12: Kopyası alınacak tuş grubu için yeni bir 

ismin seçilmesi 

5- Kopyasını oluşturduğunuz tuş grubunda değişiklik yapmak için 
Keyboard Shortcuts iletişim kutusunda Commands menüsünden 
Drawing Menu Commands değerini seçiniz. 

6- Hangi komutun kısayol tuşunu değiştirmek istiyorsanız ilgili menüyü Şekil 2.13’te 
gösterildiği gibi seçiniz ve kısayol tuşunu değiştirmek istediğiniz komutu bulunuz. 
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Şekil 2.13: Kısayol tuşlarının değiştirilmesi 

 

Şekil 2.14: Bir kısayolun silinmesi 

7- Press Key alanına yeni tuş kombinasyonunu girmek için istediğiniz tuşlara 
basınız. Change butonuna tıklayarak kısayol grubunu güncelleyiniz. 

8- Bir kısayolu silmek için Şekil 2.14’te olduğu gibi Remove düğmesine tıklayınız. 
Kısayolu olmayan bir komuta kısayol eklemek için Add Shortcut düğmesine 
tıklayınız. 

2.8. Sahnelerle Çalışmak 

Flash filmleri, birbiri ardınca sırayla gösterilen tiyatro sahneleri gibi farklı sahnelerden 
oluşabilir. Flash’ta boş çalışma sayfası açıldığında varsayılan olarak Scene 1 adlı sahne 
ekrana gelir ve tüm çalışmalar bu sahne üzerinde gerçekleştirilir. 

Filminize birden fazla sahne ekleyip her bir sahnede ayrı bir çalışma yapabilirsiniz. 
Ancak sahneler sırayla gösterildiğinden ilk önce Scene 1 sahnesi, ardından Scene 2 ve varsa 
diğer sahnelerdeki çalışmalar gösterilir. 
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Uygulama-2.6: Flash filmine birden fazla sahne eklemek. 

1- Boş çalışma sayfası açınız. Şekil 2.15’in 1. karesinde görüldüğü gibi çalışma 
sayfanız Scene 1 isimli sahneyle ekrana gelir. 

 

Şekil 2.15: Flash’ta sahneler 

2- Yeni bir sahne eklemek için menü çubuğunda Insert → Scene komutunu veriniz. 

3- Sahneler arası geçiş yapmak için şekil 2.15’in 4. karesinde gösterildiği gibi Edit 

Scene ( ) butonuna tıklayınız. Çıkan listeden, üzerinde çalışmak istediğiniz 
sahneyi seçiniz. 

Çalışma sayfası üzerinde yapılan her türlü grafik işlemi, açık olan sahne üzerinde 
yapılır. Filminizi Ctrl+Enter tuş ikilisiyle ya da Control → Test Movie komutuyla 
başlattığınızda, eğer özel bir müdahale yapmamışsanız sahnelerde yaptığınız çalışmalar 
sırayla oynatılır. 
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UYGULAMA FAALİYETİ 
  

İşlem Basamakları Öneriler 

1) 200px-200px boyutlarında bir 
çalışma sayfası açınız ve zemin 
rengini değiştiriniz. 

 File  New 

2) Açtığınız belgeye yeni bir sahne 
ekleyiniz. 

 Insert  Scene 

3) Yardım menüsünden “Flash Help” 
değerini seçiniz ve arama kutusuna 
“panels” değerini yazınız. Search 
butonuna tıklayınız. 

 F1 

4) Flash editöründeki tüm panelleri 
gizleyiniz. 

 Teker teker görünen tüm panelleri 
sürükleme kenarlarından fareyle boş bir 
alana sürükleyip sağ üst köşedeki kapatma 
simgesine tıklayabilirsiniz ya da Window 
menüsünde listelenmiş panel adlarının 
yanlarındaki işaretleri kaldırabilirsiniz.  

5) Timeline, Tools, Color Mixer, 
Color Swatches ve Properties 
panellerini görünür yapınız. 

 Window  

6) Edit menüsü altında yer alan ve 
kısayol tuşlarına sahip tüm komutların 
kısayol tuşlarını karşılık gelen Türkçe 
kelimelerin baş harfleriyle değiştiriniz. 

 Uygulama-2.5’i inceleyebilirsiniz. 

 

 UYGULAMA FAALİYETİ 
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ÖLÇME VE DEĞERLENDİRME 
  
 
Bu bölümde Öğrenme Faaliyeti-2’de anlatılan konular hakkında bilginizi ölçmek 

amacıyla çoktan seçmeli sorular sorulacaktır. Maddeleri duyarlılıkla yanıtlamanız önerilir. 
 
A. ÖLÇME TESTİ 
 
1. Color Swatches panelinin işlevi nedir? 

A) Metnin yazı tipiyle ilgili ayarlar yapılır. 
B) Seçili nesnenin özellikleri değiştirilir. 
C) Grafik öğelerinin dolgu ve çerçeve renkleri belirlenir. 
D) Gradyent etkilerinin seçildiği paneldir. 
 

2. Çalışma alanına radyo düğmesi hangi panelden eklenir? 
A) Components    
C) Properties 
B) Tools     
D) Answers 

3. Panellerin sol üst köşesinde yer alan  simgesinin işlevi nedir? 
A) Paneli gizler ya da görünür yapar. 
B) Panel boyutları değiştirilir. 
C) Panel niteliklerine ulaşılır. 
D) Paneli taşımak için kullanılır. 

4. Panellerin sağ üst köşesinde yer alan  simgesinin işlevi nedir? 
A) Paneli gizler ya da görünür yapar. 
B) Panel boyutları değiştirilir. 
C) Panel niteliklerine ulaşılır. 
D) Paneli taşımak için kullanılır. 
 

5. Guide iletişim penceresinden hangi işlemler gerçekleştirilir? 
A) Izgara ayarları yapılır. 
B) Kılavuz çizgilerinin ayarları yapılır. 
C) Cetvel ayarları yapılır. 
D) Zaman çizelgesi ayarları yapılır. 
 

6. Grid iletişim penceresinde yer alan Snap Accuracy menüsünün işlevi nedir? 
A) Nesnenin ızgaraya kenetlenme hassasiyetini ayarlar. 
B) Nesnenin ızgaraya kenetlenip kenetlenmeyeceğini belirler. 
C) Izgaraların görünürlüğünü ayarlar. 
D) Izgara boyutlarını ayarlar. 

 ÖLÇME VE DEĞERLENDİRME 
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7. Aşağıdaki eylemlerden hangisi çalışma alanı görüntüsü büyüklüğünün 

değiştirilmesinde kullanılmaz? 
A) View → Zoom in    
C) View → Magnification 
B) View → Zoom out    
D) View → Outlines 
 

8. Help menüsünden yapılamayacak işlem aşağıdakilerden hangisidir? 
A) Flash’ın derslerine ulaşılabilir. 
B) Flash sürümünün yenilikleri incelenebilir. 
C) Örnek Flash filmlerine ulaşılabilir. 
D) Dosya işlemlerine ulaşılabilir. 
 

9. Aşağıdaki seçeneklerden hangisiyle metin nitelikleri ayarlanabilir? 
A) Metin aracı etkinken özellikler (Properties) paneli 
B) Modify → Document 
C) Modify → Shape 
D) Araçlar (Tools) paneli 
 

10. İstenen paneli gizlemek için aşağıdakilerden hangisi yapılamaz? 
A) İlgili panelin panel başlığına tıklanır. 
B) Window menüsünden ilgili panelin yanındaki işaret kaldırılır. 
C) Özellikler panelinden görünürlük değerleri değiştirilir. 
D) Panel başlık çubuğuna sağ tıklanır ve çıkan menüden Close Panel komutu verilir. 
 

 

DEĞERLENDİRME 
 
Ölçme sorularının çoğunu doğru yanıtlamış ve eksiklerinizi gözden geçirmişseniz bir 

sonraki öğrenme faaliyetine geçebilirsiniz. 
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ÖĞRENME FAALİYETİ–3 
  
  

Bu öğrenme faaliyetinde çeşitli canlandırmalar ve uygulamalar hazırlarken çok sık 
olarak faydalanılan grafik araçlarının kullanımını öğreneceksiniz. 
  

 

Farklı grafik düzenleme yazılımlarının grafik araçlarını inceleyerek Flash yazılımıyla 
olan benzerlik ve ayrılıklarını anlamaya çalışınız. 

 

3. GRAFİK ARAÇLARINI KULLANMAK 
 
Uygulamalara geçmeden önce araç kutusunda yer alan Options seçeneğini kısaca 

açıklamak yerinde olacaktır. 

 

Şekil 3.1: Araç kutusunda yer alan Options bölümündeki ek özelliklerin seçilen araca göre 
değişmesi 

ÖĞRENME FAALİYETİ–3 

 AMAÇ 

 ARAŞTIRMA 
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Araç kutusunda yer alan bir araç seçildiğinde o araca ait ek özellikler Options 
bölümünde gözükür. Her aracın kendina ait  özelliği burada yer alır. 

İpucu : Araç kutusundaki araçları klavyeden ilgili harflere basarak da 
seçebilirsiniz. Örneğin Arrow Tool aracını V harfine basarak seçili duruma 
getirebilirsiniz. 

3.1. Tek Katman Üzerinde Farklı Şekiller Çizmek 
 
Flash, farklı çizim araçları ve bu araçların sahip oldukları ek özellikleriyle etkileyici 

tasarımlar yapılmasına olanak verir. Flash’ın araçları, diğer grafik yazılımlarında bulunan 
araçlara göre oldukça esnek bir yapıdadır. 

Uygulama-3.1: Çizgi aracı (Line Tool), kalem aracı (Pencil Tool), dörtgen aracı 
(Rectangle Tool) ve oval aracı (Oval Tool)’nın kullanılması. 

1- 400X400 px boyutlarında boş çalışma sayfası açınız. 

2- Cetveli ve Izgarayı görünür yapınız ve hücre boyutlarını 20X20 px’e ayarlayınız. 

3- ‘Line Tool -  aracını seçiniz. Properties panelinden Custom butonuna 
tıklayınız ve vuruş biçimi (Stroke Style) iletişim penceresinde Type açılır 
menüsünden Dashed çizgi türünü seçiniz. Thickness açılır menüsünden 2 değerini 
seçiniz. İşlemi onaylayıp pencereyi kapatınız. 

 
Şekil 3.2: Çizgi aracı özelliklerinin Properties paneli kullanılarak değiştirilmesi 

4- Çalışma alanına gidiniz ve rastgele çizgi çiziniz. 
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5- Properties panelinden çizgi rengini değiştiriniz. Çizgi türü olarak saç teli 
inceliğinde anlamına gelen hairline türünü seçiniz. Çalışma alanında rastgele 
çizgiler çiziniz. 

İpucu : Çizgi rengini Properties panelinde yer alan Stroke color açılır 
renk paletiyle değiştirebileceğiniz gibi araç kutusunda yer alan Colors 
bölümündeki Stroke Color renk paletiyle de değiştirebilirsiniz. 

6- Araç kutusundan Pencil Tool  aracını seçiniz.  

 

Şekil 3.3: Pencil Tool aracının ek özellikleri 

7- Options kısmından kalem modlarını sırasıyla seçerek çalışma alanına benzer 
çizgiler çiziniz (ör. 8 rakamını çizin) ve modlar arasındaki farkı daha iyi anlamaya 
çalışınız. 

8- Araç kutusundan Rectangle Tool aracını seçiniz. Options kısmından  
Round Rectangle Radius modunu seçerek Rectangle Settings iletişim 
penceresini açınız. 

9- İletişim penceresinde Corner Radius alanına 5 değerini giriniz. 

10- Araç kutusunda Colors kısmından Stroke Color renk paletini açınız.  
düğmesine tıklayınız ve çerçeveyi kaldırınız. Fill Color renk paletini açınız ve 
istediğiniz bir dolgu rengi seçiniz. 

‘Pencil Tool aracının ek özellikleri: 
Straighten modu : Çizgi kıvrımlarını keskinleştirir. 
Smooth modu  : Çizgi kıvrımlarını en aza indirger ve   
                     yuvarlaklaştırır. 
Ink modu  : Çizgi kıvrımlarını yumuşatır. En  
                     doğal çizim modudur. 
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(A) (B) 

Şekil 3.4: (A) Dörtgenin etrafını çevreleyen çerçevenin kaldırılması. (B) Dörtgen köşelerinin 
yuvarlaklaştırılması 

11- Çalışma alanına istediğiniz boyutta dörtgen çiziniz. 

12- Araç kutusundan Oval Tool aracını seçiniz. Properties panelinde Stroke 
color seçeneğinin yanındaki çizgi kalınlığı açılır menüsünden çizgi kalınlığını 
yükseltiniz. 

13- Custom düğmesine tıklayarak açılan Stroke Style iletişim penceresinde Type 
açılır menüsünden Stipple çizgi türünü seçiniz. 

 

Şekil 3.5: Stroke Style iletişim penceresinde Stipple çizgi türü değerlerinin ayarlanması 

14- İstediğiniz değişiklikleri yaparak çalışma alanına farklı dolgu renklerinde ve 
çerçevelerde daireler çiziniz. 

Uygulama-3.2: Dolma kalem aracı kullanarak farklı şekillerin elde edilmesi. 

Pen Tool – Dolma Kalem Aracı: Kullanımı en farklı araçlardan biridir. 
Çalışma alanında tanımlama noktaları yerleştirmenizi ve bu noktaların birbirine 
bağlanmasını sağlar. Eğer noktalar kapalı bir alan oluşturacak şekilde bağlanıyorlarsa kapalı 
alan dolgu rengiyle boyanır. 

1- Araç kutusundan dolma kalem aracını ( ) seçiniz. Pen ikonu yanında x işareti 
belirir. Bu işaret, bir yolun ilk noktasını yerleştirmeye hazır olduğunuzu belirtir. 

2- Çalışma sayfasının boş bir bölgesine tıklayınız. İmleç içi boş bir ok şeklini alır. 
Küçük bir çember, noktanın çalışma sayfasındaki konumunu belirtir. 
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3- İmleci bir miktar doğrusal bir şekilde sağa hareket ettiriniz ve tıklayınız. 

4- Çalışma sayfasında farklı noktalara tıklayarak eklem noktalarından oluşan çizgi 
meydana getiriniz. 

5- Çizimi sonlandırmak için son noktaya ya da araç kutusundan Pen Tool aracına 
tıklayınız. Edit menüsünden Deselect All komutunu veriniz. Ayrıca Esc tuşuna da 
basabilirsiniz. 

6- Bitiş noktasını başlangıç noktasıyla birleştirecek olursanız kapalı bir alan elde 
etmiş olursunuz. Böylece kapalı alanın içi dolgu rengiyle boyanır. Bitiş noktasını 
kapalı bir alan oluşturabilecek bir eklem noktasıyla kesiştirdiğinizde de kapalı bir 
alan elde edilir. Edit menüsünden Deselect All komutunu vererek çizimi bitiriniz. 

 
(A) (B) (C) (D) (E) 

Şekil 3.6: Dolma kalem aracıyla içi dolgulu bir nesnenin çizilmesi 

Önizleme Çizgisinin Gösterilmesi: Edit → Preferences komutuyla açılan 
iletişim penceresinde Editing sekmesine geçiniz ve Show Pen Preview onay 
kutusunu işaretleyiniz. Böylece dolma kalem aracıyla çizim yaparken çizginin 
önizlemesi çizgi yolu boyunca gözükür. Pencereyi kapatınız. 

7- Dolma kalem aracı seçiliyken herhangi bir noktaya tıklayınız. Farenin tuşunu 
basılı tutarak imleci istediğiniz bir noktaya doğru hareket ettiriniz. Temel 
noktadan iki tutamaç çıkar ve siz sürüklerken zıt yönlerde uzar. 

 
(A) (B) (C) 

Şekil 3.7: Dolma kalem aracıyla eğri çizilmesi 

8- İmleci aşağı doğru sürüklediğinizde şekil 3.7’de olduğu gibi bir eğri kılavuz yolu 
oluşur. Son noktaya tıkladığınızda eğri kalıcı duruma gelir. 

 

İpucu : Dolma kalem aracını kullanarak S harfi gibi şekiller çizebilirsiniz. 
Çeşitli denemeler yaparak bu aracı kullanma yeteneğinizi güçlendirmeye 
çalışınız. 
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Uygulama-3.3: Fırça aracı kullanarak farklı şekillerin çizilmesi. 

1- Ctrl+N tuşlarıyla boş bir çalışma sayfası oluşturunuz. 

2- Araç kutusundan Brush Tool (Fırça) aracını seçiniz. Araç kutusundan Fill 
Color düğmesine tıklayınız. 

3- Fare imlecini Color Swatches renk paleti üzerine götürünüz. İmleç tüp şeklini 
alınca paletten istediğiniz bir rengi seçiniz. Araç kutusu Colors bölümünde Fill 
Color renginin değiştiğini göreceksiniz. 

 
 

 

Şekil 3.8: Arzu edilen rengin 
seçildiği renk paleti 

Şekil 3.9: Fırça aracının 
ek özellikleri 

Şekil 3.10: Fırça aracının 
diğer özellikleri 

4- Fırça aracının beş farklı modu vardır. Normal boyama işlemi için Paint Normal 
modunu seçiniz. 

 

 Fırça aracına ait boyama modlarının işlevlerini yazınız. 

Paint Normal : …………………………………………………………….. 

Paint Fills : …………………………………………………………….. 

Paint Behind : ………………………………………………………………. 

Paint Selection : …………………………………………………………….. 

Paint Inside : …………………..………………………………………… 
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5- Çalışma alanına çeşitli çizimler yapınız ve sonucu görünüz. 

6- Arrow Tool aracını seçerek çizmiş olduğunuz şeklin bir kısmını seçili duruma 
getiriniz. 

7- Yeniden Brush Tool aracını seçin ve Paint Selection -Seçileni Boya- modunu 
ayarlayınız. 

8- Color Swatches panelinden ya da Fill Color düğmesinden farklı bir renk seçiniz 
ve seçili duruma getirdiğiniz alanı da kesecek şekilde çalışma alanına fırça 
darbeleri indiriniz. 

9- Yalnızca seçili kısmın boyandığını görmeniz gerekir (Şekil 3.11). 

 
(A) (B) (C) (D) (E) 

Şekil 3.11: Paint Selection modunda bir nesnenin seçili kısmının boyanması 

10- Paint Behind -Arkada Kalacak Şekilde Boya- modunu seçiniz ve farklı bir dolgu 
rengi belirleyiniz. 

11- Yine daha önceki şekli kesecek şekilde fırça darbeleri indiriniz. Son çizdiğiniz 
şeklin önceki şeklin arkasında kaldığını gördünüz mü? 

3.2. Izgaraları, Cetvelleri ve Kılavuzları Kullanmak 
 
Flash çalışma ortamı, kullanıcının hassas ve ölçekli çizimler gerçekleştirmesi için 

gerekli özellikleri sunar. Izgaralı çalışma alanı sayesinde sayfa içindeki nesnelerin 
yerleşimi ve konumları daha kolay belirlenir. Yatay ve düşey cetveller ile ölçekli nesneler 
çizebilirsiniz. Kılavuz çizgileri yardımıyla da çalışma ortamı içine yerleştirdiğiniz nesnelere 
referans noktaları atayabilirsiniz. 

Uygulama-3.4: Izgaranın, cetvellerin ve kılavuzların görünür hale getirilmesi. 

1- File → New komutunu vererek ya da Ctrl+N tuşlarına basarak yeni bir çalışma 
sayfası açınız. 

2- Çalışma sayfasının boyutlarını 200px – 200px’e ayarlayınız. 

3- View → Grid → Show Grid komutunu vererek ya da Ctrl+I tuşlarına basarak 
çalışma alanında birbirini kesen düşey ve yatay çizgilerin gözükmesini sağlayınız. 

alonso
Vurgu

alonso
Vurgu



 

 28

4- View → Grid → Edit Grid komutuyla ya da Ctrl+Alt+G tuşlarıyla ızgara 
düzenleme penceresini açınız. 

  

Şekil 3.12: Izgara iletişim penceresi Şekil 3.13: Izgara renginin ayarlanması 

5- Izgara genişliğini ve yüksekliğini 20 px olarak belirleyiniz. 

6- Color kısmından renk paletini açınız. Fare imleci tüp şeklini alınca renk 
paletinden veya Flash editörünün herhangi bir yerinden renk belirleyiniz. OK 
düğmesine tıklayınız ve iletişim penceresini kapatınız. Izgara renginin değiştiğini 
göreceksiniz. 

7- View → Rulers komutuyla ya da Ctrl+Alt+Shift+R tuşlarına basarak cetvelin 
gözükmesini sağlayın. 

8- Fare imlecini yatay cetvelin istediğiniz bir noktasında iken tıklayınız. (Fare 

imlecinin  şeklini alması gerekir.) Fare tuşunu bırakmadan fare imlecini 
çalışma sayfasının istediğiniz bir noktasına sürükleyiniz. Fare tuşunu 
bıraktığınızda şekil 3.14’te görüldüğü gibi renkli yatay kılavuz çizgisi belirir. 

 

Şekil 3.14: Flash çalışma sayfasında yatay kılavuz çizgisinin oluşturulması 

alonso
Vurgu
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9- Düşey kılavuz çizgisini çalışma sayfasının istediğiniz noktasında elde etmeniz için 
8. adımdaki benzer işlemleri fareyi düşey cetvele tıklayarak gerçekleştiriniz. Bu 

durumda fare imlecinin  şeklini alması gerekir. 

10- 8. adımdaki yöntemle istediğiniz kadar kılavuz çizgisi elde edebilirsiniz. View → 
Guides → Edit Guides komutuyla ya da Ctrl+Alt+Shift+G tuşlarına basarak 
kılavuz iletişim penceresini açınız. 

 

Şekil 3.15: Kılavuz çizgileri iletişim penceresi 

İletişim penceresi yardımıyla kılavuz çizgilerinin rengini değiştirebilirsiniz, tüm 
kılavuz çizgilerini silebilirsiniz ya da Lock Guides komutuyla kılavuz çizgilerini yerleri 
değişmeyecek şekilde sabitleyebilirsiniz. Yaptığınız değişiklikleri Save Default komutuyla 
varsayılan değerler olarak kaydedebilir ve sonradan göreceğiniz gibi çalışma sayfasındaki 
nesneleri Snap to Guides komutuyla kılavuz çizgilerine kenetleyebilirsiniz. 

11- Kılavuz çizgilerinden istediğinizi yok etmek istiyorsanız örnek olarak az önceki 
çalışma sayfasında oluşturduğunuz düşey kılavuz çizgisini yok ederek işe 

başlayalım: Araç kutusundan Arrow Tool  aracını seçiniz. Düşey kılavuz 

çizgisinin üzerine geliniz (Fare imleci  şeklini alır) ve tıklayınız. Şekil 
3.16’da gösterildiği gibi fare tuşunu bırakmadan kılavuz çizgisini düşey cetvel 
hizasına kadar sürükleyiniz ve tuşu bırakınız. 
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Şekil 3.16: Düşey kılavuz çizgisinin yok edilmesi 

12- Yatay kılavuz çizgisini yok etmek için 11. adımdaki benzer işlemleri fare imlecini 
yatay kılavuz çizgisi üzerine tıklayarak gerçekleştiriniz. 

Uygulama-3.5: Çalışma sayfasının belli koordinatlarına grafik nesnesi eklenmesi. 

1- 200px – 200px boyutlarında bir çalışma sayfası oluşturunuz. 

2- 20px – 20px boyutlarında hücrelerden oluşan bir ızgarayı görünür hale getiriniz. 

3- Cetvelden yaralanarak çalışma sayfasının 50px noktasına düşey kılavuz çizgisi 
ekleyiniz. Sayfanın 100px noktasına da yatay kılavuz çizgisi ekleyiniz. 

 

 

Şekil 3.17: Kılavuz çizgilerinin belirtilen 
koordinatlarda oluşturulması 

Şekil 3.18: Kılavuz çizgilerinin çalışma sayfasına 
kilitlenmesi 

4- View menüsünden Guides → Edit Guides komutuyla iletişim penceresini açınız 
ve kılavuz çizgilerini kilitleyiniz. 
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5- Araç kutusundan Rectangle Tool aracını seçiniz. Fare imleci  şeklini 
aldığında çalışma alanının 50px-100px konumuna 50px genişliğinde ve 50px 
yüksekliğinde farenin sol tuşuna basarak bir dikdörtgen çiziniz. 

6- Sayfaya eklediğiniz nesnenin kılavuz çizgilerine yaklaşıldığında çizgilere 
kenetlenmesini istiyorsanız şekil 3.18’de olduğu gibi Snap to Guides özelliğini 
etkinleştiriniz. 

7- Nesne hareket ettirilirken nesnenin kılavuz çizgilerine de kenetlenmesini 
istiyorsanız View menüsünden Grid → Edit Grid komutuyla iletişim penceresini 
açınız ve Snap to Grid özelliğini etkinleştiriniz. 

8- Eklediğiniz dikdörtgeni seçili hale getirmek için üzerine çift tıklayınız ve çalışma 
sayfası üzerinde klavyenin yön tuşlarıyla ya da fareyle hareket ettiriniz. Hareket 
sırasında nasıl bir farklılık oluştuğuna dikkat ediniz. 

Kenetleme İşlemi: Kenetleme işlemi (Snap), farklı hassasiyetlerde yapılabilir. 
Izgara (Grid) ve kılavuz çizgileri (Guides) iletişim pencerelerinde kenetlenme hassasiyeti 
(Snap accuracy) menüsünü açtığınızda dört farklı seçenek karşınıza gelir. 

- Must be close (Yakın olmalı): Nesneye kenetlenmek için nesnenin yakın olması 
gerekir. 
- Normal: Varsayılan kenetlenme düzeyidir. 
- Can be distant (Uzak olabilir): Nesne uzak olsa da kenetlenme işlemi gerçekleşir. 
- Always snap (Her zaman kenetle): Nesneye her durumda kenetlenilir. 
 

Kenetlenme düzeylerini sırasıyla deneyerek aralarındaki farkı anlamaya çalışın. 

 

3.3. Nesneler Üzerinde Temel İşlemleri Gerçekleştirmek 

Bu kısımda çalışma sayfası içine eklediğiniz nesnelere ya da belli bir bölgeye 
yakınlaşmayı (Zoom), Properties panelini kullanarak nesne özelliklerini değiştirmeyi 
öğreneceksiniz. 

Uygulama-3.6:Çalışma sayfasına farklı nesnelerin eklenmesi, yakından 
incelenmesi ve bazı özelliklerinin değiştirilmesi. 

1- Ctrl+N tuşlarıyla yeni bir çalışma sayfası açınız. Sayfa boyutlarını 400X400 px’e 
ayarlayınız. 

2- Araç kutusundan dikdörtgen aracını seçerek çalışma sayfasına istediğiniz boyutta 
bir dikdörtgen çiziniz.  
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3- Araç kutusundan Fill Color aracını çalıştırınız. İmleç tüp şeklini alınca 
boya paletinden farklı bir renk seçiniz.  Oval Tool aracını seçerek sayfaya 
daire çiziniz. 

4- Araç kutusundan Arrow Tool aracını seçerek dikdörtgen üzerine tıklayınız ya da 

Subselection Tool aracını seçerek dikdörtgenin sol üst köşesinde boş bir 
yere tıklayarak seçim alanı dikdörtgen şeklini tamamen içine alacak şekilde fareyi 
sürükleyiniz. 

5- View menüsünden Zoom in komutunu birkaç defa uygulayınız. Dikdörtgen 
şekline yaklaştığınızı görmeniz gerekir. 

6- View menüsünden Magnification → %100 komutuyla çalışma sayfasının gerçek 
boyutuna geri dönünüz. 

7- 4. adımdaki işlemi uygulayarak çizmiş olduğunuz daireyi seçili hale getiriniz. 

8- Zoom in komutuyla daireye yaklaşınız. Zoom out komutunu gerçek boyutlara 
dönene kadar çalıştırınız. 

9- Daire şekli seçiliyken Properties panelinden Fill color komutunu seçerek 
dairenin dolgu rengini değiştiriniz. 

 

 Şekil 3.19: Dolgu renginin değiştirilmesi 

10- Dairenin dışında yer alan çerçeveyi Selection Tool ok işareti aracıyla seçili 
duruma getiriniz. Özellikler (Properties) panelinde Stroke Color komutunu 
seçerek çerçevenin rengini değiştiriniz. 

11- Dikdörtgeni seçili duruma getiriniz ve özellikler panelinden; 

W: 40 X: -25 

H: 80 Y: 100 
 

Şekil 3.20: Boyut ve koordinat değerleri 

değerlerini giriniz. 
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3.4. Şekiller Üzerinde Değişiklik Yapmak 

Uygulama-3.7:Çalışma alanına çizilen bir dörtgen ve oval üzerinde seçme 
araçlarıyla çeşitli değişikliklerin yapılması. 

1- File menüsünden Close komutuyla ya da Ctrl+W kısayol tuşlarıyla bir önceki 
çalışma sayfalarını sırasıyla kaydetmeden kapatınız. 

2- 400X400 px boyutlarında yeni bir çalışma sayfası açınız. 

3- Hücre boyutları 20x20 px olan ızgarayı etkinleştiriniz ve cetveli açınız. 

4- Yatay 100 px noktasına ve düşey 100 px noktasına yatay ve düşey kılavuz 
çizgileri ekleyiniz ve kılavuz çizgilerini kitleyiniz. 

5- View menüsünden Zoom in komutuyla çalışma alanını birkaç defa yakınlaştırınız 
ve kılavuz çizgilerini istenen noktalara yerleştirdiğinize emin olunuz. Eğer kılavuz 
çizgileri belirtilen koordinatlarda değilse Arrow Tool aracıyla kılavuz çizgilerini 
ayarlayınız. 

6- View → Grid → Edit Grid komutuyla ızgara düzenleme iletişim penceresini açın 
ve Snap to Grid seçeneğini kaldırınız (Kenetlenme özelliğini iptal ediniz). 

7- View → Magnification → %100 seçerek gerçek boyutlara dönünüz. 

8- X:100 ve Y:100 koordinatlarına 200 px genişliğinde 200 px yüksekliğinde kırmızı 
dolgu rengine sahip, 2 px kalınlığında siyah çerçevesi olan bir dörtgen çiziniz  

 

Şekil 3.21: Belirtilen koordinatlara dikdörtgen çizilmesi 

9- ‘Arrow Tool aracını seçerek dörtgenin dışındaki çerçeveye çift tıklayarak seçili 
duruma getiriniz. Edit menüsünden Clear komutuyla ya da Backspace tuşuyla 
seçili çizgiyi siliniz. 
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İpucu : Eğer dörtgenin yalnızca bir kenarını seçmek istiyorsanız seçmek 
istediğiniz kenar çizgisine bir kez tıklayınız. 

 

10- Edit menüsünden Undo komutuyla ya da Ctrl+Z tuşlarıyla silme işlemini geri 
alınız. Çalışma alanında boş bir yere tıklayarak çerçeveyi seçili durumdan 
kurtarınız. 

 

 İpucu : Ctrl+Z tuşlarını kullanarak bilgisayarınızın sistem hafızası 
kapasitesine göre geçmiş eylemlere dönebilirsiniz. 

11-  Subselection Tool aracıyla dörtgenin çerçevesine farenin sol tuşuyla bir kez 
tıklayınız. Dörtgenin çerçevesi şekil 3.22’deki durumu alır. 

 

 
Şekil 3.22: Subselection aracıyla 

dörtgenin seçilmesi 
Şekil 3.23: Dörtgenin başka bir noktaya taşınması 

Subselection Tool – Altseçim Aracı: Subselection aracıyla seçilen bir 
çerçevenin içinde kalan alan da seçilir. Ayrıca seçilen çerçeve üzerinde çeşitli tutma 
noktaları oluşturularak şeklin bu noktalardan değiştirilmesi sağlanır.  

12- Subselection aracıyla dörtgenin etrafını kaplayan çerçeveyi seçtikten sonra 
farenin tuşunu bırakmadan dörtgeni farklı bir bölgeye taşıyınız. Dörtgenin iç 
dolgusuyla birlikte taşındığını göreceksiniz (Şekil 3.23). 

13- Dörtgenin etrafında içi boş küçük kareler şeklinde oluşan noktalara Subselection 
aracıyla tıklayarak tuşu bırakmadan fareyi sürükleyiniz ve bırakınız. Bu işlemi 
farklı noktalar için tekrarlayarak dörtgenin şeklini değiştiriniz (Şekil 3.24). 
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(A) (B) (C) 

Şekil 3.24: (A) Subselection aracıyla bir grafik öğesi seçiliyor. (B) Farenin sol 
tuşuna basarak tutamaçlardan biri tutuluyor. (C) İmleç grafiğin dışına 

sürükleniyor 

14- Çalışma sayfanıza yaklaşık 200 px genişliğinde bir oval çiziniz. 

15- Araç kutusundan Arrow Tool aracını seçiniz ve çizdiğiniz çemberi çevreleyen 
çizgiye tıklayarak seçili duruma getiriniz. 

16- Çevre çizgisini siliniz. Araç kutusundan Lasso Tool aracını seçiniz ve 
dairenin bir bölümünü içine alacak şekilde seçili duruma getiriniz. 

 
(A) (B) 

Şekil 3.25: (A) Lasso Tool aracıyla nesnenin istenen parçası seçiliyor. (B) Seçilen alan 

Lasso Tool – Kement Aracı: Serbest seçim yapmak için kullanılır. Fare 
imlecini seçime başladığınız noktaya kadar sürüklemenize gerek yoktur. Başladığınız 
noktayla sürüklemeyi bitirdiğiniz nokta arasını seçili duruma getirir. 

17- Araç kutusundan Arrow Tool aracını seçiniz ve az önce seçmiş olduğunuz 
parçanın üzerine tıklayarak tuşu bırakmadan farklı bir konuma sürükleyiniz. 

18- Yine ok aracıyla bu sefer oval şeklin dışına tıklayarak belli bir bölgesinde düz 
seçim alanı oluşturacak şekilde fareyi şekle doğru sürükleyiniz. 
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(A) (B) 

Şekil 3.26: Ok aracıyla bir grafikte düz seçim bölgesinin oluşturulması 

19- İstediğiniz bölgeyi seçtikten sonra siliniz. 

20- Ok aracı seçiliyken fare imlecini şeklin istediğiniz bir kenarına yaklaştırınız. 

Arrow Tool – Ok Aracı: Flash yazılımında en sık kullanılan araçtır. Pek çok 
işlem yapabilme özelliğine sahiptir. Bu araç seçiliyken imleci bir nesnenin kenarına 
getirdiğinizde imleç iki şekilden birini alır: 

 Eğer yaklaşılan kenar yumuşak kıvrımlardan oluşuyor ya da tamamen düzse 

 şeklini alır. 

 Yaklaşılan kenar keskin köşeliyse  şeklini alır. 

21- Fareyi sol tuşa basılıyken istediğiniz bir noktaya sürükleyiniz. Örnekte şeklimiz 
şekil 3.27’deki görüntüyü almıştır. Seçme araçlarıyla farklı uygulamalar yaparak 
elinizi bu tür uygulamalara alıştırmaya çalışınız. 

 
(A) (B) (C) 

Şekil 3.27: (A) Fare imleci şeklin düz kenarına yaklaştırılıyor. (B) Fare imleci sol tuşa basılarak 
şeklin dışına doğru sürükleniyor. (C) Fare tuşu bırakılıyor 

Uygulama-3.8:Free Transform Tool aracıyla grafik öğeleri üzerinde değişikliklerin 
yapılması 
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Free Transform Tool – Serbest Dönüşüm Aracı: Bu aracı nesneleri, 
metinleri, grup altına alınmış öğeleri ve flashın örnek öğelerini (instances) istenildiği gibi 
döndürmek ve boyutlandırmak amacıyla kullanabilirsiniz. 

1- Çalışma sayfasına üzerine, Free Transform Tool aracını uygulayacağınız bir 
dikdörtgen çiziniz. 

2- Araç kutusundan  Free Transform Tool aracını seçiniz. 

3- Eğer çizdiğiniz dörtgenin çerçevesi varsa ve bunu da seçime dâhil etmek 
istiyorsanız farenin sol tuşuyla dörtgene iki kere tıklayınız (Bir kez tıklayacak 
olursanız yalnızca dolgu kısmı seçilir, çerçeve seçimin dışında kalır). 

4- İmleç  şeklini alır. Şekil 3.28’de seçili dörtgenin farklı noktalarına 
yaklaştırılan fare ikonunun değişimi gösterilmiştir. 

 
(A) (B) (C) 

Şekil 3.28: (A) Dörtgenin çerçevesiyle birlikte seçilmesi. (B) Fare imlecinin yan, üst ve köşe 
noktalarına yaklaştırılması sonucu aldığı şekil. (C) Fare imlecinin dörtgenin dönme merkezine 

yaklaştırılması sonucu aldığı şekil 

5- İmleç şekil 3.28 (A)’daki görünümü aldığında dörtgeni farenin sol tuşuna 
basılıyken farklı bir noktaya sürükleyiniz. 

6- İmleç şekil 3.28 (B)’deki görünümlerden birini aldığında seçili dörtgeni ok yönleri 
doğrultusunda uzatıp daraltabilirsiniz. 

7- Fare imlecini dörtgenin sağ alt köşesine yaklaştırınız ve sol tuşa basılıyken yukarı 
doğru döndürünüz. Tuşu bıraktığınızda şekil 3.29’dakine benzer bir konum 
alacaktır. 

 
(A) (B) (C) 

Şekil 3.29: Dörtgenin merkez dönme noktasına göre döndürülmesi 

alonso
Vurgu

alonso
Vurgu
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8- Her nesnenin bir dönme referans noktası vardır. Bu nokta varsayılan olarak 
merkezdedir. İmleç şekil 3.28 (C)’deki görünümü aldığında dörtgenin dönme 
noktasını değiştirebilirsiniz. Dönme noktasını dörtgenin sağ üst köşesine 
yaklaştırınız. 

9- Fare imlecini dörtgenin istediğiniz bir noktasına yaklaştırınız. Fare imleci dönen 
ok şeklini aldığında sol tuş basılıyken şekli istediğiniz yönde hareket ettiriniz. 

 
(A) (B) (C) 

Şekil 3.30: Dörtgenin dönme noktasının değiştirilmesi 

10- Fare imlecini sağ ve üst orta noktadaki tutamaçlara imleç (  ya da ) şeklini 
alacak şekilde yaklaştırınız. Bu durumda şekil iki yöne doğru eğilerek 
değiştirilebilir. 

İpucu : Serbest dönüşüm işlemi için, Modify menüsünden de yapılabilir. 
Dönüşüm işlemi yapmak istediğiniz nesneyi seçili duruma getirip Modify 
menüsünden Transform komutunu veriniz. Şekil 3.31’deki menü karşınıza 

gelir.  

 
Şekil 3.31: Modify → Transform menüsünün alt seçenekleri 
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Transform menüsüne ait seçeneklerin işlevlerini şöyle sıralayabiliriz: 

(1) Free Transform: Free Transform Tool aracının yaptığı işlemi gerçekleştirir. 

(2) Distort: Bu komut verildiğinde Free Transfom işlemine benzer olarak nesnenin 
etrafında seçme bölgesi oluşur. Ancak merkez dönme noktasını değiştiremezsiniz. Fare 
imlecini tutamaç noktalarına yaklaştırdığınızda imleç şekil 3.32’deki görünümü alır. 
Tutamaçlardan şeklin genişliğini ve yüksekliğini ayarlayabilirsiniz. 

 
(A) (B) (C) (D) (E) 

Şekil 3.32: (A, B) Distort komutuyla şekil boyutlarının değiştirilmesi (C) Envelope komutuyla 
şekil kenarlarında çok zayıda tutamaç oluşturulması (D, E) Yuvarlak tutamaçlardan şekil 

görüntüsünün değiştirilmesi 

(3) Envelope: Şekil etrafında çok sayıda yuvarlak tutamaç oluşturur. Bu 
tutamaçlardan şeklin görüntüsü istenildiği gibi değiştirilir (Şekil 3.32 C,D,E). 

(4) Scale: Şekil boyutlarında döndürme noktası referans alınarak elle değişiklik 
yapılabilir. 

(5) Rotate and Skew: Şekil döndürme noktası referans alınarak elle döndürülür. 

(6) Scale and Rotate…: İletişim penceresi çıkar. Bu pencereye girdiğiniz değerlere 
göre grafik öğesinin boyutlarını ve dönme açısını sayısal olarak değiştirebilirsiniz. 

(7) Rotate 90° CW ve CCW: Saat yönü tersinde ve saat yönünde seçilen nesne 
döndürülür. 

(8) Flip Vertical, Flip Horizontal: Seçili nesneyi düşey ve yatay konuma göre ayna 
görüntüsünü oluşturur. 

Modify menüsünden eriştiğiniz bu komutlara, şekil üzerindeyken farenin sağ tuşuna 
tıkladığınızda çıkan menüden de ulaşabilirsiniz. 

Uygulama-3.9: Ink Bottle Tool aracıyla grafik öğelerinin dış çerçeve hatlarının 
değiştirilmesi 

Ink Bottle Tool – Mürekkep Şişe Aracı: Grafik öğelerinin çerçeve renklerini 
değiştirmek için kullanılır. Çerçevesi olmayan grafik öğelerine de çerçeve ekler. 

1- Çalışma alanına farklı şekiller (çizgi aracı, dörtgen aracı, oval aracı, fırça aracı 
araçlarıyla) çiziniz. 
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2- Araç kutusundan  - Ink Bottle Tool aracını seçiniz. 

3- Araç kutusu Colors bölümünden Stroke Color komutuyla ya da Color Mixer 
panelinden Stroke color komutuyla farklı bir çizgi rengi belirleyiniz. 

4- Ink Bottle Tool aracıyla çizmiş olduğunuz şekillerin üzerine tıklayınız. 

5- Çerçevesi olmayan şekillere çerçeve eklendiğini, çerçevesi olan şekillerin de 
çerçeve renklerinin değiştiğini görmeniz gerekir. 

Uygulama-3.10:Paint Bucket Tool aracıyla grafik öğelerinin dolgu renklerinin 
değiştirilmesi 

Paint Bucket Tool – Boya Kutusu Aracı: Aynı tonda ve renkte bir bölgeye 
tıklandığında o bölgeyi kendi rengine dönüştürür. Nesnelerin rengini değiştirmek 
istediğinizde kullanabilirsiniz. 

1- Araç kutusundan  - Paint Bucket Tool aracını seçin. Fill Color seçeneğinden 
ya da Color Swatches panelinden farklı bir dolgu rengi seçiniz. 

2- Çizmiş olduğunuz çizgilerin üzerine tıklayarak sonucu görünüz. 

 

Dört farklı boyama modu vardır. Araç kutusundan Options bölümünden farklı 
boyama modlarını seçerek çalışma alanına çizdiğiniz şeklin çeşitli yerlerine 
tıklayınız. Her bir modu seçtiğinizde dolgu rengini değiştirmeyi unutmayınız. 
Boyama modları arasında nasıl bir fark olduğunu anlamaya çalışınız. 

 

Uygulama-3.11: Eraser Tool aracıyla çizilen nesnelerin farklı şekillerde silinmesi 

Eraser Tool – Silgi Aracı: Çizilen grafik öğelerini farklı biçimlerde silmek 
için kullanılır. Metin ve Flash bileşenleri gibi nesneleri silmez. 

1- Araç kutusundan  - Eraser Tool aracını seçiniz. 

2- Farklı silme modlarını seçiniz ve çalışma alanındaki nesneleri silerek silme 
modları arasındaki farkı görünüz. 
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Şekil 3.33: Eraser Tool aracının farklı silme modları ve Faucet – Musluk özelliği 

Uygulama-3.12: Nesneler üzerinde Gradyent etkileri kullanılarak dolgu renklerinin 
değiştirilmesi 

Gradyent İşlemi Hakkında: Şu ana kadar üzerinde çalıştığınız grafiklerin 
dolgu rengi Solid diye adlandırılan katı biçimindeydi. Diğer bir ifadeyle %100 koyulukta ve 
tek tondaydı. Ancak dolgu renklerini yoğun tonlardan azalan tonlara doğru ayarlayarak 
grafikler üzerinde etkileyici efektler meydana getirebilirsiniz. 

‘Linear modunda doğrusal ton değişimi uygulanır. Radial modundaysa dairesel ton 
değişimi uygulanır. 

1- Ctrl+W tuşlarıyla önceki çalışma sayfalarını kaydetmeden kapatınız. 

2- Ctrl+N tuşlarıyla yeni bir sayfa açınız. 

3- Çalışma alanına (Stage) 300-300px boyutlarında bir dörtgen çiziniz. 

4- Çizdiğiniz dörtgenin iç dolgusunu seçili duruma getiriniz (Nesnelerin seçilmesiyle 
ilgili işlemleri hatırlamak için Uygulama 3.7’ye göz atınız). 

5- Color Mixer panelinde Fill Color düğmesinin yanında yer alan açılır menüden 
Linear seçeneğini seçiniz. 
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Şekil 3.34: Gradyent aracı olarak Linear modunun seçilmesi 

6- Menünün yanında yer alan  simgesine tıklayınız ve bir dolgu rengi 
belirleyiniz. 

 
(A) (B) (C) (D) 

Şekil 3.35: (A) Solid dolgulu grafik nesnesi (B) Linear gradyent etkisinin uygulanması (C) 
Linear gradyent etkisinin ters çevrilmesi (D) Ara gradyentin eklenmesi 

7- Şeklinizin dolgu renginin yoğundan aza doğru değiştiğini görmeniz gerekir. 

8- Ton değişimini renk değiştirme tutamaçları yardımıyla farklılaştırabilirsiniz. 
Şekil 3.36’da görüldüğü gibi fare imlecini soldaki tutamacın üzerine tıklayınız ve 
sağ tarafa sürükleyiniz. Benzer şekilde sağdaki tutamacı da sola sürükleyiniz. 
Aynı etkiyi tutamaçların renklerini değiştirerek de yapabilirsiniz. 

 
 

Şekil 3.36: Tutamaçların yerleri 
değiştiriliyor. 

Şekil 3.37: Yeni bir tutamaç eklenerek 
gradyent etkisi değiştiriliyor. 
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9- Aralara en fazla 8 adet tutamaç ekleyebilirsiniz. (Flash 8’de bu sayı 16’ya 
çıkartılmıştır.) Bunun için tutamacı eklemek istediğiniz noktada renk bandı 
üzerine tıklayınız. Yeni bir tutamaç çıkar. Şekil 3.37’de olduğu gibi üçüncü bir 
tutamaç eklediğinizde şeklinizin son durumu şekil 3.35 (D) görünümünü alır. 

10- İstediğiniz tutamacı kaldırmak için üzerine tıklayınız ve kaydıracın dışına bir 
noktaya sürükleyiniz ve tuşu bırakınız. Kaydıracın yok olduğunu göreceksiniz. 

3.5. Şekilleri Gruplamak 

Uygulama-3.13: Nesnelerin gruplanması ve öncelik sıralamalarının değiştirilmesi 

1- Çalışma sayfasına dış çerçevesi olan bir oval ve bir dörtgen çiziniz. Dörtgeni seçili 
duruma getiriniz ve oval şeklin bir kısmını örtecek şekilde ovalin üzerine getiriniz. 

2- Dörtgeni seçili durumdan kurtarınız. (Çalışma alanında boş bir yere tıklayınız ya 
da Esc tuşuna basın.) Dörtgeni tekrar seçiniz ve başka bir yere sürükleyiniz. Oval 
şeklin dörtgen tarafından örtülen kısmının silindiğini gördünüz mü? (Şekil 3.38) 

 

Şekil 3.38: (A) İki farklı grafik öğesi (B) Sağdaki grafik soldakinin üzerine sürükleniyor. (C) 
Sağdaki grafik seçili durumdan çıkartıldıktan sonra tekrar seçiliyor ve başka bir konuma 

sürükleniyor. Soldaki şeklin örtülen kısmı siliniyor. 

3- Çalışma sayfasına yeni bir grafik öğesi ekleyiniz. Ok aracıyla şeklin üzerine iki 
kere tıklayınız ya da tüm şekli seçecek şekilde grafik öğesini seçim alanı içine 
alınız. 

4- Şeklinizi seçili duruma getirdikten sonra Modify menüsünden Group komutunu 
çalıştırınız ya da Ctrl+G tuşlarına basınız. 

5- Şeklinizin dışında mavi bir çerçevenin oluştuğunu göreceksiniz. Artık tek parça 
halinde kullanabileceğiniz, diğer bir ifadeyle grup altına aldığınız bir nesne elde 
etmiş oldunuz. Çerçeveye çift tıklayınız ve grubun içine giriniz. Grup öğeleri 
seçili duruma gelir. 
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6- Çalışma alanında boş bir yere çift tıklayarak grup moduna geri dönünüz. 

 GRUPLAR: Grafik öğelerini grup altına alarak onlar üzerinde tek parça 
halinde her türlü değişikliği yapabilirsiniz. Taşıyabilir, boyutunu değiştirebilir, döndürebilir 
ve en önemlisi yerleşim sıralarını değiştirebilirsiniz. 1. ve 2. adımlarda gördüğünüz gibi grup 
altına alınmayan şekiller üst üste geldiklerinde birbirlerini keser, şekillerde bozulma 
meydana gelir. 

Grubu çözmek için grubu seçili duruma getirdikten sonra Modify menüsünden 
Ungroup komutunu veriniz. 

7- Çalışma alanına farklı bir şekil çiziniz ve çizdiğiniz bu şekli de grup altına alınız. 

8- Modify menüsünden Arrange komutu altından Send to Back değerini seçiniz. 

9- Çizdiğiniz ikinci şekle tıklayınız ve diğer şeklin üzerine sürükleyin. İkinci şeklin 
ilk şeklin altında kaldığını gördünüz mü? 

10- Çalışma alanına üçüncü bir şekil çiziniz. O şekli de grup altına alınız. Modify 
menüsünden Arrange komutu altından Bring to Front komutunu veriniz. 

11- Çizdiğiniz üçüncü şekli diğer iki şeklin üzerine sürükleyiniz. Üçüncü şeklin en 
üstte, ikinci şeklin en altta, birinci şeklin ortada yer aldığını görürsünüz. 

 

Şekil 3.39: Grupların yerleşim 
sıralarının ayarlanması 

 

Şekil 3.40: Arrange komutu altından grupların 
yerleşim sıralarının değiştirilmesi 
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 Bring to Front: Grubu en öne getirir. 

 Bring Forward: Grubu bir derece öne getirir. 

 Send Backward: Grubu bir derece arkaya atar. 

 Send to Back: Grubu en arkaya atar. 

 Lock: Grubu çalışma sayfasına sabitler. Hareket ettirilemez. Unlock All 
komutuyla tüm kilitli nesneler bu durumdan kurtulur. 

Uygulama-3.14:Grup altına alınan grafik nesnelerinin Alpha değerlerinin 
değiştirilmesi 

Alpha Değeri: Bu değer yardımıyla grafik nesnelerinin saydamlık değerini 
ayarlayabilirsiniz. Böylece nesneler üst üste gelse bile alttaki nesne gözükebilir. 

1- Çalışma sayfasına dolgu renkleri farklı ve katı dolgulu (Solid) iki grafik öğesi 
çiziniz ve grup altına alınız. 

2- Grup altına aldığınız şekillerden birinin öncelik sırasını Modify → Arrange → 
Bring to Front komutuyla en öne getiriniz. 

3- Öne aldığınız şekle iki kere tıklayarak grubun içine giriniz ve dolguyu seçili 
duruma getiriniz. Color Mixer panelinden Alpha değerini %30’a çekiniz. 

4- Çalışma alanında boş bir yere iki kere tıklayınız ve şeklin grup moduna dönmesini 
sağlayınız. 

5- Şekli ok aracıyla tutunuz ve diğer şeklin üzerine getiriniz. Sonuca dikkat ediniz. 

 
Şekil 3.41: (A) Kırmızı dolgulu opak (%100 alpha) görüntülü grafik öğesi (B) Saydam 

görüntünün elde edilmesi 
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3.6. Katmanlar Üzerinde Grafik İşlemleri Gerçekleştirmek 
 
Flash ve benzer grafik yazılımlarının sunduğu en önemli özellik katmanlara ayrılmış 

çalışma sayfaları üzerinde birbirini etkilemeyen grafik öğeleri ve nesnelerle çalışabilmektir. 
Daha önce nesnelerin grup altına alınması (Uygulama-3.13) anlatılırken görüntü öncelikleri 
değiştirilmişti. Böylece grafiklerin birbirlerini etkilemeleri engellenmişti. 

 
Ancak tek bir çalışma alanında çok daha fazla nesne ve grafik öğesinin yer alması 

durumunda bunları organize etmek zorlaşır. Bunu ortadan kaldırmak için çalışma sayfasına 
birden fazla katman ekleme yeteneği geliştirilmiştir. Her bir katman birbirinden bağımsızdır. 
Şimdi sözü fazla uzatmadan uygulamalara geçebiliriz. Katmanların ne olduğunu daha iyi 
anlayacaksınız. 

 
3.6.1 Farklı Katmanlar Oluşturmak 

Uygulama-3.15: Birden fazla katmanın ve katman klasörünün oluşturulması 

1- Boş bir çalışma sayfası açınız. Şekil 3.42’de görüldüğü gibi Timeline panelinde 
Layer 1 adında katman yer alır. 

 
Şekil 3.42: Flash MX’de yeni açılan boş çalışma sayfasının Timeline panelinin ilk görüntüsü 

2- Şekil 3.43’ten yararlanarak yeni katman ekleme butonuna tıklayınız. Layer 2 
isimli yeni bir katman önceki katmanın üstüne eklenecektir. 
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Şekil 3.43: Katmanlar üzerinde işlem gerçekleştiren kısayol butonları 

 

3- Henüz grafik işlemi yapmadığınızdan her iki katmanın birinci karelerinde içi boş 
daire görünmesi gerekir. Layer 1 isimli katmanı seçiniz ve çalışma alanına 
rastgele şekiller çiziniz. 

4- Layer 1 katmanının ilk karesinin içi dolgulu hale gelmiş olması gerekir. 

 
(A) (B) (C) 

 
Şekil 3.44: (A) Layer 1 katmanına grafik öğeleri çiziliyor. (B) Layer 2 katmanına grafik öğeleri 

çiziliyor. (C) Layer 2 katmanı Layer 1 katmanının altına sürükleniyor. 

5- Layer 2 katmanını seçiniz ve ilk katman seçiliyken çizmiş olduğunuz şekillerin 
üzerine gelecek şekilde yeni şekiller çiziniz. 
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6- Şekil 3.44’te görüldüğü gibi katman öğelerinin gizlenmesini ya da görünmesini 
sağlayan göz simgesinin ( ) hizasına gelen noktaya tıklayınız 
(  - noktanın üzerinde kırmızı çarpı işareti belirir) ve 
Layer 2 katmanı öğelerini gizleyiniz. 

7- Üzerinde kırmızı çarpı oluşan noktaya tekrar tıklayınız ve Layer 2 katmanı 
öğelerini görünür kılınız. Layer 2 katman yazısının üzerine tıklayınız ve tuşu 
bırakmadan Layer 1 katmanının altına sürükleyiniz. Daha önce üstte yer alan 
Layer 2 katmanı öğelerinin bu sefer altta kaldığını görmeniz gerekir. 

3.6.2. Katmanlarda Grafik İşlemlerini Yapmak ve Katman Klasörlerini 
Oluşturmak 

Uygulama-3.16:Çok sayıda katman hazırlanması ve ilişkili katmanların ortak 
klasörler altında toplanması 

1- Önceki sayfaları kapatarak yeni bir boş çalışma sayfası açınız. 

2- Layer 1 katmanının üzerine sağ tıklayınız ve çıkan menüden Properties… 
değerini seçiniz. Açılan Layer Properties penceresinde Name değerine grafik 
adını giriniz ve onaylayınız. Katman adının değişmiş olması gerekir. Bu işlemi 
adını değiştirmek istediğiniz katmanın yazısına çift tıklayarak ve istediğiniz bir 
adı yazarak da yapabilirsiniz. 

3- Grafik2 adında ikinci bir katman oluşturunuz. 

4- Grafik katmanını seçiniz ve çalışma alanının sol üst köşesine bir daire çiziniz. 
Dairenin iç dolgusunu seçiniz ve Color Mixer panelinden Radial Gradyent 
uygulayın (gradyent etkileri için Uygulama-3.12’ye göz atınız.) Daireye Arrow 
Tool aracıyla iki kere tıklayıp seçili duruma getiriniz ve sağ tıklayarak çıkan 
menüden Convert to Symbol komutunu veriniz. Çıkan iletişim penceresinde isim 
alanına amblem adını veriniz ve üç durumlu Type isimli tercihten Movie Clip 
değerini seçiniz. 

5- Grafik2 katmanına dış çerçevesi olmayan bir dörtgen çiziniz. 

6- Grafik katmanını seçiniz ve sağ üst köşeye dörtgen çiziniz. Bunu da seçili duruma 
getiriniz ve bayrak adında bir Movie Clip nesnesi olarak ayarlayınız. 

7- Timeline panelinde  simgesine tıklayarak bir katman klasörü oluşturunuz. 
Folder 3 adında bir klasör oluşması gerekir. Üzerine çift tıklayınız ve adını grafik 
grubu diye değiştiriniz. 

8- Grafik katmanına tıklayınız klavyenin Shift tuşuna basılıyken grafik2 katmanına 
da tıklayınız. Her iki katmanın da seçildiğini görmeniz gerekir. Shift tuşunu 
bırakınız ve her iki katman da seçiliyken herhangi birine fareyle tıklayarak grafik 
grubu isimli klasörün üzerine doğru katmanları sürükleyiniz (Şekil 3.45-3.46). 
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Şekil 3.46: Katmanların gizlenmesi ya da görünür 
yapılması 

Şekil 3.45: Katmanların katman klasörü 
içine taşınması 

 

Şekil 3.47: Timeline panelinin son şekli 

9- Grafik grubu katman klasörünü seçiniz ve yeni bir katman ekleyiniz. Eklenen 
yeni katmanın katman klasörü dışında yer alması gerekir. 

10- Eklediğiniz yeni katmana mesaj adını veriniz (Şekil 3.47). Çalışma alanına metin 
aracını kullanarak (Text Tool - A) içinde istediğiniz bir yazının yer aldığı metin 
kutusu ekleyiniz. 

Çok karmaşık ve çok fazla öğenin yer aldığı filmler hazırlarken belli bir konuyla 
ilişkili katmanlarınızı grup altına almanız sizlere büyük kolaylık sağlar.  

 

3.6.3. Kılavuz ve Maske Katmanlarıyla Çalışmak 

Uygulama-3.17: Kılavuz katmanı yardımıyla bir Motion Tween canlandırmasının 
yapılması ve maske katmanının kullanılması. 

1- Yeni bir çalışma sayfası açınız. Layer 1 katmanının adını maske olarak 
değiştiriniz. 

2- Katmanın üzerine sağ tıklayın ve Properties komutuyla Layer Properties 
iletişim penceresini açınız. Type isimli radyo butonlarından oluşan seçme 
menüsünde mask değerini seçiniz ve pencereyi kapatınız. 



 

 50

3- İkinci bir katman ekleyiniz. Eklediğiniz Layer 2 isimli katman eğer maske 
katmanının üstünde oluşturulmuşsa üzerine tıklayınız ve maske katmanının altına 
gelecek şekilde sürükleyiniz. 

 

Şekil 3.48: (A) Katmanın maske katmanı olarak ayarlanması (B) maske katmanı altında yeni 
bir katman oluşturulması 

4- Layer 2 katmanın simgesinin Şekil 3.48 (B)’de olduğu gibi değişmesi gerekir. 
Üzerine sağ tıklayarak Properties komutuyla Layer Properties iletişim 
penceresini açınız. Type: menüsünde Masked değerinin seçili olduğunu 
göreceksiniz. 

5- Maske katmanını seçiniz ve üçüncü bir katman ekleyiniz. Layer 3 adını ay adıyla 
değiştiriniz.  (Add Motion Guide) simgesine tıklayınız ve ay katmanının 
üzerinde Guide: ay isimli bir kılavuz katmanı oluşturunuz. 

 

Şekil 3.49: Oluşturulan katmanların Timeline panelindeki dizilimleri bu şekilde olmalıdır 

6- Maske katmanını seçiniz ve şekil 3.50’ye benzer bir şekil çiziniz. Şekli seçiniz ve 
üzerine sağ tıklayarak Convert to Symbol komutunu veriniz. Açılan pencerede 
Name değerine maske adını yazınız. Type tercihi olarak Movie Clip değerini 
seçiniz. 
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Şekil 3.50: Maske katmanında maske olarak kullanılacak grafik öğesinin çizilmesi ve maske 
sembolüne dönüştürülmesi 

7- Maske katmanını seçiniz ve Properties panelinde Tween isimli açılır menüden 
Motion değerini seçiniz. 

8- Maske katmanı hizasındaki zaman çizelgesinde 20. karenin üzerine sağ tıklayınız 
ve Insert Keyframe komutunu vererek anahtar kare eleyiniz. Böylece şeklinizin 
bir kopyasının 20 kare boyunca yer aldığı ve zaman çizelgesinde 1. kareden 20. 
kareye kadar bir ok simgesinin oluştuğu bir doğrusal hareket animasyonu 
hazırlamış oldunuz. 

9- Çizdiğiniz şekli seçiniz ve klavyenin sağ yön tuşuyla bir miktar sağa doğru 
hareket ettiriniz. 

 

Şekil 3.51: maske katmanında bir Motion Tween – Hareket Animasyonu hazırlanması 

10- Maske katmanını  simgesine tıklayarak gizleyiniz ve Layer 2 katmanını 
seçiniz. Şekil 3.52’dekine benzer bir şekil çiziniz ve şekil isminde bir Movie Clip 
sembolüne dönüştürünüz. 
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11- 20. karenin üzerine sağ tıklayıp çıkan menüden Insert Keyframe komutunu 
vererek aynı şeklin 20 kare boyunca yer almasını sağlayınız. 

 

Şekil 3.52: Layer 2 katmanında sekil isimli grafik öğesinin oluşturulması 

12- Ay katmanını seçiniz ve bir hilal çiziniz. Çizimi daha rahat gerçekleştirebilmek 
için diğer katmanların görüntülerini gizleyiniz. Hilali Layer 2 katmanında 
çizdiğiniz şeklin ortasına denk gelecek şekilde çiziniz. 

13- Ay katmanını seçiniz ve Motion Tween oluşturunuz. Çizdiğiniz hilal şeklini 
seçiniz ve sağ tıklayarak Convert to Symbol komutunu veriniz. Hilal isminde 
Movie Clip nesnesine çeviriniz. 20. karenin üzerine sağ tıklayınız ve Insert 
Keyframe komutuyla hilal şeklinin 20. kareye kadar yer almasını sağlayınız. 
Diğer katmanların da içeriklerini görünür duruma getiriniz. 

 

Şekil 3.53: Hilal şeklinin oluşturulması ve Motion Tween canlandırmasının hazırlanması 

14- Maske ve Layer 2 katmanlarının içeriklerini gizleyiniz. Guide: ay katmanını 
seçiniz. Ay katmanında çizilmiş olan hilal şeklinin kılavuz yolunu belirlemek için 
şekil 3.54’tekine benzer bir şekli Pencil Tool aracını kullanarak çiziniz. 
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15- Birinci karede hilal şeklini seçiniz ve şeklin merkezinde gözüken daire şekli 
çizmiş olduğunuz çizginin bir ucuna kenetlenecek şekilde hilal şeklini ayarlayınız 
(Şekil 3.54). 

 

 

Şekil 3.54: Kılavuz yolunun çizilmesi ve 
hilalin kılavuza kenetlenmesi 

Şekil 3.55: Hilalin kılavuzun 
diğer ucuna kenetlenmesi 

16- Guide: ay katmanını seçiniz ve 20. kareye sağ tıklayarak Insert Keyframe 
komutunu veriniz. 20. kare üzerindeyken hilal şeklini seçiniz ve şekil 3.55’te 
gösterildiği gibi hilal şeklini çizginin diğer ucuna kenetleyiniz. 

Kılavuz (Guide) Katmanı Hakkında: Özellikle Motion Tween animasyonu 
yapılırken kullanılır. Belli bir yol boyunca hareket etmesini istediğiniz Movie Clip sembolü 
için hareket yolu çizilir. Sembolünüz bu yol boyunca hareket eder. Modülün Canlandırmalar 
bölümünde daha ayrıntılı olarak bahsedilecektir. 

17- Zaman çizelgesinde o an üzerinde bulunulan karede yer alan kırmızı renkli 
oynatıcı çizgisini seçiniz ve 1.kare ve 20. kare arasında hareket ettiriniz. Hilal 
şeklinin çizilen kılavuz yolu boyunca hareket ettiğinden emin olunuz. 

 
Şekil 3.56: Oynatıcı çizgisi 

Maske (Mask) Katmanı Hakkında: 
Maske katmanında yer alan grafikler, filminiz 
oynatıldığında gözükmez. Maske katmanının amacı 
maskelediği katmanlarda yer alan grafiklerin istenilen 
kısımlarının gösterilmesini sağlamaktır. 

Maske katmanı kullanarak çok hoş etkiler 
yapılabilir. Maske katmanında çizilen grafiğin hizasına 
gelen nesneler gözükür. 

18- Control menüsünden Test Movie komutunu veriniz ve filmi çalıştırınız. Maske 
katmanının içi dolgulu bölgelerine denk gelen Layer 2 katmanındaki şeklin 
gözükmesi gerekir. Aynı zamanda maske katmanı hareket ettiğinden dolayı şeklin 
gözüken kısmının sürekli değişmesi gerekir. 
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UYGULAMA FAALİYETİ 
  

İşlem Basamakları Öneriler 

1) Çalışma sayfasında 10px-10px 
boyutlarında hücrelerden oluşan ızgara 
oluşturunuz. Izgara kenarlarının nesnelere 
kenetlenme özelliğini etkinleştiriniz. 

 View → Grid → Edit Grid komutunu 
verip, Show Grid ve Snap to Grid 
seçeneklerini işaretleyebilirsiniz. 

2) 400px-200px boyutlarında boş bir 
çalışma sayfası açınız. Düşeyde 200px ve 
300px noktalarında yatayda da 50px ve 
150px noktalarında kılavuz çizgileri 
oluşturunuz. 

 

3) Çalışma alanına içi dolgulu 200px 
genişliğinde 150px yüksekliğinde bir oval 
çiziniz. Çizdiğiniz ovalin dış çerçeve 
çizgisini yok ediniz. 

 Oval aracıyla çiziminizi yaptıktan sonra 
ok (Arrow) aracıyla şekli seçebilir ve 
Properties panelinde W ve H değerlerini 
değiştirebilirsiniz. 

3) Ovalın dolgu rengini değiştirin. Ovalı 
seçiniz ve grup altına alınız.  

 Grup işlemi için Uygulama-3.13’ten 
yararlanabilirsiniz. 

6) Çalışma alanının ortasına 200px-200px 
genişliğinde bir dikdörtgen çiziniz. Bu 
dikdörtgenin yalnızca 100px-100px 
boyutlarında orta kısmını gösterecek bir 
maske katmanı oluşturunuz. 

 Maske katmanının üstte olması 
gerektiğini, maskelenecek katmanınsa 
masked biçiminde olması gerektiğini 
unutmayınız! 

 

 UYGULAMA FAALİYETİ 
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ÖLÇME VE DEĞERLENDİRME 
  
 
Bu bölümde Öğrenme Faaliyeti-3’te anlatılan konular hakkında bilginizi ölçmek 

amacıyla çoktan seçmeli sorular sorulacaktır. Soruları duyarlılıkla yanıtlamanız önerilir. 
 
A. ÖLÇME TESTİ 
1. Bir grafik öğesinin dolgu gradyenti hangi panelden değiştirilir? 

A) Color Swatches   
C) Properties  
B) Color Mixer    
D) Tools 
 

2. Color Mixer panelinde yer alan Alpha değerinin işlevi nedir? 
A) Seçili grafik öğesinin saydamlık değerini ayarlar. 
B) Seçili grafik öğesinin parlaklığını ayarlar. 
C) Seçili grafik öğesinin ekrandaki konumunu ayarlar. 
D) Seçili grafik öğesinin daha ayrıntılı incelenmesini sağlar. 
 

3. Ink Bottle Tool ( ) aracının işlevi nedir? 
A) Üzerine tıklandığı grafik öğesinin dolgu rengini değiştirir. 
B) Metin rengini değiştirmek için kullanılır. 
C) Zemin rengini değiştirmek için kullanılır. 
D) Üzerine tıklandığı grafik öğesinin çerçeve niteliklerine (renk, boyut, vb.) ayarlı 

(mevcut) değerleri atar. 
 

4. Free Transform Tool ( ) aracının işlevi nedir? 
A) Seçili grafik öğesini yalnızca döndürmek için kullanılır. 
B) Seçili grafik öğesinin boyutlarını ölçekli olarak değiştirmek için kullanılır. 
C) Üzerine tıklanan grafik öğesini seçer ve üzerinde boyutlandırma ve döndürme 

işlemleri yapılır. 
D) Grafik öğesinin şeklini değiştirmek için tutamaçlar oluşturur. Tutamaçlardan şeklin 

biçimi değiştirilir. 
 

5. Araçlar panelinde yer alan Options bölümünün işlevi nedir? 
A) Metin nitelikleriyle ilgili ayarlar yapılır. 
B) Grafik öğelerinin renk düzenlemeleri yapılır. 
C) Seçili grafik öğesiyle ilgili işlemler yapılır. 
D) Seçili aracın eğer varsa nitelikleri ayarlanır. 

6. Fare imleci yandaki şekli ( ) ne zaman alır? 
A) Fare imleci bir grafik öğesinin keskin köşeli kısmına yaklaştırıldığı zaman 
B) Fare imleci bir grafik öğesinin düz ya da yumuşak eğimli bir köşesine 

yaklaştırıldığı zaman 
C) Fare imleci grup altına alınmış bir nesnenin köşesine yaklaştırıldığında 
D) Seçili bir grafik öğesi taşınacağı zaman 

 ÖLÇME VE DEĞERLENDİRME 

alonso
Vurgu



 

 56

7. Fırça aracının (Brush Tool - ) Paint Inside niteliği nasıl bir boyama etkisi 
oluşturur? 
A) Herhangi bir grafik öğesinin üzerinden geçilen bölgesini dolgu rengine boyar. 
B) Herhangi bir grafik öğesinin ya da çalışma alanının yalnızca iç kısmını boyar. 
C) Herhangi bir grafik öğesinin arkada kalan tarafını boyar. 
D) Herhangi bir grafik öğesinin yalnızca dolgu rengini boyar. 
 

8. Bir grafik öğesine gradyent etkisi uygulamak için aşağıdakilerden hangisi yapılır? 
A) Grafik öğesi seçildikten sonra Color Swatches panelinden istenen gradyent seçilir. 
B) Grafik öğesi seçildikten sonra özellikler panelinden istenen gradyent seçilir. 
C) Araçlar panelinden istenen gradyent seçilir ve şekil çizilir. 
D) Grafik öğesi seçildikten sonra Color Mixer panelinde renk kutusunun yanındaki 

açılır menüden istenen gradyent etkisi seçilir. 
 

9. Modify menüsünden ulaşılan Break Apart komutunun işlevi nedir? 
A) Seçili bir grafik öğesini grup altına alır. 
B) Seçili bir grafik öğesini ölçeklendirmek için kullanılır. 
C) Bir metin ya da grafik grubunun parçalarına ayrılmasını sağlar. 
D) İç içe girmiş çok sayıda gruptan oluşan bir nesneden tüm grupları kaldırır. 
 

10. Break Apart komutu iki defa uygulanarak parçalarına ayrılmış bir metin üzerinde 
aşağıdaki işlemlerden hangisi yapılamaz? 
A) Yazı tipi değiştirilebilir. 
B) Boyutu vektörel olarak değiştirilebilir. 
C) Her bir karakterinin rengi ayrı ayrı değiştirilebilir. 
D) Ink Bottle Tool aracıyla her bir karaktere çerçeve çizilebilir. 
 

11. Yandaki simgenin ( ) işlevi nedir? 
A) Seçili katmanı silmek 
B) Yeni bir katman eklemek 
C) Katman klasörü eklemek 
D) Hareket kılavuzu eklemek 
 

12. Yandaki simgenin ( ) işlevi nedir? 
A) Seçili katmanın içeriğini siler. 
B) Yalnızca seçili katmanın içeriğini gizler ya da gösterir. 
C) Tüm katmanların içeriğini gizler ya da gösterir. 
D) Seçili katman üzerinde işlem yapılmasını engeller. 
 

13. Kılavuz katmanıyla ilgili söylenenlerden hangisi yanlıştır? 
A) Kılavuzluğunu yaptığı katmanda yer alan grafik öğeleri için hareket yolu belirlenir. 
B) Birden fazla katmana kılavuzluk yapabilir. 
C) Bir sahnede birden fazla kılavuz katmanı yer alabilir. 
D) Bir kılavuz katmanında yalnızca bir tane kılavuz yolu olabilir. 
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14. Aşağıdakilerden hangisi birden fazla katmanla çalışmanın yararlarından değildir? 
A) Grafik öğelerini Movie Clip nesnelerine dönüştürmeye gerek kalmaz. 
B) Farklı işlemler farklı katmanlarda yapılarak düzen sağlanır. 
C) Katmanların sıraları değiştirilerek grafik öğelerinin görüntü sıraları ayarlanır. 
D) İstenen katman gizlenerek üzerinde çalışılan katmanda daha rahat işlem yapılır. 
 

15. 1. kare üzerinde birkaç öğe yer almaktadır. 20. kareye sağ tıklanıp Insert Blank 
Keyframe komutu verildiğinde ne olur? 
A) 20. kare de dâhil 1-20 arası tüm kareler aynı öğelerle doldurulur. 
B) 1-19 arası kareler aynı öğelerle doldurulur. 20. karede bağımsız içi boş bir sayfa 

oluşturulur. 
C) 1-19 arası kareler aynı öğelerle doldurulur. 20. karede bağımsız içi dolu bir sayfa 

oluşturulur. 
D) 1. kare hariç 20. kareye kadar tüm karelere boş sayfalar yerleştirilir. 

 

 

DEĞERLENDİRME 

Ölçme sorularının çoğunu doğru yanıtlamış ve eksiklerinizi gözden geçirmişseniz bir 
sonraki öğrenme faaliyetine geçebilirsiniz. 

alonso
Vurgu



 

 58

ÖĞRENME FAALİYETİ–4 
  

 
Bu öğrenme faaliyetinde Flash’ın esnek metin aracıyla çeşitli metin 

biçimlendirmelerini nasıl yapacağınızı öğreneceksiniz. 
  

 
Metin ve grafik öğeleri arasındaki farkı araştırınız. Örneğin bir kelime işlemci 

yazılımında yazdığınız metinle bir resim editöründe yazdığınız metin arasında ne gibi bir 
farkın olduğunu anlamaya çalışınız. 

 

4. METİN İŞLEMLERİ 
GERÇEKLEŞTİRMEK 

Diğer masaüstü yayıncılık yazılımlarında olduğu gibi Flash’la da metin işlemleri 
yapılabilir. 

4.1. Metinlerle Çalışmak 

Uygulama–4.1: Belgeye metin eklenmesi 

1- Araç kutusundan metin aracını (Text Tool - ) seçiniz. 

 

Şekil 4.1: Çalışma sayfasına metin eklenmesi 

2- Metin aracını seçince çalışma alanının altında yer alan Properties panelinde metin 
aracıyla ilgili nitelikler gözükecektir. Metin türü olarak Static Text seçiniz. 
Çalışma alanına şekil 4.1’de gösterildiği gibi klavyeden bir metin yazınız. Metnin 
etrafında çerçeve oluştuğunu göreceksiniz. 

ÖĞRENME FAALİYETİ–4 

 AMAÇ 

 ARAŞTIRMA 
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Şekil 4.2: Metne hyperlink eklenmesi 

3- Şekil 4.2’de görüldüğü gibi metne hyperlink bağlantısı eklemek için ilgili alana 
bir internet adresi giriniz. 

 Hyperlink hakkında: Durağan metinlere hyperlink bağlantısı ekleyebilirsiniz. 
Böylece Flash filminizi oynatıp fare imlecini bağlantı eklediğiniz metin üzerine 

getirdiğinizde imleç el ( ) şeklini alır. Metin üzerine tıkladığınızda ilgili adrese gidilir. 
Bağlantı eklenmiş metnin altında kesikli çizgi oluşur. Ancak bu çizgi, filminizi 
oynattığınızda gözükmez. 

4- Metni kaplayan kutunun dışına tıkladığınızda metin kutusu kaybolur. Ancak metin 
bir bütündür ve seçildiğinde metin kutusu gözükür. Metnin niteliklerini 
değiştirmek için metni seçili duruma getirmeniz gerekir. 

4.2. Metin Niteliklerini Ayarlamak 

Metin nitelikleri, metnin yazı tipi (Font), boyutu (Size), yazı şekli (Style),  
hizalanması (Align) ve harfleri arasındaki mesafe (Letter Spacing) olarak sıralanabilir. Bu 
nitelikler şekil 4.3’te gösterildiği gibi Text menüsünden ya da şekil 4.1’de gösterildiği gibi 
Properties panelinden değiştirilebilir. 

 

Şekil 4.3: Metin niteliklerinin menü araç çubuğunda yer alan Text menüsü kullanılarak 
ayarlanması 
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Bu niteliklerin dışında Static Text, Dynamic Text ve Input Text olmak üzere üç 
farklı metin türü vardır. Static Text türü durağan metinler yazmak için kullanılır ve kontrol 
edilemez. Dynamic Text ise bir değişken adı olan ve kendisine değer gönderilebilen metin 
türüdür. Input Text ise daha çok elektronik form hazırlanmasında kullanılan ve veri girişi 
için kullanılan, dolayısıyla bir değişken adına sahip olan metin türüdür. 

Flash’ın dâhili ActionScript dili ve değişkenlerle veri türleri anlatılırken Dynamic 
Text ve Input Text metin türleriyle ilgili uygulamalar yapılacaktır. 

Uygulama-4.2: Metin niteliklerinin ayarlanması 

1- Araç çubuğundan metin aracını seçiniz. 

2-  Properties panelinden Static Text metin türünü 
seçiniz. 

3-  Metin tipi olarak Arial yazı tipini seçiniz. 

4-  Metin harfleri arasındaki mesafeyi ayarlayan kaydıracı 15 değerine 
getiriniz. 

5-  Metin boyutunu, rengini, şeklini ve 
hizalanma yönünü ayarlamayı sağlayan değerleri isteğinize göre değiştiriniz. 

6-  Metnin ekranda nasıl görüneceğini ayarlamayı 
sağlayan ve dört farklı seçenekten oluşan görüntü tercihlerinden birini seçiniz. 

7- Çalışma alanına bir metin yazınız. Metnin dışına tıklayın ve araç çubuğundan ok 
aracını (Arrow Tool) seçiniz. Yazdığınız metne tıklayınız. Metin kutusunu 
görmeniz gerekir. Bu durumda metin seçilidir. 

8- Metin seçiliyken yukarıdaki işlem adımlarını farklı değerler için bir kez daha 
uygulayınız. Ctrl+Enter tuş ikilisiyle ya da Control → Test Movie komutuyla 
sonucu izleyiniz. 
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4.3. Metinler Üzerinde Grafik İşlemleri Gerçekleştirmek 
 
Metinler Uygulama-4.1 ve Uygulama-4.2’de görüldüğü gibi bir bütündür ve grafik 

nesnesi değildir. Metinleri grafik nesnesine çevirerek her bir harfi birbirinden bağımsız hale 
getirebilir ve üzerlerinde istediğiniz grafik işlemini yapabilirsiniz. 

Uygulama-4.3: Metinlerin parçalanması ve grafik öğesi haline getirilmesi 

1- Araç kutusundan metin aracını seçiniz. Çalışma alanına istediğiniz bir yazı 
yazınız. 

2- Metni seçiniz ve Modify menüsünden Break Apart (Parçalarına Ayır) komutunu 
uygulayınız ya da Ctrl+B tuşlarına basınız. 

3- Bir bütün olan metin harflerine ayrılır ve her bir harf birbirinden bağımsızdır. 
Tekrar Break Apart komutunu uygulayınız. 

(A) 

(B) 

(C) 
 

Şekil 4.4: (A) Bütün metin grubu. (B) Break Apart komutu uygulanmış metin grubu. Artık her 
bir harf bağımsız. (C) Break Apart komutu ikinci kez uygulanıyor. Artık yazı metin özelliğini 

kaybediyor. 

4- Break Apart komutuyla parçalara ayırdığınız yazı metin özelliğini kaybetmiş 
olduğundan her bir harf üzerinde istediğiniz grafik işlemini yapabilirsiniz.  

 

İpucu : Break Apart komutuyla grup altına alınmış tüm grafikleri öğelerine 
ayırabilirsiniz. 
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4.4. Dinamik Metinlerle Çalışmak 

Dinamik metinler, kendilerine değer gönderilebilen metin kutularıdır. Çalışma 
alanının herhangi bir noktasına dinamik metin türünde metin kutusu eklediğinizde ve içine 
hiçbir şey yazmadığınızda metin kutusu kesik çizgilerle gösterilir. İçine başka bir yerden 
değer gönderebilirsiniz ya da kendisine daha önceden gönderilmiş değeri okuyabilirsiniz. 

Dinamik metin kutularıyla çalışmanın yolu değişken olarak adlandırılan, çeşitli türden 
verileri tutmayı sağlayan değerleri kullanmaktır. Örnek vermek gerekirse bir nüfus kimliğini 
ele alalım: 

Nüfus kimlğinde; Kimlik Nu, Soyadı, Adı vb. başlıklar vardır. Bu başlıkları değişken 
olarak adlandırırsak bu değişkenlere girilen bilgiler de veri olur. Zaten değişken kelimesi 
duruma göre sakladığı veri değişen anlamına gelmektedir. Dinamik metin kutularının bir 
değişken adı olmalıdır ki, bu değişken adına atıfta bulunarak değer gönderebilelim. 

 

İpucu : Bilgisayar programcılığı konusundaki tecrübelerinizden yararlanarak 
değişken adı verilirken dikkat edilmesi gereken kuralları hatırlamaya çalışınız. 

 

Uygulama-4.4: Flash bileşenlerinden (components) radyo butonlarına duyarlı 
dinamik metin kutusunun hazırlanması 

1- Boş bir çalışma sayfası açınız. 

2- Timeline panelinde yer alan  - Insert Layer simgesine tıklayarak yeni bir 
katman ekleyiniz. 

3- Eklenen katmana iki kere tıklayınız ve Layer 2 adını siliniz, katman adı olarak 
Kontrol Katmanı yazınız. 

4- Layer 1 katmanına iki kere tıklayınız ve katmana mesaj adını veriniz. 

5- Eylem adında yeni bir katman daha ekleyiniz. 

6- Eylem katmanı seçiliyken Window menüsünden Actions komutuyla ya da F9 
tuşuyla Actions-Eylemler penceresini açınız. 

7- Pencerede şekil 4.5’te gösterilen simgeyi bulunuz ve tıklayarak açılan menüden 
Expert Mode değerini seçiniz. 

 Kod Yazım Modları Hakkında: Flash’ta iki tür kod yazım modu vardır. 
Actions penceresi iki ana bölümden oluşur. Sol tarafta Flash tarafından kullanılan kodların 
bir listesinin yer aldığı bölüm, sağ taraftaysa kodların yazıldığı bölüm vardır. Eğer 



 

 63

yazacağınız kodları ezbere bilmiyorsanız sol taraftaki bölümden yararlanarak ilgili kodu 
seçebilir ve sağ tarafa yerleştirebilirsiniz. Bu kod yazımı Normal Mode olarak adlandırılır. 
Diğer kod yazım modundaysa (Expert Mode) kodlar ezbere yazılır. Flash 8’de Normal ve 

Expert kod yazım modlarına geçmek için  düğmesi kullanılmaktadır. 

 
Şekil 4.5: ActionScript kodunun yazılması için Expert Mode modunun seçilmesi 

 
8- Şekil 4.6’da gösterilen ActionScript kod yazım alanına tek satırdan oluşan işaretli 

kodu dikkatlice yazınız. 

 
Şekil 4.6: Eylem katmanına ActionScript kodunun yazılması 

9- Actions penceresini kapatınız. Kontrol Katmanı katmanına tıklayınız ve seçili 
duruma getiriniz. 

10- Components panelinden RadioButton bileşenini bulunuz. Tıklayınız ve 
sürükleyerek çalışma alanına bu bileşenden ekleyiniz. Aynı şekilde üç tane daha 
radyo butonu ekleyiniz (Şekil 4.7). 

 

 

Şekil 4.7: Çalışma alanına dört adet radyo butonunun 
eklenmesi 

Şekil 4.8: Radyo butonu 
değerlerinin değiştirilmesi 
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11- Radyo düğmelerinden birini seçili duruma getiriniz ve Properties paneline 
giderek aşağıdaki değişiklikleri yapınız (Şekil 4.8): 

Label alanına tıklayınız ve Galatasaray yazınız. 

Initial State alanına tıklayınız ve açılır listeden true değerini seçiniz. 

Group Name alanına takim yazınız. 

Data alanına GALATASARAY yazınız. 

12-  Diğer radyo düğmelerine sırasıyla aşağıdaki değerleri giriniz: 

Label alanına Fenerbahçe, Trabzon ve Beşiktaş, 

Group Name alanına takim (bütün radyo butonlarına), 

Data alanına FENERBAHÇE’, TRABZON’, BEŞİKTAŞ yazılarını yazınız. 

Galatasaray düğmesi dışında diğer butonların Initial State değeri false olacak. 

13- Mesaj katmanını seçiniz ve çalışma alanına yeterince geniş içi boş bir metin 
kutusu ekleyiniz. Şekil 4.9’da gösterildiği gibi Properties panelinden Dynamic 
Text değerini seçiniz. Var: kısmına mesaj yazınız. 

 

Şekil 4.9: Metnin dinamik metin olarak ayarlanması 

14- Mesaj katmanına isterseniz içinde Hangi Takımı Tutuyorsunuz? yazılı statik bir 
metin kutusu ekleyebilirsiniz. 

15- Kontrol Katmanında yer alan Fenerbahçe düğmesini seçiniz ve Actions 
penceresini açın. Aşağıdaki kod satırlarını Expert Mode yazım modunda yazınız. 

on(press){ 
_root.mesaj = "ŞAMPİYON " + this.getData(); 
} 

16- 14. adımı diğer radyo düğmeleri için de uygulayınız. 
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17- Control menüsünden Test Movie komutunu vererek hazırladığınız Flash filmini 
çalıştırınız. Seçtiğiniz değere göre mesaj yazdıran bir canlandırmanın (animasyon) 
ekranı gelmesi gerekir. Eğer böyle bir sonuç almıyor ya da karşınıza hata mesajı 
geliyorsa yukarıdaki adımları gözden geçiriniz. 

 
Şekil 4.10: Seçilen değerlere göre elde edilen ekran çıktıları 

 
Şekil 4.11: Hazırlanan canlandırmanın bitmiş tasarım görüntüsü 

Uygulama Hakkında: 4.4 nu.lı uygulamayla üç katmanlı bir film hazırlandı. Göz 
( ) simgesinin hizasına karşılık gelen noktaya tıklayarak görünen katmanı gizleyebilir, 

gizli katmanı da görünür yapabilirsiniz. Kilit ( ) simgesinin hizasına karşılık gelen noktaya 
tıklayarak seçili katmanı üzerinde değişiklik yapılamayacak duruma getirebilirsiniz. 
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4.4 nu.lı uygulama, dört adet radyo düğmesi yardımıyla ekranın istenen yerinde yazı 
yazdıran bir canlandırmadır. 

Eylem katmanı içinde, canlandırma ilk çalıştırıldığı zaman hangi radyo düğmesi 
varsayılan olarak seçiliyse o radyo düğmesinin Data değerini ŞAMPİYON kelimesine 
ekleyen bir kod vardır. Böylece canlandırmanın ilk durumu denetlenmektedir. 

Ekrana yazdırılan mesaj da ayrı bir katmana yerleştirilmiştir. Bu katmana kontrol 
edilecek başka elemanlar da yerleştirileceği zaman Kontrol Katmanı gizlenebilir ve katman 
üzerinde daha rahat işlem yapılabilir. 

İpucu : Eğer katmanlarınıza ActonScript diliyle eylem yerleştirecekseniz bunu 
ayrı bir katmanda yapmanız yerinde olur. Böylece çok büyük canlandırmalarla 
uğraştığınızda üzerinde değişiklik yapmak istediğiniz katmanı rahatlıkla 
bulabilirsiniz. 
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UYGULAMA FAALİYETİ 
  

İşlem Basamakları Öneriler 

1) Çalışma alanına okulunuzun adını 24pt 
büyüklüğünde ve harf aralığı (Letter 
spacing) 10 değerinde olacak şekilde 
Static Text türünde yazınız. 

 Metin niteliklerini özellikler 
(Properties) panelinden yapabilirsiniz. 

2) Yazdığınız metni seçiniz ve iki defa 
üst üste parçalarına ayırma komutunu 
çalıştırınız. 

 Modify  Break Apart 

3) Metin aracını seçiniz. Metin türünü 
Dynamic Text olarak ayarlayınız. 
Çalışma alanına metin kutusu ekleyiniz. 

 

4) Eklediğiniz metin kutusunu seçiniz ve 
Properties panelinde Var: değeri olarak 
“deneme” yazınız. 

 

5) Zaman doğrusunun birinci karesini 
seçiniz ve aşağıdaki kodu yazınız. 

deneme= “merhaba dünya”; 

 Filminizi çalıştırdığınızda metin 
kutusuna vermiş olduğunuz deneme 
değişkenine gönderilen değer ekranda 
gözükür. 

 

 UYGULAMA FAALİYETİ 
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ÖLÇME VE DEĞERLENDİRME 
  
 
Bu bölümde Öğrenme Faaliyeti-4’te anlatılan konular hakkında bilginizi ölçmek 

amacıyla çoktan seçmeli sorular sorulacaktır. Soruları duyarlılıkla yanıtlamanız önerilir. 
 
A. ÖLÇME TESTİ 

 
1. Metin üzerinde grafik işlemleri yapmak için hangi işlemin uygulanması gerekir? 

A) Metnin ekran görünürlüğü için Bitmap text değeri seçilir. 
B) Break Apart komutuyla metin parçalara ayrılır. 
C) Metin seçilir ve grafik sembolüne çevrilir. 
D) Metin üzerinde doğrudan grafik işlemleri yapılabilir, bir işleme gerek yoktur. 
 

2.  Yandaki simgenin işlevi nedir? 
A) Metin boyutunu ayarlar. 
B) Metnin nasıl konumlanacağını ayarlar. 
C) Metnin harfleri arasındaki mesafeyi ayarlar. 
D) Metnin ekranda nasıl görüneceğini değiştirir. 
 

3.   Yandaki simgenin işlevi nedir? 
A) Metni hizalar (sağa, sola, ortaya, vb.). 
B) Metnin harfleri arasındaki mesafeyi ayarlar. 
C) Yazı türünü değiştirir. 
D) Metin türü belirlenir (Static Text, Dynamic Text, vb.). 
 

4. Input Text metin türünün işlevi nedir? 
A) Metin üzerinde grafiksel işlemler yapmak için kullanılır. 
B) Çalışma alanına herhangi bir metin yazmak için kullanılır. 
C) Metin içeriğini dinamik olarak değiştirmek için kullanılır. 
D) Kendisine atanan bir değişken yoluyla içine yazılan metin değeri okunabilir. 

5. Ekrandan girilen çeşitli değerleri işleyip sonucu yazan uygulama nasıl yapılır? 
A) Input Text – Static Text metin türleri birlikte kullanılır. 
B) Dynamic Text – Static Text metin türleri birlikte kullanılır. 
C) Dynamic Text – Input Text metin türleri birlikte kullanılır. 
D) Yalnızca Dynamic Text türü yeterlidir. 

 
DEĞERLENDİRME 

Ölçme sorularını doğru yanıtlamış ve eksiklerinizi gözden geçirmişseniz bir sonraki 
öğrenme faaliyetine geçebilirsiniz. 

 ÖLÇME VE DEĞERLENDİRME 

alonso
Vurgu
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ÖĞRENME FAALİYETİ–5 
  
  

Bu öğrenme faaliyetinde sembol oluşturmayı, farklarını ve kütüphaneden hazır 
sembollerin çağrılmasını öğreneceksiniz. 
  

 
Bir nesnenin örneğini oluşturma kavramını araştırınız. Bir programda yapılan 

çalışmaların o programın kütüphanesine eklenmesinin üstünlüklerini tartışınız. İnternette 
araştırma yaparak Flash’la hazırlanmış çeşitli buton örnekleri toplamaya çalışınız. Elde 
ettiğiniz sonuçları sınıf arakadaşlarınızla paylaşınız. 

 

5. SEMBOLLERİ KULLANMAK 
Flash’ın önemli özelliklerinden biri de çizilen grafikleri ve nesneleri sembol olarak 

oluşturabilmektir. Flash’ta Movie Clip, Button ve Graphic olmak üzere üç tür sembol 
vardır. 

Semboller birden fazla kullanılabilen nesnelerdir. Sembole dönüştürülen bir nesne 
Flash kütüphanesine eklenir. Sembol kullanılmak istendiğinde kütüphaneden çağrılır ve bir 
örneği oluşturulur.  

Bu durumu şu şekilde açıklayabiliriz; Bir otomobil fabrikası düşününüz. Bu fabrikada 
kaportayı üretmek için daha önceden hazırlanmış bir kalıbın olduğunu varsayınız. Her yeni 
kaporta üretilmek istendiğinde ilgili kalıp kullanılarak yeni kaportalar hazırlanır. Böylece 
ilgili kalıptan yeni kaporta örnekleri elde edilmiş olur. 

5.1. Grafik Sembolleri Oluşturmak 

Grafik sembolleri; yazılımsal olarak kontrol edilemeyen, hareketli ya da durağan 
grafiklerden oluşabilen nesnelerdir. 

Uygulama-5.1: Grafik sembolü oluşturmak 

1- Boş çalışma sayfası açınız ve çalışma sayfasına çeşitli şekiller ekleyiniz. 

2- Eklediğiniz şekilleri seçiniz ve Modify → Convert to Symbol komutuyla ya da 
F8 tuşuyla sembol dönüşüm penceresini ekrana getiriniz. 

3- İstediğiniz bir sembol ismi yazınız. 

4- Sembol türü olarak Graphic değerini seçiniz. İşlemi onayladıktan sonra seçtiğiniz 
şekillerin kapalı bir çerçeve içine alındığını görmeniz gerekir. 

ÖĞRENME FAALİYETİ–5 

 AMAÇ 

 ARAŞTIRMA 
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Şekil 5.1: Sembollerin kütüphane 
penceresinden izlenmesi 

Semboller ihtiyaç duyuldukça kullanılabilir. 
Oluşturduğunuz sembol otomatik olarak çalışma 
sayfanızın kütüphanesine kaydedilmiştir. Artık aynı 
isimde başka bir sembol oluşturamazsınız. 
Oluşturduğunuz sembolün bir örneğini çalışma 
sayfasına eklemek istiyorsanız Window
menüsünden Library değerini seçiniz ve kütüphane 
penceresini açınız. Şekil 5.1’de görüldüğü gibi 
filminize eklenen semboller kütüphane penceresinde 
gösterilir. Listeden hangi sembolü seçerseniz 
önizlemesi aynı pencerede gösterilir. 

Listeden istediğiniz sembolü seçip çalışma 
alanına sürükleyecek olursanız sembolün yeni bir 
kopyasını elde etmiş olursunuz. 

 

5.2. Movie Clip Sembolleri Oluşturmak 

Uygulama-5.2: Nesnelerin Movie Clip sembolleri olarak ayarlanması 

Movie Clip: Modülün başında Flash’ın ActionScript programlama dili 
yardımıyla kullanıcı tepkisine duyarlı canlandırmaların hazırlanabileceği belirtilmişti. Uygun 
programcılık teknikleriyle Flash’ta çizilmiş grafik öğelerini düzenlemek (konumlarını, 
boyutlarını, renklerini değiştirmek, vb.) mümkündür. Modülün ilerleyen bölümlerinde 
ActionScript dilinin kullanımından uygulamalı olarak bahsedilecektir. 

Düzenlenecek bir grafik öğesinin instance name (örnek ad) alabilmesi ve Motion 
Tween olarak adlandırılan hareket canlandırmalarının hazırlanabilmesi için; ilgili grafik 
öğesinin Movie Clip nesnesi olarak ayarlanması gerekir. 

1- Yeni bir Flash dosyası açınız ve Modify → Document… komutunu çalıştırınız. 
Document Properties iletişim penceresinde Background Color (Zemin Rengi) 
renk değerini gri tona ayarlayınız ve OK komutuyla pencereyi kapatınız. 

2- Çalışma alanına Türk Bayrağı ayından çiziniz. Ayrı bir yere de beş köşeli yıldız 
çiziniz. Yine ayrı bir yere ayı ve yıldızı içine alacak büyüklükte bir dikdörtgen 
çiziniz. 

3- Ayı seçili duruma getiriniz ve Modify menüsünden Convert to Symbol 
komutunu veriniz ya da F8 tuşuna basınız. Çıkan iletişim penceresinde Name 
(İsim) yazan kısma Ay adını giriniz. Type (Tür) tercihi olarak Movie Clip 
değerini seçiniz. 
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Şekil 5.2: Grafik öğesinin Movie Clip nesnesine dönüştürülmesi 

4- Aynı şekilde yıldızı da seçiniz ve Yıldız adında bir Movie Clip nesnesine 
dönüştürünüz. Dörtgeni de seçiniz ve Zemin adında bir Movie Clip nesnesine 
dönüştürünüz. 

5- Nesnelerin içine çift tıklayarak girebilir ve gerekli grafik düzenlemelerini 
yapabilirsiniz. Zemin nesnesinin görüntü sıralamasını Send to Back komutuyla 
en arkaya atınız. Böylece Ay ve Yıldız nesneleriniz bayrağın zemini üzerine 
çıkmış olur. 

 

Şekil 5.3: Movie Clip nesnelerine çevrilmiş grafik öğeleri 

6- Ay Movie Clip nesnesini seçiniz ve Properties paneline dikkat ediniz. 

7- Nesnenize çeşitli yöntemlerle kontrol edilebilmesi için <Instance Name> yazan 
yere bir örnek adı girmeniz gerekir. Buraya gireceğiniz isim içinde boşluk 
karakteri ve noktalama işaretleri olmamasına dikkat ediniz. Daha önce Movie Clip 
adı olarak vermiş olduğunuz adı da eğer kurallara uygunsa instance adı olarak 
kullanabilirsiniz. 

8- <Instance Name> kısmına ay adını giriniz. Böylece ilerde komuta edebileceğiniz 
bir Movie Clip nesnesi hazırlamış oldunuz. 
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Şekil 5.4: Movie Clip nesnesine instance (örnek) adı verilmesi 

5.3. Düğmelerle Çalışmak 
Flash’ın kullanıcılara ve özellikle web tasarımcılarına sunduğu önemli özelliklerden 

biri de etkileşimli, üç boyut (3-D) etkisine sahip düğmelerin hazırlanmasıdır. Flash’la düğme 
hazırlamak oldukça kolaydır. 

Görsel yeteneğinizin ve sanatsal bakış açınızın güçlü olması durumunda, birazcık da 
ince bir işçilikle görsel çekim gücü yüksek olan tasarımlar yapmanız mümkündür. Bu 
bölümde Flash’ın hazır düğmelerini nasıl kullanacağınız ve kendi düğmelerinizi nasıl 
hazırlayacağınız anlatılacaktır. 

5.3.1. Flash Düğmelerini Kullanmak 
Flash kullanıcılara pek çok kolaylık sağlar. Kütüphanesinde yer alan hazır düğmeler 

yardımıyla işlerinizi kolaylaştırmanız söz konusudur. Böylece zaman kaybetmeden Flash’ın 
sunduğu hazır düğmeleri kullanabilir. 

Uygulama-5.3: Flash kütüphanesinden hazır butonların seçilmesi ve kullanılması 

1- Windows menüsünden Common Libraries komutuyla flash nesne kütüphanesine 
ulaşınız. Çıkan menüden Buttons’u seçiniz. 

  
Şekil 5.5: Falash’ın buton kütüphanesi Şekil 5.6: Simgelerin anlamı 
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2- Düğme gruplarının yer aldığı bölümden istediğiniz bir grubun üzerine sağ tuşla 
tıklayınız. Expand Folder ve Expand All Folders seçeneklerinin seçilebilir 
olduklarını görmeniz gerekir. Expand All Folders’ı seçiniz. 

3- Tüm grupların altında yer alan düğmelerin listesi açılır. Pencere içerisine 
sığmadıklarından dolayı dikey kaydırma çubuğu aktif olur. Aşağı doğru 
ilerleyerek ne tür düğmeler olduğunu ön izleme alanından görünüz. Component 
button assets grubundan button isimli butonu seçiniz. 

Butonların üzerine fare imleci geldiğinde imleç el ( ) şeklini alır. Düğme 
grupları arasında yer alan Movie Clip nesnelerininse böyle bir özelliği yoktur. 
Ancak düğme listesinde yer alan Movie Clip nesnelerini düğme yaparken 
kullanabilirsiniz. 

4- Fareyle çalışma alanına doğru sürükleyiniz. Aynı düğmenin bir örneğinden 
çalışma sayfasına istediğiniz kadar alabilirsiniz. Çalışma sayfasına eklediğiniz 
düğmeyi silebilirsiniz. Silme işleminin kütüphanede yer alan örneğine bir etkisi 
olmaz. 

5- Filminizi çalıştırdığınızda çıkan Flash Player ekranında fareyle düğmenin üzerine 

geldiğinizde, imlecin el ( ) şeklini aldığını göreceksiniz. 

6- Oynatıcıyı kapatıp çalışma alanına dönünüz. Düğmenizin bu durumuyla hiçbir işe 
yaramadığını görmüş olmalısınız. Bu nedenle düğmeye bir eylem eklenmesi 
gerekir. 

7- Düğmeyi seçiniz. Window menüsünden Actions komutunu seçiniz. Açılan eylem 
penceresinde Normal Mode kod yazım modunu onaylayınız. 

 

Şekil 5.7: Normanl Mode kod 
yazımı 

Şekil 5.8: On buton eyleminin seçilmesi 

8- Sol taraftaki listeden Actions değerini seçiniz. Movie Control menüsünü seçiniz 
ve çıkan listeden on değerine iki kere tıklayınız. 
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9- Event: kısmındaki seçme kutularından yalnızca Release değerini seçiniz (Şekil 
5.8). on (release) satırı seçili durumda kalsın. 

10- Sol taraftaki listeden Objects değerini ve açılan listeden Movie değerini seçiniz. 
Listeden Movie Clip değerini ve yine açılır listeden Methods menüsünü seçiniz. 
nextFrame değerini bulunuz ve iki kere tıklayarak şekil 5.9’da olduğu gibi 
komutu on (release) { satırının altına yerleştiriniz. 

 
Şekil 5.9: Normal Mode kod yazım modunda çalışılması 

11-  <not set yet> kısmına bir değer yazılması gerekir. Çalışma sayfamız, kök dizin 
olduğundan çalışma sayfasında bir sonraki kareye gitmeyi sağlamak için Object: 
yazılı alana _root değerini yazınız. 

12- Eylem penceresini kapatınız. Kodunuzun aşağıdaki gibi olması gerekir. 

on (release) { 
  _root.nextFrame(); 
} 

13- Timeline panelinde birinci karenin yanındaki kareyi (2.kare) seçiniz. Sağ 
tıklayınız ve çıkan menüden Insert Keyframe komutunu veriniz. Aynı düğmeden 
çalışma sayfasının ikinci karesine de yerleştirildiğini görmeniz gerekir. 

14- İkinci karedeki düğmeyi seçiniz ve eylem penceresini açınız. Expert Mode yazım 
moduna dönünüz. Düğme içindeki kodu görebilmeniz için eylem penceresinin 
üstünde yer alan açılır menüden Actions for [No instance name assigned] 
(button) değerini seçiniz. 

15- 2. satırdaki _root.nextFrame() değerini _root.prevFrame() değeriyle değiştiriniz. 

16- 1. kareye gidiniz ve metin aracını seçerek Sayfa-1 yazınız. İkinci kareye giderek 
Sayfa-2 yazınız. 
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17- 1.kareyi yine seçiniz ve eylem penceresini açınız stop() kodunu yazınız. 

18- Filminizi çalıştırınız ve butonlara tıklayarak sonucu görünüz. 

ActionScript Kodları Hakkında: Filminizin ilk karesine yerleştirdiğiniz 
stop() komutu filminiz oynatılmaya başladığında kontrol dışı hareket etmesini engeller. Bu 
kodu koymayacak olursanız filminiz 1. ve 2. kareler arasında sürekli oynamaya devam eder. 

on deyimi, düğmelerde kullanılan ve fare hareketine ya da bazı klavye tuşlarına 
duyarlı eylem yöneticisidir. Programcılık konusunda bilginiz varsa fonksiyonları da 
bilirsiniz. Bir bakıma fonksiyon başlığıdır ve yalnızca düğmelerde kullanılır. on deyimini 
yazıp parantez açtığınızda bu deyimle birlikte kullanabileceğiniz fonksiyonların listesi 
karşınıza çıkar. 

5.3.2. Yeni Düğme Hazırlamak ve Film Kütüphanesine Eklemek 

Uygulama-5.4: 3-D görünümlü buton hazırlanması 

1- Çalışma alanına 50x50 px boyutlarında kırmızı dolgulu çerçevesi olmayan bir 
daire çiziniz. Color Mixer panelinde Radial gradyent etkisini seçiniz. Birinci 
tutamacın rengini kırmızıya, ikinci tutamacın rengini griye ayarlayınız. 

2- Daireyi seçiniz ve farenin sağ tuşuna tıklayıp çıkan menüden Convert to Symbol 
komutuyla sembol dönüştürme iletişim penceresini açınız. Name-İsim: olarak 
butonum ismini giriniz. Type: özelliği olarak Button değerini seçiniz. 

3- Şekliniz sembole dönüştükten sonra çift tıklayarak içine giriniz. Şekil 5.10 gibi bir 
zaman çizelgesi görmeniz gerekir. 

 
 

Şekil 5.10: Dört film karesinden oluşan buton Şekil 5.11: Butonun aldığı 
şekiller 

Butonlar Hakkında: Butonlar dört film karesinden oluşur. Bu karelerin 
anlamı aşağıdaki gibidir: 

Up: Bu kareye çizilen şekil düğmenin ilk görünen şeklidir. 

Over: Fare imleci düğme üzerine geldiğinde gözükecek şekil buraya çizilir. 
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Down: Fare imleci düğme üzerindeyken tıklandığında düğmenin alacağı şekil buraya 
çizilir. 

Hit: Düğmenin vuruş alanıdır. Buraya çizdiğiniz şekil önemli değildir. Ancak buraya 
butonunuzun kapladığı alan kadar bir şekil çizmeye çalışınız. Düğmenin etki alanı ve fare 

imleci düğmenin üzerine geldiğinde imlecin el ( )  şekli almasını sağlayacak yüzey alanı 
bu kare yardımıyla belirlenir. 

4- Over karesini seçiniz, sağ tıklayınız ve Insert Keyframe komutunu veriniz. Aynı 
işlemi Down ve Hit kareleri için de yapın. 

5- Down karesini seçiniz ve Radial gradyent etkisi uygulayınız. Bu sefer ikinci 
tutamacın rengini beyaza ayarlayınız. 

6- Filminizi oynatınız. Düğmenize üç boyut etkisini kazandırmak grafik öğelerini iyi 
kullanabilme yeteneğinize kalmıştır. 

7- Window menüsünden Library seçeneğini seçiniz ya da F11 tuşuna basınız. 
Ekrana, üzerinde çalıştığınız çalışma sayfasında yer alan nesneleri gösteren bir 
pencere gelir. Çalışma sayfasındaki nesneleri silseniz bile kütüphanede (Library) 
bu nesneler saklanır. Listeden kullanmak istediğiniz nesneyi seçip çalışma alanına 
doğru sürükleyiniz. Bu şekilde bir nesnenin sayısız örneğini oluşturabilirsiniz. 

5.3.3. Flash Düğmeleri Üzerinde Değişiklik Yapmak 

Uygulama-5.5: Flash düğmeleri üzerinde değişiklik yapılması 

1- Window menüsünden Common Libraries seçeneği altından Buttons değerini 
seçiniz ve çıkan buton klasörleri listesinden button assets klasörünü Expand 
Folder komutuyla açınız. 

2- Button isimli düğmeyi seçiniz ve çalışma alanına sürükleyiniz. 

3- Üzerine çift tıklayıp içine giriniz. Çok sayıda katmandan oluştuğunu görmeniz 
gerekir. 

4- Kilit simgesini tıklayarak düğme üzerinde değişiklik yapılabilmesini sağlayınız. 

İstediğiniz katmanın istediğiniz karesinde her türlü değişiklik yapabilirsiniz. Ancak bu 
değişiklikler kalıcı duruma gelmez. Çalışma alanını kapadığınızda üzerinde değişiklik 
yaptığınız buton eski durumuna gelir. 
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Şekil 5.12: Flash butonları üzerinde değişiklik yapılması. Butonun gradients katmanı seçili 
durumdadır 

Üzerinde değişiklik yaptığınız düğmeden bir tane daha eklemek istediğinizde ekrana 
Resolve Library Conflict hata penceresi gelir. Don’t replace existing items değerini 
seçerseniz yaptığınız değişiklik, eklediğiniz düğme için de geçerli olur. Replace existing 
items değerini seçerseniz yaptığınız değişiklik etkisini kaybeder. 
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UYGULAMA FAALİYETİ 
  

İşlem Basamakları Öneriler 

1) Flash’ın buton kütüphanesinde Key 
Buttons adlı klasörden key-labelled button 
adlı butonu çalışma alanına yerleştiriniz. 

 Flash kütüphanesinde istenilen 
düğmenin bulunması işlemi için 4.1 
nu.lı uygulamaya bakabilirsiniz. 

2) Yerleştirdiğiniz butonun üzerindeki harfi K 
harfiyle değiştiriniz. Butonu seçiniz ve 
aşağıdaki kodu Actions panelinde yazınız. 

on (keyPress "K") { 
 this._width=300; 
 this._height=300; 
} 

 Düğmenin içine girip 
değiştireceğiniz harfin yazılı olduğu 
metin kutusunu seçebilirsiniz. Metin 
kutusu içine girip istenilen harfi 
yazabilirsiniz. 

3) Düğmeyi, klavyeden K harfine basınca 
çalışacak şekilde ayarlayınız. 

 Actions penceresi  

 

4) Çalışma alanına çerçevesi olmayan bir 
dörtgen çiziniz. Dörtgeni seçiniz ve movie 
clip sembolüne çeviriniz. Sembolü seçiniz ve 
özellikler panelinde <Instance Name> 
kısmına dörtgen yazınız. 

5) Dörtgeni seçiniz ve Actions panelinde 
aşağıdaki kodu yazınız. 

onClipEvent(mouseDown){ 
 down=true; 
} 
onClipEvent(mouseUp){ 
 down=false; 
} 
onClipEvent (mouseMove) { 
 if(down){ 
 this._x=_xmouse; 
 this._y=_ymouse; 
 } 
} 

 Filminizi çalıştırdığınızda fare 
imlecini oynatıcının üzerine getirip 
tıklayınız ve fareyi hareket ettiriniz. 
Dörtgenin fare imlecini takip ettiğini 
görmeniz gerekir. 

 Böyle bir uygulamayı Listener 
denen ve ActionScript 2.0 
versiyonuyla duyurulan olay 
dinleyicisi (event listener) 
kullanarak tasarlamaya çalışınız. 

 

 UYGULAMA FAALİYETİ 
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ÖLÇME VE DEĞERLENDİRME 
  

 
Bu bölümde Öğrenme Faaliyeti-5’te anlatılan konular hakkında bilginizi ölçmek 

amacıyla çoktan seçmeli sorular sorulacaktır. Soruları duyarlılıkla yanıtlamanız önerilir. 
 
A. ÖLÇME TESTİ 
 
1. Kullanıcı yapımı düğmeler kaç kareden meydana gelir? 

A) 1   
B) 2   
C) Değişir   
D) 4 
 

2. Aşağıdaki eylem yöneticilerinden hangisi bir düğmenin fare tuşuna tepki göstermesini 
sağlar? 
A) onClipEvent(load)     
C) on(keyPress "<Up>") 
B) on(release)      
D) onClipEvent(keyUp) 
 

3. Aşağıdaki eylem yöneticilerinden hangisi bir düğmenin, fare ile sürüklenmesine tepki 
göstermesini sağlar? 
A) onClipEvent(enterFrame)    
C) on(dragOver) 
B) on(press)      
D) onClipEvent(mouseUp) 
 

4. Movie clip nesnelerinin dışardan ActionScript kodlarıyla denetlenmesi için ne 
yapılmalıdır? 
A) Bir değişken adı verilmelidir. 
B) Verilen sembol adına referansta bulunulmalıdır. 
C) Kontrol edilecek nesne yalnızca kök (_root) dizininde yer almalıdır. 
D) Grafik sembolüne çevrilmesi gerekir. 
 

5. Aşağıdaki ifadelerden hangisi grafik sembolleri için doğrudur? 
A) Grafik sembolleri ActionScript kodlarıyla kontrol edilebilir. 
B) Grafik sembollerine değişken adı verilebilir. 
C) Grafik sembolleri de bir nesnedir ve birden fazla örneği kullanılabilir. 
D) Grafik sembolünün birden fazla örneğini kullanmak için movie clip sembolüne 

çevrilmesi gerekir. 
 

6. Aşağıdakilerden hangisi bir harf tuşuna duyarlı düğme hazırlanmasında kullanılabilir? 
A) on(keyDown “A”)     
C) on(keyOver “C”) 
B) on(keyHit “B”)     
D) on(keyPress “D”) 

 ÖLÇME VE DEĞERLENDİRME 

alonso
Vurgu
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7. Aşağıdaki ifadelerden hangisi yanlıştır? 
A) Kütüphaneden alınan bir düğmenin çalışma alanında birden fazla örneği 

oluşturulabilir. 
B) Düğme örneklerinden birinde yapılan değişiklik diğer örnekleri de etkiler. 
C) Flash kütüphanesinden alınmış bir düğme üzerinde yapılan değişiklik 

kütüphanedeki asıl düğmeyi etkiler. 
D) Flash kütüphanesinden alınmış ve üzerinde değişiklik yapılmış bir düğmeden bir 

tane daha örnek alındığında Resolve Library Conflict hata mesajı gelir. 
 

8. Flash kütüphanesinde Component Buttons klasörünün altında yer alan düğmelerin 
özelliği değildir? 
A) Her bir karesi üzerinde değişiklik yapılabilir. 
B) Üzerlerinde renk ve parlaklık dışında değişiklik yapılamayan düğmelerdir. 
C) Birden fazla örneği oluşturulabilir. 
D) Örneklerden birinde yapılan değişiklik diğer örnekleri etkilemez. 
 

9. Aşağıdaki görüntülerden hangisi bir düğmenin bütün olarak seçildiğini 
göstermektedir? 

A)     B)   

C)     D)  

10. Düğme üzerine fare imleci geldiğinde, çalışma alanında mesaj değişkenli bir metin 
kutusuna Selam  mesajı yazılması için hangi işlem yapılmalıdır? 
A) Düğmenin Up karesine gidilir ve _root.mesaj = “Selam…”; kodu eklenir. 
B) Düğme seçilir ve eylem penceresinde on(rollOver){ _root.mesaj = “Selam…”;} 

kodu yazılır. 
C) Düğme seçilir ve eylem penceresinde mesaj = “Selam…”; kodu yazılır. 
D) Düğme seçilir ve eylem penceresinde on(release){ _root.mesaj = “Selam…”;} 

kodu yazılır. 
 

DEĞERLENDİRME 
 
Ölçme sorularının çoğunu doğru yanıtlamış ve eksiklerinizi gözden geçirmişseniz bir 

sonraki öğrenme faaliyetine geçebilirsiniz. 

alonso
Vurgu
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ÖĞRENME FAALİYETİ–6 
  

Bu öğrenme faaliyetinde canlandırmaların nasıl hazırlanacağını öğreneceksiniz. 
  

 

Flash’la yapabilecekleriniz konusunda bir fikir sahibi olmak istiyorsanız verilen 
internet bağlantılarını incelemeniz yerinde olur. 

 http://www.macromedia.com ya da http://www.adobe.com 

 http://speed.city-net.com/~alimhaq/flashsamples/menumultimedia.htm    
(Kasım 2006) 

 http://www.visualxtreme.com/flash.html (Kasım 2006) 

 http://www.flashokulu.com (Türkçe – Kasım 2006) 

 http://www.gingerbooth.com/flash (Kasım 2006) 

 http://www.weboshawa.com/webdesign/flash_samples.htm (Kasım 2006) 

 http://www.flashdersleri.com (Türkçe – Kasım 2006) 

6. CANLANDIRMA (ANİMASYON) 
HAZIRLAMAK VE KULLANMAK 

Flash yazılımı gibi bir yazılımın ana görevi bir iki basit vektörel grafik çizmek değil 
elbette. Flash’ın bu kadar ünlü ve tercih edilen bir yazılım olmasının arkasında yatan gerçek, 
çizmiş olduğunuz her türlü grafiğin kolaylıkla etkileyici canlandırmalara 
dönüştürülebilmesidir. 

Bilgisayar kullanım tecrübesi az olan deneyimsiz kullanıcılar da rahatlıkla göze hoş 
gelen canlandırmalar hazırlayabilir. Programcılık bilgisi ve yeteneği güçlü olanlar internet 
sayfası kullanıcılarının etkileşime girebildiği güçlü uygulamalar hazırlayabilir. 

6.1. Hareket Canlandırmaları (Motion Tween)Hazırlamak 

Flash’la Motion Tween denen canlandırma yöntemiyle nesnelerin hareketine dayalı 
canlandırmalar hazırlanabilir. Bu, en kolay canlandırma hazırlama yoludur. Bir başlangıç ve 
bir bitiş noktası tanımlanır. Flash aradaki geçişleri kendisi hazırlar. 

ÖĞRENME FAALİYETİ–6 

 AMAÇ 

 ARAŞTIRMA 
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Doğrusal ve kılavuz yoluyla olmak üzere iki tür hareket canlandırması vardır. Hareket 
canlandırmalarında şeklin fiziksel görüntüsünde bir değişiklik olmaz. Yalnızca belli bir yol 
boyunca hareket eder. Eğer canlandırmanızı play() – oynat ve stop() – durdur deyimleriyle 
denetlemeyecek olursanız canlandırma geldiği son kareden tekrar ilk kareye döner ve süreç 
sürekli devam eder. 

6.1.1. Doğrusal Motion Tween Hazırlamak ve Hareketleri Yumuşatmak 

Uygulama-6.1: Doğrusal hareket canlandırması hazırlanması 

1- Boş bir çalışma sayfası açınız. Çalışma alanının dışındaki iki yana şekil 5.1’deki 
gibi yazılar yazınız.  

 

Şekil 6.1: Yazıların çalışma alanı dışına eklenmesi 

2- Yazılardan birini seçiniz ve Insert menüsünden (Flash 8 için Modify menüsü) 
Convert to Symbol komutunu vererek yazi1 adında Movie Clip sembolüne 
dönüştürünüz. Diğer yazıyı da seçiniz ve onu da yazi2 adında Movie Clip 
sembolüne dönüştürünüz. 

3- yazi1 nesnesi üzerine çift tıklayarak içine giriniz. Insert menüsünden Create 
Motion Tween komutunu veriniz (Flash 8 için Insert → Timeline → Create 
Motion Tween). Metin kutusu otomatik olarak Tween 1 adında bir sembole 
dönüşür. 

4- yazi2 nesnesi için 3. adımı tekrarlayınız. 

5- Window menüsünden Library komutunu veriniz. O ana kadar çalışma sayfanıza 
eklediğiniz nesnelerin bir listesi karşınıza gelir. 

6- yazi1 nesnesinin içine girerek 20. karenin üzerine sağ tıklayınız ve Insert 
Keyframe komutunu veriniz. yazi1 nesnesinin bir kopyasının 20 kareye de 
yerleştirildiğini göreceksiniz. 20. karedeki yazı 1 nesnesini seçiniz ve klavyenin 
yön tuşuyla çalışma sayfasının diğer tarafına doğru sürükleyiniz. 

7- yazi2 nesnesinin içine girerek 20.karenin üzerine sağ tıklayınız ve Insert 
Keyframe komutunu veriniz. 20. karedeki yazi2 nesnesini seçiniz ve klavyenin 
yön tuşuyla çalışma sayfasının diğer tarafına doğru sürükleyiniz. 
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Şekil 6.2: yazi1 ve yazi2 nesnelerinin bitiş noktalarının belirlenmesi 

8- Böylece yazi1 ve yazi2 nesneleri içinde birbirinden bağımsız hareket 
canlandırması hazırlamış olduk. yazi1 ya da yazi2 içine girip 1. ve 20. kare 
arasındaki karelere bakabilirsiniz. Hareketin nasıl gerçekleştiğine dikkat ediniz. 
Ara kareler, Flash tarafından otomatik olarak doldurulmuştur. 

9- Hazırladığınız çalışmayı Control → Test Movie komutuyla deneyiniz. 

Uygulama-6.2:Doğrusal hareket canlandırmalarında hareket yönlerinin 
değiştirilmesi 

Flash’ın otomatik olarak doldurduğu ara karelere müdahalede bulunup ara hareketleri 
değiştirmek mümkündür. 

1- Yeni bir çalışma sayfası açınız ve çalışma alanına bir şekil çiziniz. 

2- Çizdiğiniz şekli seçiniz ve Insert → Create Motion Tween komutuyla hareket 
canlandırması oluşturunuz (Flash 8 için Insert → Timeline → Create Motion 
Tween). 

3- Daha önceki uygulamadan farklı olarak bu uygulamada bütün çalışma sayfası 
hareket canlandırmasına ayrılır. Çalışma alanına yeni bir grafik öğesi ekleyiniz. 
25. kareye sağ tıklayınız ve Insert Keyframe komutunu veriniz. 
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Şekil 6.3: 1. ve 25. kareler 

4- 1. kareye eklediğiniz şekil hareket canlandırmasının dışında kaldığı için şekil 
6.3’te gözüken bozulma meydana gelir. Hareket canlandırmasını belirten ok 
simgesi zaman çizelgesinde gözükmemektedir. Onun yerine canlandırmada bir 
hata olduğunu belirten kesikli çizgiler vardır. Sonradan çizdiğiniz şekli silgi 
aracının Faucet yardımcı aracıyla siliniz. 

5- Şekil tamamen silindiğinde ok simgesinin 1. kareden 25. kareye kadar oluştuğunu 
görmelisiniz. 

 

Şekil 6.4: (A) Zaman çizelgesinin alması gereken şekli. (B) Ara anahtar kare eklenmesi 

6- 25. kareye gidiniz ve movie clip nesnenizi farklı bir yere taşıyınız (Şekil 6.4-A-). 

7- 10. kareye gidiniz ve sağ tıklayarak Insert Keyframe komutunu veriniz. Okun iki 
ayrı ok olarak bölündüğünü görmeniz gerekir (Şekil 6.4-B-). 

8- 10. karedeki şekli başka bir yere sürükleyiniz ve canlandırmanızı çalıştırıp farka 
dikkat ediniz. 
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Hareket canlandırmalarında Flash tarafından oluşturulan karelere müdahale edip 
daha yumuşak geçişli hareketler elde edebilirsiniz ya da her bir hareket için ayrı 
ayrı motion tween yapmaya gerek kalmadan araya anahtar kare ekleme 
yöntemiyle çok sayıda farklı hareketi tek bir canlandırmayla yapabilirsiniz. 

 
6.1.2. Kılavuz Yoluyla Motion Tween Hazırlamak 

Uygulama-6.3: Kılavuz katmanıyla uçan kelebek canlandırmasının oluşturulması 

1- Yeni bir çalışma sayfası açınız ve bir kelebek şekli çiziniz ya da ekleyiniz. 

2- Insert → Create Motion Tween komutuyla (Flash 8 için Insert → Timeline → 
Create Motion Tween) hareket canlandırması oluşturunuz. 

3- Add Motion Guide -  simgesine tıklayarak Layer 1 katmanının üzerinde bir 
hareket kılavuzu katmanı oluşturunuz. 

4- Şeklinizin nasıl bir yol boyunca hareket etmesini istiyorsanız Pencil Tool aracıyla 
ona uygun bir yol çiziniz. 

5- Motion tween nesnesine dönüşen şeklinize tıklayınız. Büyük olasılıkla şekliniz 
çizmiş olduğunuz kılavuz yolunun bir ucuna kenetlenecektir. Kenetlenme olmazsa 
şekli seçiniz ve kılavuz çizgisinin bir ucuna sürükleyiniz. 

 

Şekil 6.5: Şeklin hareket kılavuzuna kenetlenmesi 

6- Layer 1 katmanında 20. kareye sağ tıklayın ve bir anahtar kare (Insert 
Keyframe) ekleyiniz. 

7- Kılavuz katmanının hizasına gelen 20. kareye sağ tıklayın ve bir anahtar kare 
(Insert Keyframe)  ekleyiniz. 

8- Layer 1 katmanının 20. karesini seçiniz ve şekli kılavuz çizgisinin diğer ucuna 
klavye yön tuşlarıyla sürükleyiniz ya da fareyle taşıyınız. 
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Şekil 6.6: Şeklin kılavuz çizgisinin diğer ucuna kenetlenmesi 

9- Canlandırmanızı çalıştırınız. Kelebeğinizin gerçek bir kelebek esnekliğinde 
hareket etmediğini göreceksiniz. 

10- Şeklin yönünü çevirmek suretiyle daha yumuşak ve gerçekçi bir hareket elde 
edebiliriz. Bunun için bazı yerlerde ara anahtar kareler ekleyip şekli döndürmek 
gerkecektir. Şekil 6.7’de gösterildiği gibi ara kareler ekleyiniz ve şeklinizi Rotate 
komutuyla gerek gördüğünüz yerlerde döndürünüz. Filminizi kaydediniz. 

 

Şekil 6.7: Ara kareler ekleyerek hareketin daha gerçekçi yapılması 
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6.2. Şekil Canlandırmaları (Shape Tween)Hazırlamak 
Şu ana kadar yapılan canlandırmalar nesnelerin hareketlendirilmesi şeklindeydi. Flash 

bunun yanında Shape Tween denen canlandırma yardımıyla şekillerin görüntülerinde de 
değişiklik yapılmasına imkân sağlar. 

Uygulama–6.4:Düğmelerle denetlenen shapetween canlandırmasının hazırlanması 

1- 300 px genişliğinde ve 200 px yüksekliğinde yeni bir Flash sayfası açınız. 

2- Çalışma alanının ortasına 100X100 px boyutlarında bir daire çiziniz. 

3- Daireyi seçiniz ve “shapetwen” adında movie clip sembolüne dönüştürünüz. 
Movie clip sembolüne dönüşen nesnenize çift tıklayınız ve içine giriniz. 

4- Katmanı seçiniz ve Properties panelinde Tween: yazan kısmın yanında yer alan 
açılır menüden Shape değerini seçiniz. Birinci karenin açık yeşil renge 
büründüğünü görmeniz gerekir. 

 

Şekil 6.8: Shape tween canlandırmasının oluşturulması 

5- 20. karenin üzerine sağ tıklayınız ve Insert Keyframe değerini veriniz. 

6- 1. kareden 20. kareye kadar yer alan karelerin yeşile boyandığını ve ok şeklinin 
oluştuğunu görmeniz gerekir. 
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7- 20.karede yer alan daireyi siliniz. 1. kareden 20. kareye kadar kesikli çizginin 
oluşması gerekir. Sildiğiniz daire şekli yerine 150 px genişliğinde 50 px 
yüksekliğinde dörtgen çiziniz (Şekil boyutunu Properties panelinde yer alan 
W: ve H: değer alanlarına uygun değerleri girerek ayarlayabilirsiniz.) 

8- Ok şekli yeniden oluşur. 40. kareye de anahtar kare ekleyiniz. 1.karedeki daireyi 
seçiniz ve kopyalayınız. 40. dairedeki dörtgeni siliniz. 

9- Edit → Paste in Place komutuyla 1. karedeki daireyi 40. karede aynı yere 
yapıştırınız. 

 
Şekil 6.9: Shape tween için anahtar karelerin oluşturulması 

10- Boş bir alana çift tıklayınız ya da şekil 6.8’de gösterilen Scene1 yazısına tıklayınız 
ve ana sayfaya (sahne 1) geri dönünüz. 

11- Shapetween isimli daireyi çizdiğiniz katmanın adını grafik adıyla değiştiriniz. 
Shapetween nesnenizi seçiniz ve Properties panelinde şekil 6.10’da gösterilen 
alana shapetween değişken adını yazınız. Buraya yazdığınız isimle nesnenize 
verdiğiniz isim aynı olmak zorunda değildir. 

 

Şekil 6.10: Grafik sembolüne değişken adı girilmesi 
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12- Canlandırmanızı çalıştırıp test ediniz. Önce daireden dörtgene ve ardından 
dörtgenden daireye dönüşen bir canlandırmanın oluşması gerekir. Flash 
oynatıcısını kapatınız ve çalışma alanına geri dönünüz. 

13- Grafik katmanının üzerinde eylem adında yeni bir katman oluşturunuz. 

14- Window → Actions komutuyla eylem penceresini açınız ve shapetween.stop(); 
komutunu yazınız. Eylem katmanınızın 1 nu.lı karesi üzerinde α simgesinin 
çıkması gerekir. 

15- Grafik katmanının altında butonlar adında yeni bir katman oluşturunuz. 

16- Window → Common Libraries → Buttons komutuyla Şekil 6.11’de gösterilen 
düğmeleri bulunuz ve butonlar katmanına yerleştirin. 

 

Şekil 6.11: Butonlar katmanına yerleştirilecek butonlar 

17- Düğmeleri sırasıyla seçiniz ve her bir buton için Window → Actions komutuyla 
çıkan eylem penceresinde aşağıdaki kodları yazınız: 

Durdurma Butonu:  
on (release){ 
  shapetween.stop(); 
} 
Oynatma Butonu:  
on (release){ 
  shapetween.play(); 
} 
 

Bir Önceki Kare:  
on (release){ 
  shapetween.prevFrame(); 
} 
Bir Sonraki Kare: 
on (release){ 
  shapetween.nextFrame(); 
} 
 

18- Canlandırmanızın ana sayfa görüntüsü şekil 6.12’deki gibi olmalıdır. Control → 
Test Movie komutuyla filminizi oynatınız. Düğmelere tıklayarak sonucu 
gözleyiniz. Filminizi kaydediniz. 
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Şekil 6.12: Shape Tween canlandırmasının 
bitmiş tasarım görüntüsü 

Shape Tween Hakkında: Bu 
canlandırma yöntemiyle yalnızca görüntü 
değişikliğine dayalı canlandırmalar değil,
motion tween gibi hareket canlandırmaları da 
hazırlayabilirsiniz. Hatta renk değişimine dayalı 
oldukça hoş canlandırmalar da hazırlamak söz 
konusudur. 

Uygulama-6.5: Daha karmaşık bir şekle Shape Tween uygulanması 

1- Stage’in (Çalışma Alanı) 1. karesine dolgu rengi ve dış hat rengi farklı olan bir 
oval çiziniz. 

2- 1. kareye tıklayarak seçili duruma getiriniz. Properties panelinde Tween: 
alanından Shape değerini seçiniz. 

3- Zaman çizelgesinde 5. kareye sağ tıklayınız ve Insert Keyframe komutunu 
veriniz. Şeklin 5. kareye kadar bir kopyası oluşturulur. 

4- 5. karedeki oval şekle dört köşeli yonca yaprağı şekli veriniz. (Bu işlem için 
Subselection aracını kullanabilirsiniz. Aracı seçiniz, şeklin dış hattına tıklayınız 
ve çıkan kare şeklindeki tutamaçlardan tutup fareyi farklı yönlere hareket 
ettirerek dört köşe yonca yaprağını elde edebilirsiniz.) 

5- 10. kareye sağ tıklayınız ve Insert Keyframe komutunu veriniz. Dört köşe yonca 
yaprağı şekliniz 10. kareye kadar kopyalanır. 

6- 10. karedeki şekle şekil 6.13’te gösterildiği gibi çiçek sapı ekleyiniz. (Bu işlemi 
gerçekleştirmek için 4. adımda olduğu gibi Subselection aracını kullanmanız 
işinizi kolaylaştırır.) 
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Şekil 6.13: Başlangıç ve bitiş kareleri 

7- Filminizi oynatınız. Çiçeğe sapın eklenmesi, doğru görünen yumuşak bir geçiş 
oluşturmasını zorlaştırır. Oynatım çubuğunu 1. ve 5. kareler arasında 
gezdirdiğinizde düzgün bir geçişin olduğunu ancak 5. ve 10. kareler arasında 
bozulmalar olduğunu fark etmelisiniz. 

8- Bunu engellemek amacıyla Shape Hints (Şekil ipuçları) kullanılır. 5. kareyi 
seçiniz ya da oynatım kafasını 5. kareye götürünüz. Modify menüsünden Shape 
→ Add Shape Hint komutuyla ya da Ctrl+Shift+H tuşlarıyla ilk şekil ipucunu 
ekleyiniz. (Şekil ipuçları a harfinden başlamak üzere küçük daireler şeklinde 
eklenen etiketlerdir, şeklin merkezine eklenir.) 

9- Arrow aracını kullanarak fare imleciyle ilk a harfli şekil ipucu etiketini sorunlu 
noktaya taşıyınız (Şekil 6.14). 

10- Bir şekle birden fazla şekil ipucu ekleyebilirsiniz. 8. adımı tekrarlayarak iki tane 
daha şekil ipucu ekleyiniz. b harfli etiketi sapın ucunun çıkacağı noktaya ve c 
harfli etiketi de diğer kenara yerleştiriniz (Şekil ipuçlarının saat yönünün tersinde 
yerleştirilmesi Flash için daha iyidir.). 

 
Şekil 6.14: Şekil ipuçlarının eklenmesi 
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11- 10. kareyi seçiniz ya da oynatım kafasını 10. kareye götürünüz. a, b, c etiketli 
şekil ipuçlarının üst üste bindiğini göreceksiniz. Arrow aracını kullanarak her bir 
etiketi sırasıyla uygun yere taşıyınız. 

12- Şeklinizin durumuna göre daha fazla şekil ipucu eklemeniz gerekiyorsa 
8-11. adımları yineleyiniz. Canlandırmayı oynatınız ve sonucu gözleyiniz. 

6.3. Sesli Canlandırmalar Hazırlamak 

Flash çok farklı formatlarda sesleri çalabilme özelliğine sahiptir. Windows işletim 
sisteminin ses formatı olan .wav, Macintosh işletim sisteminin ses formatı olan .aiff, 
QuickTime filmlerinin sesleri, .au dosyaları ve tüm platformlarda kullanılan .mp3 dosyaları 
flash tarafından kullanılabilir. Bir filme ithal edilen ya da kopyalanan tüm sesler, o filmin 
kütüphanesinde (Library) kalır. 

Uygulama-6.6: Düğmelere seslerin eklenmesi 

1- Window → Common Libraries → Buttons komutuyla düğme kütüphanesini 
açınız. 

2- Listeden Push Buttons klasörünü bulunuz ve üzerine sağa tıklayınız. Expand 
Folder komutunu veriniz ve push button – blue düğmesini çalışma alanına 
sürükleyin ve bırakınız. 

3- Düğmenin üzerine çift tıklayınız ya da düğmeyi seçtikten sonra Edit → Edit 
Selected komutunu çalıştırınız. 

4- Düğmenin içine girdikten sonra en üst katmanı seçiniz. Insert → Layer (Flash 8 
için Insert → Timeline → Layer) komutuyla ya da Insert Layer simgesine 
tıklayarak yeni bir katman ekleyiniz. Katmana ses adını veriniz. 

5- Ses katmanında Over karesini seçiniz ve karenin üzerine sağ tıklayarak Insert 
Blank Keyframe komutunu çalıştırarak boş bir film karesi ekleyin. Down 
karesini seçiniz ve aynı şekilde boş bir film karesi ekleyiniz. 

6- Düğmeler penceresini kapatınız. Over karesini seçiniz ve Window → Common 
Libraries → Sounds (Flash 8’in ses kütüphanesi olmadığı için File → Import 
→ Import to Library komutunu çalıştırınız ve bilgisayarınızdan kısa bir ses 
dosyası ekleyiniz.) komutuyla Flash ses kütüphanesini açın. 

7- Sol yanında hoparlör simgesi ( ) olan ve sağ yanında Sound yazan ses 
dosyalarından istediğiniz birini seçiniz ve çalışma alanına sürükleyiniz. (Flash 8 
için kütüphaneyi [Window → Library] açınız ve eklediğiniz ses dosyasını 
listeden seçip çalışma alanına sürükleyiniz.) 
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Şekil 6.15: Sounds paneli Şekil 6.16: Ses dosyasının anahtar kareye 
eklenmesi ve katman yüksekliğinin 

büyütülmesi 

8- Anahtar kare içinde şekil 6.16’da gösterildiği gibi ses dalgasının belirdiğini 
görmeniz gerekir. Ses katmanını seçiniz ve üzerine sağ tıklayınız. Properties 
komutunu çalıştırınız ve Layer Height değerini %200 yapınız. 

9- Ses katmanında Down karesini seçiniz ve bir ses dosyası ekleyiniz. 

10- Düğmeyi bütün bir nesne olarak görmek için Scene 1 yazısına tıklayın ya da boş 
bir alana çift tıklayınız. 

11- Filmi çalıştırmadan düğmeyi test etmek için Control menüsünden Enable Simple 
Buttons komutunu çalıştırınız ya da Ctrl+Alt+B tuşlarına basınız. 

12- Fare imlecini, düğmenin üzerine getirdiğinizde Over karesindeki ses, düğmeye 
tıkladığınızdaysa Down karesindeki ses çalınır. 

Uygulama-6.7: Seslerin farklı Sync modlarında kullanılması 

 

Şekil 6.17: Farklı Sync modlarının seçilmesi 

Flash’da sesler dört farklı eylem türüyle kullanılabilir. Bunları kısaca şöyle 
açıklayabiliriz: 



 

 94

Event - Olay: Varsayılan çalma türüdür. Sesin ne kadar kare kapladığı önemli 
değildir. Henüz sesin bitim noktası gelmemişse, film diğer karelere geçse bile ses çalmaya 
devam eder. Film başa döndüğünde, ses henüz bitmemiş olsa bile sesin bir başka örneği 
başlatılır. 

Start - Başlat: Ses klibi zaten çalınıyorsa sesin ikinci bir örneği başlatılmaz. Eğer ses, 
film oynatıcısı sesin çalındığı kareye yeniden gelmeden bitmişse yeni bir ses başlamaz. Film 
oynatıcısı, ne zaman sesin olduğu kareye gelirse o zaman ses çalınır. 

Stop - Durdur: Bu eylem türünün kullanıldığı kareye gelindiğinde ses kesilir. 

Stream - Akan: Ses akışının belli bir hareketle ilişkilendirilmesi istendiğinde 
kullanılır. Flash o ses klibini daha küçük alt kliplere parçalar ve ayrı karelere gömer. Filmin 
kare gösterim hızı (frame rate), alt kliplerin boyunu belirler. Örneğin 10fps’lik kare 
gösterim hızına sahip bir filmde, Flash akan sesi bir saniyenin onda biri uzunluğunda alt 
kliplere böler. Flash, bu sesin, her 10 karede 1 saniyesini çalar. 

Flash, her alt klibin başlangıcını filmdeki belirli bir kareyle senkronize eder. Ses, 
Flash oynatıcının kareleri görüntülemesinden daha hızlı oynatılırsa, Flash oynatıcı, 
canlandırmanın bazı karelerini görüntüleyemez. Bu sebepten dolayı ses ve görüntü mümkün 
olduğunca eş zamanlı (senkronize) olmalıdır. 

1- Uygulama 3.17’de yaptığınız canlandırmayı açınız. 

2- En alta maskelenmemiş Normal modda bir katman ekleyiniz. 

3- 5., 10. ve 15. karelere boş anahtar kare ekleyiniz. 

4- 1., 5., 10. ve 15. karelere Sounds panelinden bir ses ekleyiniz. 

5- Filminizi oynatınız. Seslerin nasıl çalındığına dikkat ediniz. 

6- Flash oynatıcısını kapatınız. 1., 5., 10. ve 15. kareleri sırasıyla seçerek Properties 
panelinden Sync modu olarak Stream değerini seçiniz. Filminizi tekrar oynatınız 
ve farka dikkat ediniz. 

7- 15. kareyi seçiniz ve farenin sol tuşu basılıyken 10. kare üzerine sürükleyiniz. 10. 
kareye yerleştirdiğiniz anahtar karenin 20. kareye kadar devam ettiğini görmeniz 
gerekir. 

8- 1. ve 5. karelerdeki sesleri yeniden Event moduna alınız. 10. kareyi seçiniz. 
Properties panelinde “Sound:” etiketinin yanında yer alan açılır listeden 
durdurmak istediğiniz sesi seçiniz. 
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Şekil 6.18: (A) Durdurulacak sesin Properties panelinde Sound etiketinden seçilmesi (B) Ses 
klipleri üzerinde yapılacak değişiklikler 

9- “Sync:” etiketinin yanında yer alan açılır listeden Stop değerini seçiniz. 

10- Filmi oynatınız. Eğer durma emri verdiğiniz ses 10. kareye gelindiğinde de 
normalde çalmaya devam ediyorsa o ses klibi 10. kareye gelindiğinde durdurulur. 

Uygulama-6.8: Ses klipleri üzerinde değişiklik yapılması 

1- Boş bir flash dosyası açınız. 

2- Örnek bir ses klibi ekleyiniz. Şekil 6.18 (B)’de gösterildiği gibi “Effect:” etiketi 
yanında yer alan açılır listeden istediğiniz özelliği seçiniz. Filmi çalıştırınız. 

3- Bu işlemi diğer seçeneklerde de uygulayınız. 

 

Şekil 6.19: Ses klibinin isteğe göre düzenlenmesi 



 

 96

4-  Eğer ses klibini kendi isteğinize göre düzenlemek istiyorsanız, ses klibini 
eklediğiniz kareyi seçiniz ve Properties panelinde Edit düğmesine tıklayarak 
Edit Envelope penceresini açınız. 

5- Şekil 6.19’da gösterildiği gibi fare imleciyle içi boş kareye tıklayınız ve 
istediğiniz konuma sürükleyiniz. Daha fazla içi boş kare eklemek için (Değişim 
noktası) ses klibi ön izleme ekranında gözüken çizgiye tıklayınız. Yeni bir 
değişim noktası oluşturulur. 

6- Filminizi çalıştırınız ve yaptığınız değişikliklerin etkisini anlamaya çalışınız. 

6.4. Zaman Doğrusu Efektlerini (Timeline Effects) Kullanmak 

Flash 8’de zaman doğrusuna (Timeline) çeşitli hazır canlandırmalar ekleyerek 
zamandan kazanabilir ve animasyon hazırlama işlemini sıradan kılabilirsiniz. 

Uygulama-6.9: Zaman doğrusunda yer alan iki ayrı grafik öğesine farklı efektlerin 
uygulanması 

1- Flash 8’de boş çalışma sayfası açınız. 

2- Layer 1 isimli katmanın 1. karesine 200 px-200 px genişliğinde dış çerçevesi 
olmayan içi dolgulu bir daire çiziniz. 

3- 1. kareyi seçiniz ve Insert → Timeline Effects → Effects → Blur komutunu 
çalıştırınız. 

 

Şekil 6.20: Blur efektinin uygulanması 

4- Blur efektiyle ilgili ayar penceresi ekrana gelir. 
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5- Ayar panelinde farklı değerler girerek pencereyi kapatınız ve filminizi çalıştırınız. 

 

Şekil 6.21: Blur efektinin ayarlanması ve önizlemesi 

6- Efekt eklendikten sonra başka bir efekt eklemek söz konusu olmadığından farklı 
değerlerin etkisini anlamak için yaptığınız değişiklikleri Ctrl+Z tuş ikilisiyle geri 
alınız ve yeniden Blur efektini uygulayınız. 

7- Çalışma sayfasına yeni bir şekil ekleyiniz ve eklediğiniz şekli seçiniz. 

8- Insert → Timeline Effects → Effects → Explode komutunu çalıştırınız. 

9- Explode penceresinde istediğiniz değişiklikleri belirleyiniz ve OK butonuna 
tıklayarak pencereyi kapatınız. 

10- Filminizi oynatarak hazır efektlerin sunduğu kolaylığı anlamaya çalışınız.  

Filminize ikinci bir efekt eklediğinizde yeni efekti eklediğiniz şeklin otomatik olarak 
ayrı bir katmana yerleştirildiğini görmeniz gerekir (Şekil 6.22). Şekildeki örnekte Blur efekti 
16 kare ve Explode efekti 20 kare yer kaplamaktadır. 

 

Şekil 6.22: İki ayrı efekt canlandırması 

Uygulama-6.10:Dönüşüm ve geçiş (Transform/Transition) efektlerinin 
uygulanması 

1- Flash 8’de boş çalışma sayfası açınız ve 1. kareye 200 px-200 px genişliğinde dış 
çerçevesi olmayan içi dolgulu bir kare çiziniz. 
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2- Şekli seçiniz ve Insert → Timeline Effects → Transform/Transition → 
Transform komutunu çalıştırınız. 

3- Ekrana gelen Transform penceresinde aşağıdaki değişiklikleri yapınız. 

Effect Duration: Efektin kaç kare kaplayacağını belirleyen bu değeri 20 yapınız. 
İki tercihli listeden Change Position By değerini seçiniz. X:200px ve Y:50px olarak 

ayarlayınız. 
Change Position By: Şeklin konumunu belirtilen X ve Y değerleri kadar değiştirir. 
Move to Position: Şekli belirtilen X ve Y koordinatlarına sürükler. 
Scale: Şekli belirtilen yüzde değeri kadar ölçekler. 
Rotate ve Spin: Şekli 0-360° arasında ya da 0.0-1.0 değeri arasında girilen değer 

kadar sola ya da sağa döndürür. 
Change Color ve Final Color: Change Color tercihi seçilirse ve Final Color için 

farklı bir renk belirlenirse şekil renk değiştirir. 
Final Alpha: Şeklin saydamlığı %0 - %100 arasında ayarlanır. 
Motion Ease: Şeklin animasyona hangi hızda başlayacağı ya da animasyonu hangi 

hızda bitireceği buradan ayarlanır. En fazla -100 ve +100 arasında değer alabilir. Pozitif 
değerler animasyonun bitişini yavaşlatırken negatif değerler animasyon başlangıcını 
yavaşlatır. 

4- Yukarıda bahsedilen değerleri sırayla değiştiriniz ve Update Preview butonuna 
tıklayarak önizlemedeki değişimi fark ediniz. Değişiklikleri onaylayınız. 

5- Yeni bir şekil çiziniz ve şekli seçerek Transition efektini uygulayınız. Efekti 
uyguladığınız şekil Transition isimli ayrı bir katmana yerleşir. 

Uygulama Ödevi: Copy to Grid, Distributed Duplicate, Drop Shadow ve Expand 
efektleriyle ilgili ufak uygulamalar geliştiriniz. 

6.5. Sahneye Hazır Filmler ve FLV (Flash Video) Dosyaları Eklemek 

Flash sahnesine daha önceden hazırlanmış swf uzantılı flash filmleri, farklı 
formatlarda resim dosyaları ve flv uzantılı Flash Videoları eklenebilir. Bu işlem için bazı 
ActionScript kodlarını kullanmak gerekecektir. 

loadMovie() Komutu: loadMovie() komutu fonksiyon olup SWF, JPEG, GIF 
ve PNG dosyalarını Flash sahnesindeki bir Movie Clip nesnesine ya da doğrudan sahne 
içine ekler. Hareketli GIF’lerin yalnızca ilk karesi eklenir. Bu fonksiyon bazı parametrelerle 
birlikte kullanılır. Bu parametreler fonksiyona hangi dosyanın yükleneceğini, dosyanın 
nereye yükleneceğini ve bazı değişkenlerin nasıl gönderileceğini belirtir. 

Bu fonksiyon birden fazla SWF dosyasının tek seferde gözükmesini sağlar ve yeni bir 
HTML sayfası yüklemek zorunda kalmadan SWF dosyaları arasında geçiş yapılabilir. 
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Kullanımı 

loadMovie(url:Metin , hedef:Nesne, [yöntem:Metin) : Void 
loadMovie(url:Metin, hedef:Metin, [yöntem:Metin]) : Void 

Parametreleri 

- url:String(Metin Dizisi)= Yüklenecek dosyanın bağıl ya da mutlak yoludur. Bağıl 
yol üzerinde çalışılan SWF dosyasına sıfır seviyesine (level 0) göre bağıl olmalıdır. Diğer bir 
ifadeyle referans noktası üzerinde çalışılan SWF dosyasının kendisidir. Mutlak yolda http:// 
ya da file:/// gibi fiziksel başlangıç noktaları belirtilir. 

- target (hedef):Object/String(Nene ya da Metin Dizisi)= Yüklenecek dosyanın sahne 
içindeki bir movie clip nesnesine referansını belirtir. Movie clip nesnesi yüklenen SWF 
dosyası ya da resimle değiştirilir. Nesne olarak sahne içinde yer alan bir movie clip 
nesnesinin adı yazılır. 

Eğer SWF ya da JPEG dosyaları belli bir seviyeye göre yüklenecekse loadMovie() 
fonksiyonu yerine loadMovieNum() fonksiyonu kullanılır. Hedef (target) değeri olarak 
1,2,3… gibi sayısal değerler kullanılır. 

- method (yöntem): String (Seçmelidir)= Değişkenlerin gönderilmesi için bir http 
yöntemi belirtir. Parametre GET ya da POST olmalıdır. Gönderilecek değişken yoksa bu 
değer kullanılmaz. 

loadMovie() fonksiyonuyla yüklenen SWF dosyaları ve resimleri unloadMovie() 
fonksiyonuyla uzaklaştırılır. 

Kullanım Örnekleri 

Kullanım-1: Aşağıdaki örnekte üzerinde çalışılan Flash filmiyle aynı düzeyde 
bulunan arayuz.swf isimli Flash dosyası yüklenir ve sahnede yer alan den isimli movie clip 
nesnesiyle yer değiştirilir. Yüklenen SWF dosyası sahnede yer alan den isimli nesnenin sol 
üst köşe noktası koordinatlarına yerleştirilir. 

loadMovie(“arayuz.swf”, den); 
//Eş değer ifade: loadMovie(“arayuz.swf”, _level0.den); 

Kullanım-2: Aşağıdaki örnekte movie clip nesnesi ya da seviye belirteci çift tırnak 
içinde yazılmıştır. 

loadMovie(“arayuz.swf”, “den”); 
//Eş değer ifade: loadMovie(“arayuz.swf”, “_level0.den”); 

Kullanım-3: Aşağıdaki örnekte yalnızca seviye belirteci yazılmış olup SWF dosyası 
_level0’ın zaman doğrusuna doğrudan yüklenmektedir. 

loadMovie(“arayuz.swf”, _level0); 
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_levelN: Bir referans belirtecidir. _level belirteci kullanılmadan önce Flash 
oynatıcısına SWF dosyalarını yüklemek için loadMovieNum() fonksiyonu kullanılmalıdır. 
N sayısal bir değerdir ve Flash oynatıcısına yüklenecek SWF dosyasının seviyesi bildirilir. 

Flash oynatıcısına yüklenen ilk SWF dosyası otomatik olarak _level0 düzeyine 
yüklenir. _level0 düzeyine yüklenen SWF dosyasının zemin rengi (background color), 
çerçeve oranı (frame rate) ve çerçeve boyutu (frame size) alt sıralara yüklenen diğer SWF 
dosyaları için varsayılan değer olur. Daha sonra SWF dosyaları seviye değerlerine göre 
yığına alınır. 

loadMovieNum() fonksiyonuyla yüklenen her SWF dosyası için bir yığın numarası 
verilmelidir. Eğer daha önceden atanmış bir numara verilecek olursa yeni SWF dosyası 
öncekinin yerini alır. 

Ör: loadMovieNum(“deneme.swf”, 1); 

Aşağıdaki örnekte benimButonum adlı düğmeye tıklayınca den isimli movie clip 
nesnesine yüklenmiş olan deneme.swf dosyasının yerine image1.jpg resmi yüklenir. 

benimButonum.onRelease = function(){ 
 loadMovie(“image1.jpg”, den); 
}; 

Uygulama-6.11: Sahneye (stage) flv dosyası (flash video file) eklenmesi 

1- Öncelikle FLV uzantılı bir flash video dosyası temin ediniz. (Not: 
http://www.helpexamples.com/flash/video/ adresinden örnek flv dosyaları 
alabilirsiniz.) 

2- Temin ettiğiniz FLV dosyasının boyutlarına uygun genişlik ve yükseklikte bir 
flash çalışma sayfası açınız. 

3- Window → Library komutuyla kütüphane penceresini açınız. 

4- Pencerenin sağında bulunan simgeye ( ) tıklayınız ve şekil 6.23’teki menüyü 
açınız. Menüden New Video… komutuyla Video Properties penceresini açınız. 

 
Şekil 6.23: Flash kütüphanesine yeni 

bir video nesnesinin eklenmesi 

 
Şekil 6.24: Video simgesinin sahneye 

sürüklendikten sonra sahne içindeki görünümü 
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5- Video türü olarak Video (ActionScript-controlled) değerini seçiniz. Video ismi 
olarak oynat adını veriniz. Yaptığınız işlemi onaylayınız. 

6- Kütüphane penceresine eklenen oynat isimli video simgesini sahneye 
sürükleyiniz. 

7- Çalışma sayfasında yer alan Şekil 6.24’tekine benzeyen şekli seçiniz ve 
Properties panelinde <Instance Name> yazan yere filmim yazınız. 

8- Timeline panelindeki Layer 1 isimli katmanın adını video olarak değiştiriniz. 

9- video katmanını seçin ve Actions panelini açarak aşağıdaki kodu yazınız. 

var baglantim:NetConnection = new NetConnection(); 
baglantim.connect(null); 
var my_ns:NetStream = new NetStream(baglantim); 
filmim.attachVideo(my_ns); 
my_ns.play("0105.flv");// flv dosyası çağrılır. 

10- Flash filmini oynatarak sonucu izleyiniz. 

 Kendi FLV dosyalarınızı oluşturmak istiyorsanız MOV uzantılı QuickTime 
dosyalarını ya da WMV uzantılı Windows medya dosyalarını uygun bir kodlayıcıyla 
dönüştürmeniz gerekir. Bunun için “Flash Video Encoder” yazılımı kullanılır. Bu yazılımı 
temin ettiğinizde dönüştürmek istediğiniz medya dosyası program içerisine sürüklenir ve 
gerekli düzenlemeler yapıldıktan sonra medya dosyasının FLV uzantılı bir kopyası elde 
edilir. Bilgisayarınızın işlemci performansı ve video dosyasının boyutu dönüşüm süresini 
etkiler. 
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UYGULAMA FAALİYETİ 
  

İşlem Basamakları Öneriler 

1) Transistör devre elemanının beyzinden 
ve kolektöründen gelen akımın, emiter 
ayağından çıkışını gösteren bir canlandırma 
hazırlayınız.  

2) 1. adımda hazırladığınız canlandırmaya 
anahtar ekleyiniz ve anahtar yardımıyla 
devreyi açıp kapatınız. 

 

3) Bir olay tetiklendiğinde çalışmaya 
başlayan alarm canlandırması tasarlayınız. 
Alarm olarak kullanılacak ikaz sistemi 
alçak tondan yüksek tona doğru değişen 
kırmızı renk kullanacak olsun. 

 Alarm devresi sahnedeki bir düğmeye 
basınca çalışacak şekilde ayarlanabilir. 

4) Alarm canlandırmasına Flash’ın ses 
kütüphanesinden ya da varsa başka bir 
ortamdan ses ekleyiniz. Sesi renk tonuyla 
birlikte alçalıp yükselecek şekilde 
ayarlayınız. 

 

5) Yeni bir Flash sayfası açınız. Bir daire 
çiziniz ve daireyi çizdiğiniz katmanı 
seçerek Insert menüsünden Create Motion 
Tween komutunu veriniz.  

 20 kareden oluşan bir hareket 
canlandırması yapınız. 

6) Yeni bir sahne ekleyiniz.   Insert  Scene 

7) Eklenen sahnede dörtgen çiziniz ve 20 
karelik şekil değiştiren bir canlandırma 
hazırlayınız. Filmi çalıştırınız ve sahne 
eklemenin etkisini inceleyiniz. 

 

 Motion Tween 

 

 UYGULAMA FAALİYETİ 
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ÖLÇME VE DEĞERLENDİRME 
  

Bu bölümde Öğrenme Faaliyeti-6’da anlatılan konular hakkında bilginizi ölçmek 
amacıyla çoktan seçmeli sorular sorulacaktır. Soruları duyarlılıkla yanıtlamanız önerilir. 

A. ÖLÇME TESTİ 
 
1. loadMovie() komutu hakkında aşağıda söylenenlerden hangisi yanlıştır? 

A) FLV dosyası yüklemek için kullanılabilir.  
C) Bir fonksiyondur. 
B) SWF dosyası yükleyebilir.    
D) Resim dosyası yükleyebilir. 
 

2. Aynı katmanda birden fazla öğe varken yalnızca bir öğede hareket canlandırması 
hazırlanmak isteniyorsa ne yapılmalıdır? 
A) İlgili öğe seçilip Insert → Create Motion Tween komutunun verilmesi yeterlidir. 
B) İlgili öğe grup altına alınmalıdır. Grup içine girilip hareket canlandırması 

oluşturulmalıdır. 
C) İlgili öğe Movie Clip nesnesine dönüştürülmelidir. Ardından içine girilip hareket 

canlandırması oluşturulmalıdır. 
D) Diğer öğler kendi aralarında grup altına alınmalı, ardından ilgili öğe seçilip hareket 

canlandırması oluşturulmalıdır. 
 

3. Bir canlandırmaya eklenen sesin belli bir hareketle senkronize edilmesi istendiğinde 
ses hangi eylem türünde oynatılmalıdır? 
A) Event   
B) Stream  
C) Start   
D) Stop 
 

4. Bir kareye eklenen ses üzerinde değişiklik yapılması istendiğinde ne yapılmalıdır? 
A) Sesin eklendiği kare seçilip Properties panelinde Edit butonuna basılmalı ve Edit 

Envelope iletişim penceresi açılmalıdır. 
B) Sesin eklendiği kareye sağ tıklanıp Actions komutu verilmelidir. 
C) Sesin eklendiği kare seçilip Edit→Preferences komutu verilmelidir. 
D) Flash kütüphanesinden ilgili ses örneği bulunup üzerinde değişiklik yapılmalıdır. 
 

5. Timeline panelinde bulunan  simgesinin işlevi nedir? 
A) Zaman çizelgesine yeni anahtar kare eklenmek istendiğinde kullanılır. 
B) Zaman çizelgesine yeni katman ekler. 
C) Zaman çizelgesindeki katmanları düzenler. 
D) Zaman çizelgesi karelerinin görünümü değiştirilir. 

 ÖLÇME VE DEĞERLENDİRME 

alonso
Vurgu
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6. Şekil ipuçlarıyla ilgili söylenenlerden hangisi yanlıştır? 
A) Shape Tween canlandırmalarında kullanılır. 
B) Karmaşık şekil değişimlerinde değişim noktalarına eklenen ve değişimin daha 

gerçekçi oluşmasını sağlayan etiketlerdir. 
C) Eklenen her şekil ipucu bir harfle temsil edilir. 
D) Eklenen şekil ipuçları çalışma sayfasından kaldırılamaz. 
 

7. Ara kareleri Flash tarafından hazırlanmış bir hareket canlandırmasında hareketin daha 
gerçekçi yapılması için aşağıdaki yöntemlerden hangisi uygulanabilir? 
A) Film karelerinin sayısı artırılır. 
B) Yeni film kareleri eklenir. 
C) Filmin oynatıldığı alan boyunca uygun yerlere anahtar kareler eklenir. Anahtar 

karede yer alan şeklin yönünde düzeltmeler yapılır.  
D) Kılavuz yolu eklenir, öğelerin kılavuz yolunu izlemesi sağlanır. 
 

8. Bir Flash filminde yer alan ses klibine ses efekti nasıl eklenir? 
A) Window → Common Libraries → Sounds komutu verilir. 
B) Sesin yer aldığı film karesi seçilir. Properties panelinden Effect etiketinin 

yanındaki menüden istenen efekt seçilir. 
C) Properties panelinde Edit butonuyla Edit Envelope penceresi açılır, istenen etki 

oluşturulur. 
D) Flash’ta ses efekti ekleme olanağı yoktur. 
 

9. Bir filmin kare gösterim hızı aşağıdaki yöntemlerden hangisiyle ayarlanamaz? 
A) Edit →Preferences komutu verilir. 
B) Zaman çizelgesinde yer alan ve kare gösterim hızını gösteren yandaki alana tıklanır 

( ). Document Properties iletişim penceresi açılır. Frame Rate değeri 
ayarlanır. 

C) Modify → Document… komutu verilir. Frame Rate alanından değişiklik yapılır. 
D) Çalışma alanında boş bir yere tıklanır ve özellikler panelindeki Size butonuna 

tıklanır. Document Properties iletişim penceresi açılır. Frame Rate değeri ayarlanır. 
 

10. Motion Tween canlandırmasında anahtar karelerden birine yeni bir öğe eklendiğinde 
aşağıdakilerden hangisi olur? 
A) Herhangi bir değişim olmaz. 
B) Bir önceki anahtar kareyle yeni şeklin eklendiği anahtar kare arasında kesikli çizgi 

oluşur. 
C) Tüm karelerin üzerinde kesikli çizgi oluşur. 
D) Eklenen yeni şeklin de hareket canlandırmasına dâhil edilmesi gerektiği yönünde 

bir uyarı mesajı alınır. 
 

DEĞERLENDİRME 

Ölçme sorularının çoğunu doğru yanıtlamış ve eksiklerinizi gözden geçirmişseniz bir 
sonraki öğrenme faaliyetine geçebilirsiniz. 

alonso
Vurgu
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ÖĞRENME FAALİYETİ–7 
  

Bu öğrenme faaliyetinde ActionScript eylemlerini kullanarak karmaşık etkileşim 
uygulamaları hazırlayabieceksiniz.  
  

 
JavaScript diliyle temel düzeyde ifadelerin (karşılaştırmalar, cebirsel ve mantıksal 

işlemler, fonksiyonlar, vb.) nasıl yazıldığı hakkında bilgi edininiz. Daha önceki bilgisayar 
programcılığı deneyimlerinizi hatırlamaya çalışınız. 

 

7. KARMAŞIK ETKİLEŞİME GİRMEK 
Flash’ın ActionScript dili çok sayıda eylem grubu içermektedir. Bu eylem gruplarıyla 

ana filmdeki nesneleri düzenlemek, bazı koşulların doğruluğunu test etmek, kullanıcı girdisi 
oluşturmak, diğer filmlerden ve dosya tiplerinden bilgi almak, XML uygulamalarıyla web 
tabanlı veri sorgulaması uygulamaları gerçekleştirmek gibi pek çok eylem 
gerçekleştirilebilir. 

Bu tür script’ler yazmanın anahtarı, değişkenlerle (variables) ve ifadelerle 
(expressions) çalışmaktır. Bu öğeler yardımıyla, kullanıcılara daha doğrudan ve kişisel 
tepkiler veren siteler yaratabilirsiniz. 

ActionScript dili yazım biçimi olarak (syntax düzeni) JavaScript dilini andırır. 
Matematiksel ve mantıksal tüm işaretler ve değişkenler neredeyse JavaScript ile aynıdır. 

7.1. ActionScript Eylemlerini Kullanarak Çeşitli Uygulamalar 
Tasarlamak 

Uygulama-7.1: Veri girişine dayalı bir uygulamanın tasarlanması 

1- Yeni bir Flash filmi oluşturunuz. 

2- Araç kutusundan metin aracını (Text Tool) seçiniz. 

3- Çalışma alanında Yaş, Gün, Ay ve Yıl yazılarını içeren alt alta dizili dört ayrı 
metin kutusu oluşturunuz. 

4- Properties panelinde metin türü olarak Input Text değerini seçiniz ve Yaş, Gün, 
Ay ve Yıl yazılarını yazdığınız metin kutularının yanında boş metin kutuları 
oluşturunuz. 

 

Şekil 7.1: Metin kutusu için Input Text değerinin seçilmesi 

ÖĞRENME FAALİYETİ–7 

 AMAÇ 

 ARAŞTIRMA 
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5- Yaş kelimesini içeren metin kutusunun yanında oluşturduğunuz Input Text 
modundaki boş metin kutusunu seçiniz ve Properties panelinde Var: etiketinin 
yanındaki alana yas değişken değerini giriniz. 

6- Aynı şekilde Gün yazısının yanındaki metin kutusunu seçiniz ve Var: etiketinin 
yanındaki alana gun değişken değerini giriniz. Ay ve Yıl yazılarının yanındaki 
metin kutularına da sırasıyla değişken adı olarak ay ve yil değerlerini giriniz.  

7- Yas değişkenli boş metin kutusunu seçiniz ve metin alanına yazılacak değerin 
uzunluğunu kısıtlamak için Properties panelinde Maximum Characters: 
etiketinin yanındaki alana 2 değerini giriniz. 

 
Şekil 7.2: Input Text türündeki yas değişkenli metin kutusu üzerinde çeşitli değişikliklerin 

yapılması 

8- Diğer Input Text türündeki metin kutuları için de karakter sınırlaması 
yapabilirsiniz. yas’, gün’, ay ve yil değişkenli metin kutuları sayısal değerler 
içereceğinden yanlışlıkla alfa nümerik bir karakterin girişini engellemek için şekil 
7.2’de gösterildiği gibi Character düğmesine tıklayınız ve çıkan iletişim 
penceresinde Only radyo butonunu, ardından Numerals (0-9) değerini seçiniz. 

9- Ok aracını seçiniz ve çalışma alanında boş bir yere tıklayarak üzerinde çalıştığınız 
metin kutusunu seçili durumdan kurtarınız. 

10- Metin aracını seçiniz ve çalışma alanının uygun gördüğünüz bir yerine metin 
kutusunu çiziniz. 
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11- Properties panelinde metin türü olarak Dynamic Text değerini seçiniz. Var: 
etiketinin yanına sanslisayi değişken adını yazınız. 

 

Şekil 7.3: Dynamic Text türündeki metin kutusunda değişken adının belirlenmesi 

12- Window → Common Libraries → Buttons komutunu çalıştırınız ve çalışma 
alanına bir buton yerleştiriniz. 

13- Butonu seçiniz. Window → Acitons komutunu çalıştırınız ve karşınıza gelen 

eylem penceresinde  - View Options düğmesine tıklayarak Normal Mode 
kod yazım modunu seçiniz. 

14- Eylem penceresinin sol tarafında yer alan eylem listesinde Actions → Movie 
Control eylemlerini seçtikten sonra on deyimi üzerine çift tıklayarak kod yazım 
alanında on(release){ } deyiminin oluşmasını sağlayınız. 

 

Şekil 7.4: On deyiminin seçilmesi 

15- Yine Actions eylem grubunu seçiniz ve çıkan listeden Variables eylem grubunu 
seçiniz. Bir değişkene değer ataması gerçekleştirmek üzere set variable eylemine 
çift tıklayınız. 

16- Kırmızıyla vurgulanmış <not set yet> (henüz ayarlanmadı) kelimelerini 
görmeniz gerekir. Bu yazıyı seçiniz ve Variable (Değişken) alanına 
_root.sanslisayi değişken adını giriniz. 
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17- Value alanına Number(_root.yas) + Number(_root.gun) + Number(_root.ay) + 
Number(_root.yil) kodunu yazınız. Value alanının sağındaki Expression (İfade) 
onay kutusunu işaretleyiniz. Böylece bu dört değişkenin içeriğini de toplayacak 
matematiksel bir ifade oluşturmuş oldunuz. 

18- Control menüsünden Test Movie komutunu çalıştırın ve ilgili kutulara değerleri 
giriniz. 

19- Sonucu görmek için düğmeye tıklayınız. 

_root deyiminin sırrı: Burada _root (kök) deyimi atıfta bulunulan değişkenin 
hiyerarşik düzende çalışma alanının en üst noktasında olduğunu belirtmektedir. Yazmış 
olduğunuz kod düğme nesnesinin içinde yer aldığı için _root deyiminin yazılmaması 
durumunda değişkenler düğme nesnesinin içinde aranacaktır. Böylece Flash’a söz konusu 
değişkenleri düğme içinde değil, sahnenin kendi zaman doğrusunda aramasını sağlamış 
oluruz. 

 

Uygulama-7.2: Düğmelerin Movie Clip nesnelerinin üzerinde kullanılması 

Bazen movie clip nesnelerinin üzerine fare imleci geldiğinde imlecin el( )  şeklini 
almasını isteriz. Bunu movie clip nesnesinin içine işlevi olmayan ve gözükmeyen bir düğme 
nesnesi ekleyerek yapabiliriz. 

İşlem Adımları 

1- Çalışma alanına 100X100 px boyutlarında içi dolu bir kare çiziniz. 

2- Dörtgeni seçiniz ve alan isminde Movie Clip sembolüne dönüştürünüz. 

3- Nesneye çift tıklayınız ve içine giriniz. Layer 1 katmanının altında yeni bir 
katman oluşturunuz. 

4- Layer 1 katmanında çizmiş olduğunuz dörtgenin boyutlarında bir dörtgen çiziniz. 
Çizdiğiniz yeni dörtgeni seçiniz ve “buton” adında düğme sembolüne 
dönüştürünüz. 

5- Boş bir alana çift tıklayınız ve oluşturduğunuz alan isimli movie clip sembolünü 
seçiniz. ActionScript eylem penceresini açınız ve uzman modunda (Expert 
Mode) aşağıdaki kodu yazınız. 
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onClipEvent (mouseMove) { 
  x_poz = int(this._xmouse); 
  y_poz = int(this._ymouse); 
  if((down == true) && x_poz<=50 && x_poz >= -50 && y_poz>=-50 && y_down<=50){ 
  if(y_poz < y_down){ 
   //mouse yukarı gidiyor, dörtgen küçülüyor. 
   if(this._width>=50){ 
    this._width--; 
   } 
  } 
  else if(y_poz > y_down){ 
   //mouse aşağı gidiyor, dörtgen büyüyor. 
   if(this._width<=250){ 
    this._width++; 
   } 
  } 
 } 
 _root.hesapla(this._width, this._height); 
} 
onClipEvent(mouseDown){ 
 y_down = this._ymouse; 
       x_down = this._xmouse; 
 if(x_down<=50 && x_down >= -50 && y_down>=-50 && y_down<=50){ 
  down = true; 
 } 
} 
onClipEvent(mouseUp){ 
 down = false; 
} 
onClipEvent(load){ 
 _root.hesapla(this._width, this._height); 
 
} 

Uygulama Hakkında: Uygulama–7.2’yi çalıştırdığınızda oynatıcı ekranında 

karşınıza çıkan dörtgen üzerine fare imlecini getiriniz. İmleç el( )  şeklini alınca fareye 
tıklayınız ve yukarı aşağı yönde hareket ettiriniz. Dörtgenin belli bir aralıkta büyüyüp 
küçüldüğünü göreceksiniz. 

Fare imlecinin koordinatları ActionScript kodlarıyla denetlenmektedir. this deyimi 
kodun yer aldığı nesneyi yani alan isimli movie clip sembolünü ifade etmektedir. 
onClipEvent olay yöneticisi yalnızca Movie Clip nesnelerinde kullanılır. 

_xmouse özelliği fare imlecinin x değerini, _ymouse özelliği y değerini verir. 
mouseDown özelliği fare tuşuna basıldığı anı, mouseUp özelliği fare tuşunun bırakıldığı anı 
test ettirmek için kullanılır. Load özelliği flash filminin yüklendiği anı belirtir. 
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Uygulama-7.3:Bir projektör penceresinde grafiklerin ölçeklenebilmesinin 
sağlanması ve engellenmesi 

1- Yeni bir Flash belgesi açınız. 

2- 1. kareyi seçiniz ve çalışma alanına birkaç grafik öğesi ekleyiniz. 

3- 1. kare seçiliyken Window → Actions komutuyla eylem penceresini açınız. 

4- Normal Mode kod yazım modunu etkinleştiriniz. Eylem grupları listesinde 
Actions eylem grubunu ve ardından Browser Network eylem grubunu açınız. 

5- fscommand( ) deyimini çift tıklayarak kod alanına ekleyiniz. 

6- Çeşitli parametrelerin yer aldığı alanda Commands for stand-alone player 
(Bağımsız oynatıcı için komutlar) menüsünden allowscale[true/false] değerini 
seçiniz. 

 

Şekil 7.5: fscommand() deyiminin kullanılması ve allowscale[true/false] parametresinin 
seçilmesi 

7- Parameters alanına varsayılan olarak true değeri yazılır. File menüsünden 
Publish Settings komutunu çalıştırınız ve iletişim penceresinde Formats 
sekmesinden Windows Projector (.exe) onay kutusunu işaretleyiniz. 

8- File menüsünden Publish Preview komutuna geliniz ve çıkan listeden Projector 
değerini seçiniz. 
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9- Ekrana gelen pencerenin boyutlarını fare imleciyle pencerenin kenarlarından 
tutarak değiştiriniz. 

10- Pencereyi kapatınız ve çalışma alanına geri dönünüz. Commands for stand-alone 
player için fullscreen[true/false] değerini seçiniz. 

11- Filminizi yine projektör olarak çalıştırınız. 

12- Parameter alanına yazılan true değerini false olarak değiştirerek 6-11.adımları 
yineleyiniz ve farkı anlamaya çalışınız. 

 

Uygulama-7.4: El şeklindeki imlecin yok edilmesi 

Bir Boolean değişken olan useHandCursor değişkeni false değerine ayarlandığında 
istenen butonun el şekli alması engellenir. 

1- Yeni bir Flash belgesi oluşturunuz ve Window → Common Libraries → 
Buttons komutuyla Flash düğme kütüphane penceresini açınız. 

2- Listedeki düğme klasörlerinden dilediğinize sağ tıklayınız ve çıkan menüden 
Expand Folder komutunu veriniz. 

3- Sahneye iki adet düğme sürükleyiniz. 

4- Eklediğiniz düğmelerden birine ok aracıyla (Arrow Tool) tıklayınız ve seçiniz. 

5- Properties panelinde soluk gri tonla <Instance Name> yazan yere buton1 
yazınız. 

6- Eklediğiniz ikinci düğmeyi de seçin ve <Instance Name> yerine buton2 yazınız. 

7- Flash filminizin, düğmeleri eklediğiniz birinci karesini seçiniz. Aşağıdaki 
ActionScript kodunu Actions panelinde dikkatlice yazınız. 

buton1.useHandCursor = false; 
buton1.onRelease = buttonClick; 
buton2.onRelease = buttonClick; 
function buttonClick() { 
  trace(this._name); 
} 

8- Filminizi çalıştırınız. Fare imlecini buton1’e getirdiğinizde el şeklinin 
gözükmemesi gerekir. 
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7.2. Davranışlar 

Davranışlar, ActionScript kodu yazmaya gerek bırakmadan flash filmlerine etkileşim 
kazandıran bir yöntemdir. 

Uygulama-7.5: Davranış kullanarak bir video filmini kontrol etmek 

1- Yeni bir Flash belgesi açınız ve kütüphane (Library) penceresini açarak  
simgesine tıklayınız. 

2- Çıkan menüden New Video komutunu veriniz ve açılan Video Properties 
penceresinde Embedded (synchronized with Timeline) değerini seçiniz. 

3- Import düğmesine tıklayınız ve kütüphane listesine ekleyeceğiniz video dosyasını 
seçiniz. 

4- Listeden video simgesini seçiniz ve sahneye sürükleyiniz. 

5- Window → Common Libraries → Buttons komutuyla düğmeler penceresini 
açınız ve listeden playback rounded düğme grubuna sağ tıklayarak Expand 
Folder komutunu veriniz. 

6- Çıkan listeden play ve stop düğmelerini sahneye sürükleyiniz. 

7- Play düğmesini seçiniz ve Window → Behaviors komutunu veriniz. 

8- Davranış ekle (Add Behavior) simgesine tıklayınız ve çıkan listeden Embedded 
Video → Play değerini seçiniz. 

 

Şekil 7.6: Butona davranış eklenmesi 

9- Play video penceresi ekrana gelir. Pencere listesinden kamera simgesini seçiniz. 
Eğer sahneye eklediğiniz video görüntüsüne bir örnek adı (instance name) 
vermediyseniz, Instance Name penceresi ekrana gelir. 
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10- Örnek adı olarak video yazınız. İşlemlerinizi onaylayınız. Behaviors penceresine 
On Release | Play… davranışının eklenmiş olması gerekir. 

11- Stop düğmesini seçiniz ve 7.,8.,9. adımları tekrarlayınız. Ancak play davranışı 
yerine stop davranışını seçiniz. 

12- Filminizi oynatınız. Durdur ve oynat düğmeleriyle video filminin kontrol 
edildiğini görmeniz gerekir. Oynat düğmesini seçiniz ve Actions panelini açınız. 
Aşağıdakine benzer davranış kodunu görmeniz gerekir. 

on (release) { 
//Play video Behavior 
if(this.video._parent._currentframe == this.video._parent._totalframes){ 
  this.video._parent.gotoAndPlay(1); 
 } elske { 
  this.video._parent.play(); 
 } 
} 

Kodu kısaca açıklamak gerekirse; on(release) eylem yöneticisiyle fare tuşunun 
tıklama hareketi denetlenmektedir. Tuşa tıklanıp bırakıldığında if…else karşılaştırma 
yapısıyla video isimli videonun o andaki karesinin (currentframe) nerede olduğu kontrol 
edilir. Eğer o andaki kare son karedeyse (_totalframes toplam kare sayısını verir) 1. kareye 
gidilir ve video baştan (gotoAndPlay(1)) oynatılır. Aksi takdirde (else) video oynatılmaya 
devam eder. 

Uygulama-7.6: Davranış kullanarak JPEG resim yüklemek 

1- Yeni bir Flash belgesi ve ardından Davranışlar penceresini (Behaviors) açınız. 
Davranış ekleme ( ) simgesine tıklayınız. 

2- Çıkan menüden Movieclip → Load Graphic değerini seçiniz. 

3- Load Graphic penceresinde Enter the URL to the JPG to load metin kutusuna 
yüklemek istediğiniz JPG dosyasının adını yazınız. Filmi oynattığınızda resmin 
flash oynatıcısında gözükmesi gerekir. 

Uygulama Ödevi: Bir mp3 ses dosyasının denetlenmesine ilişkin uygulama 
geliştiriniz. Yaptığınız uygulamayı öğretmeninize gösteriniz (Mp3 dosyası davranış yoluyla 
yüklenip yine davranış yoluyla oynatılacak ve durdurulacaktır.) 
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UYGULAMA FAALİYETİ 
  

İşlem Basamakları Öneriler 

1) Yeni bir çalışma alanı açınız. Çalışma 
alanına 100 px genişliğinde, 50 px 
yüksekliğinde bir dikdörtgen çiziniz. Dörtgeni 
kutubuton adında düğme nesnesine 
dönüştürünüz. 

 

2) Kutubuton isimli buton nesnenizi seçiniz 
ve eylem (Actions) penceresini açınız. 
Aşağıdaki kodu yazınız. 

on (press) { 
startDrag("", false, left, top, right, bottom); 
} 
on (release) { 
stopDrag(); 
} 

 Eğer normal modda yazacaksanız, 
Actions-Button penceresini açtıktan 
sonra Actions → Movie Control 
eylem grubunun altında on deyimi, 
Movie Clip Control eylem grubunun 
altında da startDrag ve stopDrag 
deyimleri vardır. 

3) Kutubuton isimli nesnenizi seçiniz ve kutu 
isminde film nesnesine (Movie Clip) 
dönüştürünüz. 

4) Kutu isimli film nesnenizi seçiniz ve 
aşağıdaki kodu yazınız. 

onClipEvent (mouseMove) { 
left = 100; 
right = 200; 
top = _y; 
bottom = _y; 
} 

 Filminizi çalıştırınız. Üzerine gelip 
tıklandığında fare hareketine göre sağa 
sola kaydırılabilen bir dikdörtgen 
oluşacaktır. 

 4. adımda left ve right değişkenlerinin 
değerlerini değiştiriniz ve filminizi 
yeniden oynatınız. Bu işlemi birkaç 
defa yineleyiniz, değişkenlerin ne işe 
yaradığını anlamaya çalışınız. 

 

Şekil 7.7: (A) Scene 1 ana sahnesi altında yer alan kutu film nesnesi (B) Kutu film nesnesinin 
içine giriliyor. (C) Kutu film nesnesi altında yer alan kutubuton buton nesnesinin içine giriliyor. 

 UYGULAMA FAALİYETİ 
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ÖLÇME VE DEĞERLENDİRME 
  

Bu bölümde Öğrenme Faaliyeti-7’de anlatılan konular hakkında bilginizi ölçmek 
amacıyla çoktan seçmeli sorular sorulacaktır. Soruları duyarlılıkla yanıtlamanız önerilir. 

A. ÖLÇME TESTİ 
1. Bir metin kutusuna veri gönderilebilmesi için aşağıdaki işlemlerden hangisi 

yapılmalıdır? 
A) Metin kutusu seçilir ve dinamik (Dynamic) metin biçimine ayarlanır. Var alanına 

bir değişken değeri girilir. 
B) Metin kutusu durgun (Static) metin biçimine ayarlanır. Hypermetin alanına bir 

değişken adı yazılır. 
C) Metin kutusu giriş (Input) metin biçimine ayarlanır. Var alanına bir değişken değeri 

girilir. 
D) Bütün metin türlerine değer gönderilebilir. Bir işlem yapılmasına gerek yoktur. 

2. Movie Clip nesnelerinde eylem denetleyicisi olarak hangi deyim kullanılır? 
A) on() 
B) fscommand() 
C) setProperty() 
D) onClipEvent() 

3. Bir Flash filminde yüklenen toplam byte miktarını ölçmek için hangi komut kullanılır? 
A) getBytesLoaded()   
C) _framesloaded 
B) getBytesTotal()   
D) _totalframes 

4. Bir Flash filminde belli bir süreye kadar yüklenen kare sayısı hangi komutla 
hesaplanır? 
A) getBytesLoaded()   
C) _framesloaded 
B) getBytesTotal()   
D) _totalframes 

5. Aşağıdaki komutlardan hangisi yeterli sayıda kareden oluşan bir Flash filminin 20. 
kareden itibaren oynatılmasını sağlar? 
A) gotoAndStop(20)   
C) stop(20) 
B) play(20)    
D) gotoAndPlay(20) 
 

DEĞERLENDİRME 
 

Ölçme sorularının çoğunu doğru yanıtlamış ve eksiklerinizi gözden geçirmişseniz bir 
sonraki öğrenme faaliyetine geçebilirsiniz 

 ÖLÇME VE DEĞERLENDİRME 
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ÖĞRENME FAALİYETİ–8 
  

Bu öğrenme faaliyetinde zaman doğrusuna (timeline) ve çerçevelere (frames) bağlı 
kalmadan uygulama geliştirmeyi sağlayan yüksek seviyeli taşıyıcılar (containers) sunan 
ekranları öğreneceksiniz. 
  

 
Sunu hazırlama yazılımlarında sunuların nasıl hazırlandığını inceleyiniz. Ekranlar 

konusunda araştırma yapıp elde ettiklerinizi sunu hazırlama yazılımlarının çalışma ilkesiyle 
karşılaştırınız. 

8. EKRANLARLA ÇALIŞMAK 
Flash MX 2004 ile birlikte sunular, form tabanlı uygulamalar gibi karmaşık ve 

hiyerarşik Flash belgelerinin tasarlanması için yapısal tasarım bloklarından oluşan kullanıcı 
yönetim arayüzü içeren ekranlar (screens) geliştirilmiştir. 

Flash oynatıcılar, ekranlarla tasarlanmış filmleri oynatabilir. Flash ile ekran tabanlı iki 
tür belge oluşturulabilir: Multimedya sunusu ya da slayt gösterisi gibi sıralı içerik için uygun 
olan Flash Slayt Sunusu ve zengin internet uygulamaları içeren doğrusal olmayan form 
tabanlı uygulamalar. 

Ekranlar gerçekte birer movie clip nesnesidir ve dolayısıyla her bir ekran kontrol 
edilebilir. Form uygulamalarında varsayılan olarak tüm ekranlar gösterilirken slayt 
sunularında her bir ekran belli bir anda gösterilir. Ekranlar çeşitli olayları yayınlayabilir. 
Örneğin belli bir ekran gözükür kılındığında bir sesin çalınması ya da bir video dosyasının 
oynatılması gibi olaylar tetiklenebilir. 

8.1. Ekran Özelliğini Kullanan Yeni Bir Sunuyu Başlatmak 
 
Yeni bir slayt sunusu başlatmak için File → New komutuyla çıkan yeni belge 

penceresinde Flash Slide Presentation tercihi seçilirse şekil 8.2’de gösterilen tek slaytlı 
sunu ekrana gelir. 

Şekil 8.1: Yeni bir flash slayt sunusunun 
başlatılması 

 
Şekil 8.2: Tek slaytlı sununun tasarım 

görüntüsü 

ÖĞRENME FAALİYETİ–8 

 AMAÇ 

 ARAŞTIRMA 
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Window → Other Panels → Screens komutuyla ekran slaytları gizlenir ya da açılır. 
Her slayt ekranı kendi zaman doğrusuna sahiptir. 

Uygulama-8.1: Yeni slaytlar eklemek ve slaytlarla çalışmak 

1- Presentation ya da slide1 yazan ekrana sağ tıklayıp çıkan menüden Insert Screen 
komutunu veriniz. Aynı seviyede slide2 isminde yeni bir slayt eklenir. 

2- Presentaion, slide1 ve slide2 slaytlarını sırayla seçili duruma getiriniz ve her 
birinin çalışma alanına herhangi bir nesne grafik çiziniz ya da nesne ekleyiniz. 

3- Ctrl + Enter tuş ikilisiyle filminizi çalıştırınız. 2. slayt ekranına eklediğiniz grafik 
öğelerinin gözükmediğini fark etmiş olmalısınız. 

4- Slide1 slaydını farenin sol tuşuna tıklayarak seçiniz ve sağ tuşa tıklayın. Çıkan 
menüden Insert Nested Screen komutunu verin. Şekil 8.3’te görüldüğü gibi 
slide1 ve slide2 slaytları arasına slide3 isimli biraz iç tarafa doğru girintili yeni bir 
slaytın eklenmiş olması gerekir. 

5- Yeni eklediğiniz slaytı seçin ve araç çubuğundan metin aracını seçiniz (Text Tool 
- A). Çalışma alanına Merhaba yazınız. 

6- Açtığınız belgenin isminin yazılı olduğu sol üst köşenin hemen altında  
yazılı yere tıklayarak zaman doğrusunu gözükür kılınız. 

7- Slide3 isimli slayt ekranına yazmış olduğunuz yazıyı seçiniz. Insert → Timeline 
→ Create Motion Tween komutuyla hareket canlandırması oluşturunuz. 

8- 30. kareye gidiniz ve sağ tıklayınız. Çıkan menüden Insert Keyframe komutunu 
veriniz. 

9- 30. karede yer alan yazıyı çalışma sayfasının dilediğiniz bir noktasına taşıyınız. 
Filminizi çalıştırınız. 

 
Şekil 8.3: Yuvalanmış slayt ekleme 

 
Şekil 8.4: Slide3 isimli slayda hareket canlandırması ekleme 
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Sonuç olarak slide1’in altına yuvalanmış (Nested) olarak eklenen slide3’ün içeriği 
gözükürken slide1 ile aynı seviyede yer alan slide2’nin içeriği gözükmez. 

Eğer sonraki slaytlara geçerken önceki slaytların da içeriğini görmek istiyorsanız ilgili 
slayt grubunun üstünde yer alan slayt seçilir (Şekil 8.3’te presentatio” ve slide1 isimli 
slaytlar) ve Parameters panelinde overlayChildren değeri true olarak ayarlanır. 

8.2. Sunuya Harici İçerik Yüklemek  

Sunuya eklenen her bir slaydın contentPath özelliği bulunmaktadır. Bu özellik 
yardımıyla slaytlara harici SWF dosyaları ya da resim eklemek mümkündür. Böylece her bir 
slaydın ayrı bir SWF dosyası gibi davranması sağlanabilir. 

Bu özellik, Flash yazılımının Professional sürümlerinde bulunmaktadır. 

Örneğin üç ayrı konuşmacının her biri için bölümlern ayrıldığı slayt sununuzun 
olduğunu varsayınız. Her bir konuşmacıdan kendileri için ayrı bir sunu hazırlamalarını 
istediğinizi düşününüz. Siz, sonradan ekleyeceğiniz bu üç ayrı sunuyu içerisinde 
barındıracak ana slayt sunusunu hazırlarsınız. Ana slayt sunusunun şekil 8.5’te resmedildiği 
gibi düzenlendiğini varsayalım. 

Şekil 8.5: Üç ayrı konuşmacının 
sunularını tutan ana sunu 

 

Şekil 8.6: Slayt parametrelerinin ayarlanması 

Her bir konuşmacı için ayrılmış slaytların contentPath özelliği kullanılarak ya da 
ActionScript kodu yazılarak SWF dosyaları eklenir. Contentpath değeri ayarlamak 
istediğiniz slayt seçilir ve Parameters paneli açılır. Şekil 8.6’da gösterildiği gibi yüklenmek 
istenen dosyanın yolu contentPath satırına yazılır. 

Bir diğer yol ActionScript kodu yazmaktır. Örneğin Anasunu isimli sunu seçilir ve 
Actions paneli açılır. Kod alanına aşağıdaki gibi kod dizisi yazılır. 

konusmaci_1.contentPath = “sunu1.swf”; 
konusmaci_2.contentPath = “sunu2.swf”; 
konusmaci_3.contentPath = “sunu3.swf”; 
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Böyle bir uygulama yapıldığında Anasunu ve giriş isimli sunuların içeriği gözükür ve 
diğer sunular altta kalır. ActionScript denetimiyle bu sorun çözülebilir. Bu çözüme dair 
adımlar, Uygulama-8.2’de gösterilmiştir. 

Uygulama-8.2: Sunuya harici içerik eklemek 

1- Yeni bir slayt gösterisi başlatınız. Şekil 8.5’te görüldüğü gibi 4 adet slayttan 
oluşan bir slayt sunusu hazırlayınız. 

2- Anasunu isimli slaydı seçiniz ve çalışma alanına başlık için uygun bir metin 
yazınız. 

3- Giriş isimli slaydı seçiniz ve aşağıdaki kodu yazınız. 

on(mouseUp){ 
 gotoNextSlide(); 
} 

4- Giriş isimli slayda hazırlayacağınız sununun içeriğine uygun bir giriş yazısı 
ekleyiniz. 

5- Konusmacı_1 isimli slaydı seçiniz ve aşağıdaki kodu ekleyiniz. 

on(reveal){ 
 this.contentPath= “sunu1.swf”;//Buraya elinizdeki bir dosyayı ekleyin! 
} 
on(mouseUp){ 
 gotoNextSlide(); 
} 

6- Konusmacı_2 isimli slayt için de 5. adımı uygulayınız. Contentpath değeri için 
“sunu2.swf” yazınız. 

7- Konusmacı_3 isimli slayt için de 5. adımı uygulayınız. Gotonextslide() komutu 
yerine gotoSlide (“Anasunu”) komutunu, contentPath için sunu3.swf yazınız. 

Bu sunuyu çalıştırdığınızda Anasunu ve giriş isimli sunuların içeriği ekrana gelir. 
Giriş sunusuna fare hareketini izleyen eylem yöneticisi eklediğiniz için fare imlecini sunu 
içindeki bir nesne üzerine getirdiğinizde el şeklini alır. Tıkladığınız anda konusmaci_1 adlı 
sunuya geçilir. Eğer ilerleme işleminin slaytların üzerine tıklayınca gerçekleşmesini 
istemiyorsanız her bir slaydın üzerine buton ekleyebilirsiniz. Slayt ekranları için yazdığınız 
fare izleyicisi kodunu butonlara eklediğinizde aynı işlem gerçekleşir. 

Her bir slayt için film gezginini (Movie Explorer) kullanabilir ve slaytların zaman 
doğrusu karelerinde hangi öğelerin olduğunu görebilirsiniz. Window → Movie Explorer 
komutuyla film gezgini penceresini açınız. Her bir slayt için film gezgini penceresinde yer 

alan butonlara ( ) sırayla tıklayacak olursanız gezgin 
penceresi içerisinde ilgili öğeler listelenir. 
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Uygulama-8.3: Sunuya ses yüklemek ve kontrol etmek 

1- Uygulama-8.2’de tasarladığınız sunuyu açınız. 

2- Konusmaci_3 slaydını seçiniz ve ActionScript kodunu siliniz (contentPath ve 
gotoSlide kodları silinecek). 

3- Flash filminizin kütüphanesine eklemek üzere bir ses dosyası yükleyiniz. Bu işlem 
için File → Import → Import to Library komutunu çalıştırınız. Açılan 
pencereyi kullanarak bilgisayarınızdan dilediğiniz formatta (MP3, WAV, AIF) bir 
ses dosyası seçiniz. 

4- Kütüphane penceresi açık değilse açınız ve listeye eklenen ses simgesine sağ 
tıklayınız. Çıkan menüden Linkage komutunu çalıştırınız. 

5- Açılan Linkage Properties penceresinde Linkage: değeri olarak Export for 
ActionScript değerini seçiniz. 

6- Identifier: alanına ses yazınız. 

 
Şekil 8.7: Kütüphaneye ses dosyasının yüklenmesi ve değişken adı atanması 

7- Konusmacı_3 slaydına 3 adet düğme eklemek için Window → Common 
Libraries → Buttons komutunu çalıştırınız. 

8- Flash 8 için Playback rounded düğme grubunu açınız ve oynatma, durdurma, 
ileri sarma düğmelerini sahneye ekleyiniz. 

9- Oynatma düğmesine değişken adı olarak play_btn, durdurma düğmesine değişken 
adı olarak stop_btn ve ileri sarma butonuna değişken adı olarak ileri_btn 
değerlerini giriniz. 
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10- Konusmacı_3 slaydının zaman doğrusunu açınız ve birinci kareye Actions 
panelinde aşağıdaki kodu yazınız. 

var song_sound:Sound = new Sound(); 
song_sound.attachSound("ses"); 
play_btn.onRelease = function() { 
  song_sound.start(); 
}; 
stop_btn.onRelease = function() { 
  song_sound.stop(); 
}; 
ileri_btn.onRelease = function(){ 
 gotoSlide("Anasunu"); 
} 

11- Filminizi çalıştırınız. Konusmacı_3 slaydına gelindiğinde oynat ve durdur 
düğmelerini kullanarak sesin nasıl kontrol edildiğini görünüz. İleri düğmesine 
tıkladığınızda sununun başına dönmeniz gerekir. 

 



 

 122

UYGULAMA FAALİYETİ 
  

İşlem Basamakları Öneriler 

1) Yeni bir slayt sunusu başlatınız ve sunuya 
üç tane slayt ekleyiniz. 

 Ana Slayt : presentation 

      1. Slayt     : slayt1 

      2. Slayt     : slayt2 

3) Ana slaydı seçiniz ve çalışma alanının 
üstüne slaydınızla ilgili bir başlık yazısı 
yazınız. 

 

4) 1. slaydı seçin ve çalışma alanına örnek bir 
yazı ekleyiniz. Diğer iki slayt ekranına da 
örnek birer yazı ekleyiniz. Yazıların aynı 
hizada olmamasına dikkat ediniz. 

Slaytlar arasında ilerledikçe önceki 
slaydların içeriğini görmek için her bir 
slaydın içeriğini farklı bir konuma 
yerleştiriniz. 

5) Ana slaydı seçin ve Parameters panelini 
açın. Overlaychildren parametresini true 
değerine ayarlayınız. 

 

6) 1. ve 2. slaytlara aşağıdaki kodu ekleyiniz. 

on(mouseUp){ 
  gotoNextSlide(); 
} 

Filminizi oynattığınızda sonraki 
slaytlara ilerledikçe bir önceki slayt 
gözükecektir. 

 

 UYGULAMA FAALİYETİ 
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ÖLÇME VE DEĞERLENDİRME 
  
 
Bu bölümde Öğrenme Faaliyeti-8’de anlatılan konular hakkında bilginizi ve 

yeteneğinizi ölçmek amacıyla doğru(D)-yanlış(Y) türü sorular sorulacaktır. Soruları 
duyarlılıkla yanıtlamanız önerilir. 

 
A. ÖLÇME TESTİ 
 
1. Ekranlar zaman doğrusundan ve çerçevelerden (frame) bağımsız çalışma ortamı 

sağlar………. 
2.  
3. Ekranlar yardımıyla slayt sunusu gibi sıralı içerik uygulamaları yapılabilir………… 

4. Bir sununun slaytlarını ActionScript kodlarıyla kontrol etmek mümkün 
değildir………… 

5. Gotoframe() komutu slaytlar arasında gezinmeyi sağlayan bir fonksiyondur………… 
 

6. Contentpath parametresi slaytlara içerik yüklemek amacıyla kullanılır………… 
 

 
7. Overlaychildren parametresi alt slaytlara geçişte önceki slaytların gözükmesini ya da 

kaybolmasını sağlar………… 
 

8. Gotonextslide() fonksiyonu ilgili slaydın bir sonraki çerçevesine (frame) gitmeyi 
sağlar………… 

 
 

9. Ekranlara eklenen her bir slayt movie clip nesnesidir………… 
 

10. Playhidden parametresi false olarak ayarlandığında ilgili slayt gizlense bile içeriği 
oynatılmaya devam eder………… 

 
 

11. On() eylem yöneticisi slayt ekranlarında kullanılamaz………… 
 

 

DEĞERLENDİRME 

Ölçme sorularını doğru yanıtlamış ve eksiklerinizi gözden geçirmişseniz modül 
değerlendirmesine geçebilirsiniz. 

 ÖLÇME VE DEĞERLENDİRME 
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MODÜL DEĞERLENDİRME 
Bu bölümde tüm öğrenme faaliyetlerinde anlatılan konular hakkında bilginizi ölçmek 

amacıyla çoktan seçmeli sorular sorulacak ve performans testi uygulanacaktır. Soruları 
duyarlılıkla yanıtlamanız ve performans testini uygulamanız önerilir. 
 
A. ÖLÇME TESTİ 

1. Color Mixer panelinin işlevi nedir? 
A) Metnin yazı tipiyle ilgili ayarlar yapılır. 
B) Seçili nesnenin özellikleri değiştirilir. 
C) Grafik öğelerinin dolgu ve çerçeve renkleri belirlenir. 
D) Gradyent etkileri oluşturulur ve daha hassas renk seçimi yapılır. 

2. Fırça aracının (Brush Tool - ) Paint Behind niteliği nasıl bir boyama etkisi 
oluşturur? 
A) Herhangi bir grafik öğesinin üzerinden geçilen bölgesini dolgu rengine boyar. 
B) Herhangi bir grafik öğesinin ya da çalışma alanının yalnızca iç kısmını boyar. 
C) Herhangi bir grafik öğesinin arkada kalan tarafını boyar. 
D) Herhangi bir grafik öğesinin yalnızca dolgu rengini boyar. 

3. Fare imleci, hangi durumda  şeklini alır? 
A) Fare imleci bir grafik öğesinin keskin köşeli kısmına yaklaştırıldığı zaman 
B) Fare imleci bir grafik öğesinin düz ya da yumuşak eğimli bir köşesine 

yaklaştırıldığı zaman 
C) Fare imleci grup altına alınmış bir nesnenin köşesine yaklaştırıldığında 
D) Seçili bir grafik öğesi taşınacağı zaman 

4. 1. kare üzerinde birkaç öğe yer almaktadır. 20. kareye sağ tıklanıp Insert Keyframe 
komutu verildiğinde aşağıda anlatılanlardan hagisi gerçekleşir? 
A) 20. kare de dâhil 1-20 arası tüm kareler aynı öğelerle doldurulur. 
B) 1-19 arası kareler aynı öğelerle doldurulur. 20. karede bağımsız içi boş bir sayfa 

oluşturulur. 
C) 1-19 arası kareler aynı öğelerle doldurulur. 20. karede bağımsız ve içinde aynı 

öğelerin olduğu bir sayfa oluşturulur. 
D) 1. kare hariç 20. kareye kadar tüm karelere boş sayfalar yerleştirilir. 

5. Aşağıdaki eylem yöneticilerinden hangisi bir düğmenin klavyenin yukarı tuşuna tepki 
göstermesini sağlar? 
A) onClipEvent(load)     
C) on(keyPress "<Up>") 
B) on(release)      
D) onClipEvent(keyUp) 

MODÜL DEĞERLENDİRME 

alonso
Vurgu
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6. Hazırlamış olduğunuz düğmeye fareyle tıklandığında şekil değiştirmesini istiyorsanız 
aşağıdakilerden hangisi yapılır? 
A) Hit karesine yeni şekil çizilir. 
B) Down karesine yeni şekil çizilir. 
C) Over karesine yeni şekil çizilir. 
D) On (dragOver) gotoAndStop (2); deyimi buton nesnesine eklenir. 

7. Aşağıdakilerden hangisi Shape Tween tekniğinin özelliği değildir? 
A) Şekil değişikliğinin yapılması istenen canlandırmalarda kullanılır. 
B) Doğrusal hareket canlandırmalarında bu teknik kullanılabilir.  
C) Aynı katmanda birden fazla öğe varken ilgili film karesi seçilip Tween çeşidi 

olarak Shape seçilirse tüm öğeler grup altına alınır. 
D) Shape Tween olarak ayarlanan bir canlandırmada, anahtar karelerden birine başka 

bir şekil çizilecek olursa canlandırmaya çizilen yeni şekil de dâhil edilir. 

8. Aşağıdaki HTML etiketlerinden hangisinin Flash filmiyle bir ilgisi yoktur? 
A) <object>  
B) <table>  
C) <param>  
D) <embed> 

9. Bir metin kutusuna veri girilebilmesi için aşağıdaki işlemlerden hangisi yapılmalıdır? 
A) Metin kutusu seçilir ve dinamik (Dynamic) metin biçimine ayarlanır. Var alanına 

bir değişken değeri girilir. 
B) Metin kutusu durgun (Static) metin biçimine ayarlanır. Hypermetin alanına bir 

değişken adı yazılır. 
C) Bütün metin türlerine değer gönderilebilir. Bir işlem yapılmasına gerek yoktur. 
D) Metin kutusu giriş (Input) metin biçimine ayarlanır. Var alanına bir değişken 

değeri girilir. 

10. Uzunca bir canlandırmanın herhangi bir karesinde kullanılan prevFrame() komutu 
için aşağıda söylenenlerden hangisi doğrudur? 
A) Bir önceki film karesine gidilir. Film durdurulur. 
B) Bir önceki film karesine gidilir. Film o kareden devam eder. 
C) Bir önceki film karesine gidilir ve canlandırma geriye doğru oynatılır. 
D) Parantezleri içine herhangi bir değer yazılabilir. 

alonso
Vurgu
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B. PERFORMANS TESTİ 

Bu kısımda sizlerden bir uygulamayı baştan sona adım adım yapmanız istenecektir. 
Bu amaçla şekil 9.1’de gösterilen elektrik devresi örnek olarak ele alınmıştır. 

 

Şekil 9.1: Performans testi uygulama canlandırmasının genel görünümü (Devre açık) 

Devrede yer alan grafik nesneleri tablo 9.1’de listelenmiştir. Sizden bu şekillerin 
birebir aynılarının hazırlanması beklenmemektedir. Kendi yaratıcılığınız ve hayal gücünüze 
göre benzer şekiller hazırlayabilirsiniz. 

Tablo 9.1: Performans uygulamasında yer alan şekiller ve işlevleri 

Nesneler Türü Şekli Açıklama 
Üreteç Movie Clip 

 

Üreteç devre elemanını 
oluşturmak için çizilmiştir. 

Ampul iletken 
gövdesi 

Movie Clip 

 

İletime geçen ampulün 
lamba kısmı sarı renk alacağı 
için gövde ayrı çizilmiştir. 

Çalıştırma 
Butonu 

Buton 

 

Devreyi açmak için 
kullanılır. 

Durdurma 
Butonu 

Buton 

 

Devreyi kapatmak için 
kullanılır. 
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Sönük Lamba Movie Clip 

 

 

Yanan Lamba Movie Clip 

 

 

Anahtar Tablası Movie Clip 

 

 

Anahtar Kolu Movie Clip 
 

 

Elektron Movie Clip 
 

Üretecin negatif kutbundan 
pozitif kutbuna negatif 
elektrik yükünün aktığını 
göstermek için kullanılır. 

 (Süre 80dk.) 

1- Şekil 9.2’de gösterilen her biri 50 kareden oluşan katmanları oluşturunuz. 

 

Şekil 9.2: Katmanlar 

2- İletken tel, üreteç ve anahtar tablası şekillerini “sabit resimler” katmanına çiziniz. 

3- Elektron nesnesinin üretecin eksi kutbundan artı kutbuna hareketini canlandırmak 
için “elektron” isimli katmanın üzerinde bir hareket katmanı oluşturunuz. Hareket 
katmanında elektron nesnesinin izlemesini istediğiniz yolu çiziniz. 

4- “Elektron” katmanının 11., 43. ve 50. karelerine anahtar kare ekleyin. 1. kareden 
11. kareye kadar elektron sabit kalacak ve gözükmeyecek. 11. kareden 43. kareye 
kadar elektron kılavuz yolu boyunca hareket edecek. 43. kareden 50. kareye kadar 
elektron sabit kalacak ve gözükmeyecek. 

5- Ampul ve ampul gövdesini “ampul” isimli katmana çiziniz. 11. ve 46. karelere 
anahtar kare ekleyiniz. 1. kareden 11. kareye ve 46. kareden 50. kareye kadar 
sönük lamba sembolünü, 11. kare de dâhil olmak üzere 46. kareye kadar yanan 
lamba sembolünü kullanınız. 
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6- Devreyi açma ve kapama düğmelerini butonlar isimli katmana yerleştiriniz. 

7- Mesaj isimli katmanda 1. kareden 11. kareye kadar, canlandırmanın sol üst 
köşesinde devre açık olduğundan elektronlar kaynağın pozitif kutbuna gidemez 
mesajı yer alsın. 11. kareden 50. kareye kadar devre kapandığından elektronlar 
kaynağın pozitif kutbuna erişebilir mesajı yer alsın. 

 

Şekil 9.3: Devrenin kapalı durumundan bir kesit 

8- Kol isimli katmana anahtar kolunu yerleştiriniz. 1. kareden 50. kareye kadar bir 
hareket canlandırması (Motion Tween) oluşturunuz. 11., 44. ve 50. karelere 
anahtar kare ekleyiniz. 1. kareden 11. kareye kadar anahtar kolunun devreyi 
kapatmasını canlandırınız. 11. kareden 44. kareye kadar kol kapalı konumda 
kalacak. 44. kareden 50. kareye kadar kolun açılmasını canlandırınız. 

9- Eylemler isimli katmanın 1. karesine stop() kodunu, 43. karesine 
gotoAndPlay(11) ve 50. karesine gotoAndPlay(1) kodunu yazınız. 

10- Devreyi çalıştırma ve kapama düğmelerine aşağıdaki kodları yazınız. 

Çalıştırma Butonu Kapama Butonu 
on (release) 
{ 
  gotoAndPlay(3); 
} 

on (release) 
{ 
  gotoAndPlay(44); 
} 
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DEĞERLENDİRME ÖLÇÜTLERİ 

3 2 1 0 
1.  Movie Clip nesnelerini hazırlamak.     
2.  Düğmeleri hazırlamak.     
3.  Düğmelere, ilgili eylemleri eklemek.     
4.  Elektron için hareket katmanını ve hareket kılavuzunu 

oluşturmak 
    

5.  Elektronun hareketini canlandırmak.     
6.  Anahtar kolun hareketini canlandırmak.     
7.  İlgili mesajları yazmak.     
8.  Devrenin çalışma durumuna göre ilgili lambaları 

yerleştirmek. 
    

9.  Tüm nesneleri düzgün bir şekilde yerleştirmek.     
10.  Eylemleri ilgili karelere yazmak.     

Toplam  
 

DEĞERLENDİRME 

Ölçme testinden en az 8 soruyu yanıtlamış ve performans testinden de en az 24 puan 
almışsanız modülü başarıyla tamamlamışsınızdır. İstenen sonucu alamamışsanız eksik 
olduğunuz noktaları tekrarlayınız. 
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CEVAP ANAHTARLARI 
ÖĞRENME FAALİYETİ-2 CEVAP ANAHTARI 

 
1 C 
2 A 
3 D 
4 C 
5 B 
6 A 
7 D 
8 D 
9 A 

10 C 
 

ÖĞRENME FAALİYETİ-3 CEVAP ANAHTARI 
 

1 B 
2 A 
3 D 
4 C 
5 D 
6 B 
7 B 
8 D 
9 C 

10 A 
11 B 
12 C 
13 D 
14 A 
15 B 

 
ÖĞRENME FAALİYETİ-4 CEVAP ANAHTARI 

 
1 B
2 C 
3 A 
4 D 
5 C 

 

CEVAP ANAHTARLARI 
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ÖĞRENME FAALİYETİ-5 CEVAP ANAHTARI 
 

1 D 
2 B 
3 C 
4 A 
5 C 
6 D 
7 C 
8 A 
9 A 

10 B 
  

 
ÖĞRENME FAALİYETİ-6 CEVAP ANAHTARI 

1 A 
2 C 
3 B 
4 A 
5 D 
6 D 
7 C 
8 B 
9 A 

10 B 
 

ÖĞRENME FAALİYETİ-7 CEVAP ANAHTARI 
 

1 A 
2 D 
3 B 
4 C 
5 D 
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ÖĞRENME FAALİYETİ-8 CEVAP ANAHTARI 
 

1 D 
2 D 
3 Y 
4 Y 
5 D 
6 D 
7 Y 
8 D 
9 Y 

10 Y 
 

MODÜL DEĞERLENDİRME CEVAP ANAHTARI 
 

1 D 
2 C 
3 A 
4 C 
5 C 
6 B 
7 C 
8 B 
9 D 

10 A 
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SÖZLÜK 
Türkçe      İngilizce 

Araçlar      Tools 

Belge – Sayfa     Document 

Çalışma Alanı     Stage 

Çerçeve     Frame 

Davranış     Behaviors 

Düğme - Buton     Button 

Eylem      Action 

Hareketli Canlandırma    Motion Tween 

Kare Hızı     Frame Rate (Fps) 

Katman      Layer 

Mask      Maske 

Olay      Event 

Oluştur      Create 

Özellik Sorgulayıcı     Property Inspector 

Sahne      Scene 

Seçenekler     Options 

Sınıf      Category 

Şekil Canlandırma    Shape Tween 

Yayın      Publish 

Zaman Çizelgesi    Timeline 

 

SÖZLÜK 
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